New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Why is it such a battle to get the Rift S to connect?

I plug it in, usb then display port, then i start up the software. Then either the USB or display port is apparently not working. So i unplug the one it says doesn't work, plug it back in, then the other one fails. Rinse and repeat rinse and repeat. Most times when I do get it working, I'm stuck infinitely in the three dot loading screen. Very occasionally it works, and even fewer times it works without about an hour of plugging and unplugging. Am I doing something wrong or is the software/hardware just that bad?

Comments

  • KNP54KNP54 Posts: 294
    Nexus 6
    It might be the OVRService that crashed. Have you tried restarting the OVRService (in the services tab of the task manager) when that happens?
    Specs: Delidded i7-8086k @ 5.0 GHz all cores, NZXT X52 cooler, 32GB G.Skill 3200MHz, ASRock Z370 Gaming-ITX/ac, Asus GTX 1080 Strix, Corsair SF600 platinum, Samsung 970 EVO M.2 NVMe 1TB, Samgung 850 EVO 500GB + 840 EVO 500GB in raid0, Seagate Ironwolf 10TB, Louqe Ghost S1, Asus PB287Q 3840x2160 @ 60Hz, Samsung SyncMaster 226BW 1680x1050 @ 60Hz. Oculus Rift S.
  • M1stwalk3rrM1stwalk3rr Posts: 2
    NerveGear
    edited October 10
    Should I just restart that? or all oculus related services? Whenever it gets really bad I tend to close all related oculus services (in the task manager) and the application then either refuses to start or refuses to quit
  • OculusSupportOculusSupport Posts: 1,058 Oculus Staff
    Hi @M1stwalk3rr We would like to take a look into your case, if you haven't already, please gather your diagnostic logs using the steps here and create a ticket here. - Clint
  • dill73dill73 Posts: 2
    NerveGear
    @M1stwalk3rr Go I to you options and dig down into the advanced. Find your USB port and set it to never turn off. You may need a restart on PC & Headset after that.
  • dill73dill73 Posts: 2
    NerveGear
    Geeze, go into power options...
  • VRforVendettaVRforVendetta Posts: 3
    NerveGear
    You're not the only one, got the exact same issue. Seems to get worse as well. Weird thing is, if it works it works. People even said to get an external powered USB hub, but still issues. Now it also started to get tracking issues when it works or static. You're spending more time replugging and talking to customer service than actually playing. Let me know if you fixed it... pretty please.
Sign In or Register to comment.