New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Rift S Crashing and Disconnecting

ecki386ecki386 Posts: 8
Brain Burst
edited October 10 in Support
Posting this again in the support section.

My headset was working perfectly fine for 4 days, and now after about 5-10 minutes of playing, my Rift S crashes. My screen will randomly go black, make a high-pitched beeping noise, the little white light turns orange, and then I start hearing static. After that, I'll get a notification saying my DisplayPort isn't connected, and then it will say the DisplayPort is connected again. Now I have to restart the Oculus software then plug my headset back in before it starts working again.

After looking for a fix, I've tried all of these methods and none of them work:

  • Repairing/Reinstalling the Oculus software
  • Reinstalling SteamVR + my games
  • Checking if everything is up to date (GPU Drivers, Oculus software, SteamVR, Windows 10) and they are
  • Going on the Oculus settings and enabling Public Test Channel
  • Turning off my NVIDIA In-Game Overlay
  • Tried every other USB 3.0 port on my PC
  • Disabled USB selective suspend setting in the Windows Power Options
  • Unplugging all of my other USB devices
  • Checked that the DisplayPort wire connection in the headset is connected properly
  • Ran the Oculus software in Administrator
  • Ending OculusDash.exe and OVRServer_x64.exe in task manager
  • Turned off Power Saving mode in Device Manager for all of my USB ports

These are my specs:

GPU : RTX 2070

CPU: AMD Ryzen 7 3700X

Memory: 32GB DDR4-3600

Motherboard: MSI B450 Tomahawk Max

Comments

  • RedRizlaRedRizla Posts: 8,009 Valuable Player
    edited October 11
    Do you use a Display port extension cable by any chance? Try using it without the extension cable if you use one. Have you also tried reinstalling your Nvidia graphics card driver?
  • ecki386ecki386 Posts: 8
    Brain Burst
    RedRizla said:
    Do you use a Display port extension cable by any chance? Try using it without the extension cable if you use one. Have you also tried reinstalling your Nvidia graphics card driver?
    I don't use a DisplayPort extension cable, and I tried reinstalling my GPU drivers. I'm still experiencing crashes.
  • BigSquirmyBigSquirmy Posts: 1 Oculus Start Member
    I had this happening to me today. It took forever but i finally figured out what was doing it. For me, its something to do with the audio which is weird because i wasn't even using audio at the time. I was doing some development. Anyways, I swapped my audio to my headphones and disabled oculus audio in windows. It hasn't crashed since. Before that it was doing it every 10 to 15 minutes. 
  • surlylemursurlylemur Posts: 1
    NerveGear
    Hey If this is still happening I had the exact same problem seemingly around the same time after an update.

    It would crash anywhere between 15 minutes and an hour. Support were helping me but then went silent.

    My solution (slightly annoying but worked) was to buy a powered USB 3.0

    I can't seem to post links yet so I bought a USB Hub 3.0 Powered RSHTECH Aluminum 4 Port USB Splitter Portable Data Hub 5V/2A off amazon. Haven't had a crash since so I'm guessing the update might of changed the way the Rift S handles power and causes it to crash with certain setups.

    Hope that helps.


  • Neo_33Neo_33 Posts: 38
    Brain Burst
    edited October 22
    Have you tried other DisplayPort outputs on your graphics card? Maybe one is going bad. 

    Edit: after reading more sounds like you might not be getting enough Power from the USB connection. Maybe try buying a PCIE USB adapter instead of relying on the motherboard usb connection. 
  • ShundrieShundrie Posts: 11
    Brain Burst
    ecki386 said:
    Posting this again in the support section.

    My headset was working perfectly fine for 4 days, and now after about 5-10 minutes of playing, my Rift S crashes. My screen will randomly go black, make a high-pitched beeping noise, the little white light turns orange, and then I start hearing static. After that, I'll get a notification saying my DisplayPort isn't connected, and then it will say the DisplayPort is connected again. Now I have to restart the Oculus software then plug my headset back in before it starts working again.

    After looking for a fix, I've tried all of these methods and none of them work:

    • Repairing/Reinstalling the Oculus software
    • Reinstalling SteamVR + my games
    • Checking if everything is up to date (GPU Drivers, Oculus software, SteamVR, Windows 10) and they are
    • Going on the Oculus settings and enabling Public Test Channel
    • Turning off my NVIDIA In-Game Overlay
    • Tried every other USB 3.0 port on my PC
    • Disabled USB selective suspend setting in the Windows Power Options
    • Unplugging all of my other USB devices
    • Checked that the DisplayPort wire connection in the headset is connected properly
    • Ran the Oculus software in Administrator
    • Ending OculusDash.exe and OVRServer_x64.exe in task manager
    • Turned off Power Saving mode in Device Manager for all of my USB ports

    These are my specs:

    GPU : RTX 2070

    CPU: AMD Ryzen 7 3700X

    Memory: 32GB DDR4-3600

    Motherboard: MSI B450 Tomahawk Max

    I have had this too for about 2 weeks and its getting worse 
  • ShundrieShundrie Posts: 11
    Brain Burst
    Hey If this is still happening I had the exact same problem seemingly around the same time after an update.

    It would crash anywhere between 15 minutes and an hour. Support were helping me but then went silent.

    My solution (slightly annoying but worked) was to buy a powered USB 3.0

    I can't seem to post links yet so I bought a USB Hub 3.0 Powered RSHTECH Aluminum 4 Port USB Splitter Portable Data Hub 5V/2A off amazon. Haven't had a crash since so I'm guessing the update might of changed the way the Rift S handles power and causes it to crash with certain setups.

    Hope that helps.


    I bought this too after reading it might help but it doesn't 
  • snerylsneryl Posts: 1
    NerveGear
    I'm having the same issues since the July update. Started off with losing tracking on the hands. The games either freeze up or completely crash, now. I've contacted support multiple times, gone through all the steps they tell me to do, over and over. Right now, I'm waiting on yet another support ticket response. I've updated everything I can update. My computer is one that was built for me. It's only about a year old. It's a pretty solid system that can run anything I've played, so far. If I had known my Rift S was going to be such a headache, I think I probably would've gone with a Vive. I'm not kidding. I've searched blogs and forums and support sites for an answer, and keep coming up empty. My headset is only about a year old. I bought extended warranty, so I might just try to get a new headset and see if it works better. I thought the last update from Oculus had done the trick, but whatever seemed to fix the problem stopped working within an hour of playing. Wondering whether it's software or hardware issue. I might take it in to get looked at. Nothing else is working, so far.
Sign In or Register to comment.