New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Cast not working

Both my iphone and Quest 2 are set to the same wifi, I select cast on my quest and select my app from the menu and on my phone is says it is now casting but I see  nothing.  Anyway to fix this because it's a serious bummer that I can't play with my family with no way for them to see it

Comments

  • Prof62Prof62 Posts: 1
    NerveGear
    Same here - tried using my brand new fully patched up to date Quest 2 with both my iPhone 11 and iPad Pro both of which are running the latest version of the app and are on the same network as the quest. (I have also tried connecting them all to a different Wi-Fi router)

    Both say they are casting then, a couple of seconds later announce that an error has occurred. At the same time the Quest 2 briefly displays a pop-up message to the effect that a casting/live streaming error has occurred and that casting has stopped.

    Retrying has no effect and neither does rebooting both the quest and the phone/iPad.

    I've followed the instructions on the website to the letter but casting just will not work.
  • OculusSupportOculusSupport Posts: 1,298 Oculus Staff
    @morningland Hi, If you haven't already, try disabling the WiFi and re-enabling it, power cycle the headset, and factory reset the headset (Note: All data on headset will be lost, you will need to re-download your apps/games). If you continue to have issues, please create a support ticket with us here. - Clint
  • b0xheadb0xhead Posts: 1
    NerveGear
    You must be kidding me. FFS
  • markwest76markwest76 Posts: 40
    Brain Burst
    casting always gives me an error too, but I think it might due to the fact that the Quest is connected via 5 ghz network, while my smartphone supports only the 2.4 option...
  • PITTCANNAPITTCANNA Posts: 1,068
    3Jane
    all wifi is not equal.

    ensure phone and quest unit are on the same bandwidth for casting if your phone can only support 2.4 ghz, connect your quest to the 2.4 ghz band.

    additionally make sure bluetooth is turned on for the phone.  

    also if you have a laptop or computer connected via a web browser you can go to a chrome web page to the below address
    https://www.oculus.com/casting
  • PITTCANNAPITTCANNA Posts: 1,068
    3Jane
    also in your router settings you may need to check p2p

    Your network should allow P2P connections.
  • RedTinyOneRedTinyOne Posts: 1
    NerveGear
    This solved it for us on our UniFi wireless network. I've seen P2P setting on other routers.

  • LarsBorrisLarsBorris Posts: 1
    NerveGear
    This solved it for us on our UniFi wireless network. I've seen P2P setting on other routers.
    This solved it for me on my Dream Machine Pro from UBNT.
    Thanks!
  • dvdsteltdvdstelt Posts: 1
    NerveGear
    This solved it for us on our UniFi wireless network. I've seen P2P setting on other routers.

    Like a charm! Thanks!!!!
  • vnevskyvnevsky Posts: 1
    NerveGear
    This solved it for us on our UniFi wireless network. I've seen P2P setting on other routers.

    Bingo - issue resolved! Thanks a lot for sharing!!
    Had to update Unifi controller to version 6 for this option to show.
  • i_cant_read4i_cant_read4 Posts: 1
    NerveGear
    hey oculus. just wanna know why i cant cast to my computer. please respond.
  • uberfamuberfam Posts: 1
    NerveGear
    oculus.com/casting only gives me a black screen
Sign In or Register to comment.