New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Rift S keeps disconnecting even on PCIe card

uneasyuneasy Posts: 1
NerveGear
I have that common annoying issue. Just got Rift S, it wasn't working correctly at all when plugged directly to motherboard, but that's why I had Inatek PCIe USB 3.0 card left, after my pervious CV1. Now it works, once I have it going I can play for hours and it;s fine. 
But when it's just resting on my desk, and I am not using VR, I keep getting this random disconnection of Display Port or USB, then all of the sudden comes back and that just keeps going. Sometimes to use it again, I have to unplug usb and plug it again.

My PCIe card is powered from PSU, but it sill seems like power issue, just ordered USB hub with 3A power supply, but kinda have a feeling that it won't help.

Not sure why I am writing here, as I know it is known issue with Rift S and I didn't find any solution. But maybe I am missing something ? 

Comments

  • muvrmuvr Posts: 3
    NerveGear
    edited November 16
    Hi, 
    I try to fix the same issue for a couple of months now. It seems like the oculus team is not able to solve this USB connectivity problem. I researched a lot aleady and found a couple of solutions which are working for some people (but not for me so far):
    1. Close every oculus software in Task Manager (should be 3 services)
    2. Disconnect display port and usb
    3. Open Windows Device manager and uninstall the USB with yellow trigangle warning sign and the USB Rift S hub (Important: choose the option to remove software as well)
    4. Update to latest Windows and Video Card driver versions
    5. Deactivate Windows Gamemode (somewhere in Windows Settings)
    6. Deactivate all Windows Security (Real time protection, Cloud delivered protection, Windows Defender firewall, Automatic sample submission)
    7. Disconnecte all USB devices except mouse, keyboard, one monitor and reboot windows
    8. Start Oculus Home
    9. Connect USB and wait until it shows green "connected" text
    10. Connect Display port


    If still not working this could also help:
    a) Uninstalled all Oculus Applications and remove folders:
    • C:\Users\USERNAME\AppData\Local\Oculus\
    • C:\Users\USERNAME\AppData\Local\Temp\OculusSetup\
    • C:\Users\USERNAME\AppData\LocalLow\Oculus\
    • C:\Users\USERNAME\AppData\Roaming\Oculus\
    • C:\Users\USERNAME\AppData\Roaming\OculusClient\
    • C:\OculusSetup-DownloadCache
    • C:\Program Files\Oculus
    b) Install newest Oculus Version
    c) Use a PCIe USB 3.1 (10Gbps) Card 
    d) Reconnect the cable at the headset

    Hope it will help at least you.

    greetings
Sign In or Register to comment.