New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Rift CV1 displaying desktop yet Oculus Home says "HDMI not connected"??

DEGEILENDEGEILEN Posts: 6
NerveGear
What on earth is going on here??
I can get the Rift to display the desktop as if it was just another monitor but no matter what connection or adapter I try, Oculus Home doesn't recognize the HDMI connection.

Answers

  • RichooalRichooal Posts: 1,952 Valuable Player
    edited November 18
    Since the CV1 requires a HDMI connection and you are in Oculus Home, it must be working. So I don't understand what the actual problem is.

    "Oculus Home" is the VR doll's house you go to and add furniture and stuff . Is this what you mean, or do you mean the Oculus Desktop App, when you say Oculus Home doesn't recognise the HDMI connection?

    Have you had this working before or have you just got this CV1 as a used unit?
    i5 6600k - GTX1060 - 8GB RAM - Rift CV1 + 3 Senors - 0 PROBLEMS 1 minor problem
    Dear Oculus, "If it ain't broke, don't fix it", please.

  • DEGEILENDEGEILEN Posts: 6
    NerveGear
    edited November 18
    I am talking about the Oculus desktop menu/app/whatever, where you can set up your Rift.
    I know that it must be working since I can use the Rift like a second monitor in Windows, yet the Oculus software does not see it that way...
    Since the HDMI connection is not detected in the Oculus app, I cannot use SteamVR or play games either.

    It is a barely used CV1 that I just received and I can confirm that all the hardware works 100%. Displays and connectors are all fine. I can play music through the CV1 speakers and I can see my desktop in full resolution when putting on the headset.
  • RichooalRichooal Posts: 1,952 Valuable Player
    Yeah, sorry, you've lost me. My App only shows Rift as "connected". It doesn't show a separate status for USB and HDMI.


    i5 6600k - GTX1060 - 8GB RAM - Rift CV1 + 3 Senors - 0 PROBLEMS 1 minor problem
    Dear Oculus, "If it ain't broke, don't fix it", please.

  • DEGEILENDEGEILEN Posts: 6
    NerveGear

  • RichooalRichooal Posts: 1,952 Valuable Player
    edited November 18
    Okay, I see now.
    I'm going to state the obvious here just in case you haven't already done it, apologies if you have.
    Try re-seating the HDMI cable at BOTH ends. At the headset end you need to remove the facial interface first.
    Also try removing both plugs at the PC end and insert the HDMI first, wait a few seconds and then insert the USB plug.

    Is the warning at the top of your pic about Windows 7?
    Also, at some point, you'll need to get the latest firmware 709/b1ae4f61ae
    i5 6600k - GTX1060 - 8GB RAM - Rift CV1 + 3 Senors - 0 PROBLEMS 1 minor problem
    Dear Oculus, "If it ain't broke, don't fix it", please.

  • DEGEILENDEGEILEN Posts: 6
    NerveGear
    I already checked the HDMI cable at both ends, multiple times.
    The fact that my desktop is shown flawlessly on the Rift makes me believe that it is purely a software problem.
    BTW, before reinstalling the Oculus driver I had the opposite problem: HDMI connection was shown as good but the Rift displays didn't turn on.

    Yes, I am on Win7. I may not need features like ASW so I would rather not upgrade to Win10.
  • RichooalRichooal Posts: 1,952 Valuable Player
    edited November 18
    The best I can suggest now is to search the forum and the internet for "Rift with Windows 7" and/or "Rift with multiple monitors"
    i5 6600k - GTX1060 - 8GB RAM - Rift CV1 + 3 Senors - 0 PROBLEMS 1 minor problem
    Dear Oculus, "If it ain't broke, don't fix it", please.

  • DEGEILENDEGEILEN Posts: 6
    NerveGear
    Ok, I did a full Win7 reinstall and now at least the Oculus software properly recognizes the HDMI connection and the Rift is no longer detected by Windows as a monitor. SteamVR also detects the Rift but even though the white LED is on, the displays remain black (but turned on).
    I tried some older runtime versions and while it fixed some issues, I also get regular OVRServer crashes, most of the time related to Kernel32.dll or kernelbase.dll.

    Going to install Win10 as dual-boot now to make sure the hardware is actually working but I am almost 100% that this is the case.
Sign In or Register to comment.