New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Always says USB not connected or Display Port not connected when starting

Everytime I fire up the Rift S, it has an issue and a notification that either the USB or Display Port is not connected when they are.  I have to unplug and replug in both to get the thing to work.  Sometimes that works, other times it gets the 3 dot loading display and never gets past that screen.  I would message support, but it appears they do not have that, instead they have this "Community Forum".  Does anybody know why, or how to fix it?  Should put this thing were it belongs, in the dumpster, and get myself an HTC set?

Oculus = Garbage.   That's my takeaway from my experience with this headset that can only do VR every so often.

Comments

  • dfairad8u2dfairad8u2 Posts: 8
    NerveGear

    SOLVED; With my display port monitor and my Rift S both plugged into my RTX 2080ti an error occurs     Check out the above Post from Nov 15, 2020.  Problem IS Solved


Sign In or Register to comment.