runtime 0.4.2 camera driver — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

runtime 0.4.2 camera driver

maxx11111maxx11111 Posts: 89
Hiro Protagonist
edited September 2014 in General
installed the new runtime and in installed programs in says version 1.6 for the camera but in device manager it says 1.5 anyone else getting this?

Comments

  • erickerick Posts: 125
    Brain Burst
    It sounds like you have both drivers installed but the device is currently running on the old one.

    Personally, I wanted as clean of an install as possible so this is what I did:
    • I uninstalled the devices from Device Manager.
    • Then, I unplugged the USB/HDMI from the camera and HMD (rather than pull the computer out, I simply unplugged the USB cable on the side of the camera and USB/HDMI going into the front of the HMD).
    • I killed/closed the Oculus service and configuration tool.
    • Next, I uninstalled all of the old Oculus software.
    • The runtime uninstaller wanted to reboot when it was finished; which I did.
    • I installed the new runtime. The cables for both the HMD and camera were still unplugged.
    • The install will want to reboot.
    • While the system is booting back up, I reconnected the camera and HMD.

    If it doesn't bother you that you have two versions of drivers installed (it's not uncommon), you should be able to skip the above steps and simply upgrade the driver from Device Manager.
  • maxx11111maxx11111 Posts: 89
    Hiro Protagonist
    erick wrote:
    It sounds like you have both drivers installed but the device is currently running on the old one.

    Personally, I wanted as clean of an install as possible so this is what I did:
    • I uninstalled the devices from Device Manager.
    • Then, I unplugged the USB/HDMI from the camera and HMD (rather than pull the computer out, I simply unplugged the USB cable on the side of the camera and USB/HDMI going into the front of the HMD).
    • I killed/closed the Oculus service and configuration tool.
    • Next, I uninstalled all of the old Oculus software.
    • The runtime uninstaller wanted to reboot when it was finished; which I did.
    • I installed the new runtime. The cables for both the HMD and camera were still unplugged.
    • The install will want to reboot.
    • While the system is booting back up, I reconnected the camera and HMD.

    If it doesn't bother you that you have two versions of drivers installed (it's not uncommon), you should be able to skip the above steps and simply upgrade the driver from Device Manager.

    i had already done it this way, but have tried again twice still driver version in device manager is 0.0.1.5 even on the last attempt before reinstalling plugged in the camera and it installed as "camera dk2" not "oculus positonal tracker" so the driver did delete completely
  • erickerick Posts: 125
    Brain Burst
    Okay, I wasn't at my computer when I replied earlier. Now that I am, I can confirm my driver also says 0.0.1.5 dated 7/17.

    However, if you go to Driver Details and click on "OCUSBVID.sys", you can see the file is version 0.0.1.6. I'm guessing that it's showing as 0.0.1.5 because they didn't update the inf file.

    Also, in the future, keep in mind that a new runtime might not need a new driver.
  • maxx11111maxx11111 Posts: 89
    Hiro Protagonist
    Thanks, yeah I know not all drivers will always get updates just that I saw it say 1.6 then 1.5 in device manager just making sure things had updated as they should.
Sign In or Register to comment.