Oculus 'runtime' reads as notepad on PC — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Oculus 'runtime' reads as notepad on PC

SMOK3YSMOK3Y Posts: 259
edited September 2014 in General
my pc is reading Oculus Runtime for Windows as notepad so I cant install it and I don't know what to do

even on my laptop it comes up as a .2_win[1] file not .exe

Comments

  • klasodethklasodeth Posts: 128
    Hiro Protagonist
    Try downloading it again, making sure that you're downloading the Windows version of the runtime, not the Mac version. If the second copy still doesn't work, check the file extension and make sure it's .exe instead of .txt or .doc or whatever. If that still doesn't work, I'd recommend checking your system for viruses.
  • SMOK3YSMOK3Y Posts: 259
    ya have d/l'd dozen times just tried my lappy it even comes up as a .2_win[1] file on it not a .exe file
  • SMOK3YSMOK3Y Posts: 259
    does anyone have the file where it does read as .exe on their PC and have a link to where I can get it as they aint working off Oculus for me
  • VylenVylen Posts: 209
    Just add .exe to the end of the name.
  • mtamta Posts: 317
    Sounds like you have some antivirus software that renames downloaded executables
  • AT76AT76 Posts: 52
    Brain Burst
    First, make sure you're downloading it to a local hard drive, not to a shared folder.

    Second, you could try renaming the extension. Select file, hit F2, delete whatever is after the . then type exe and hit enter.
  • klasodethklasodeth Posts: 128
    Hiro Protagonist
    SMOK3Y wrote:
    ya have d/l'd dozen times just tried my lappy it even comes up as a .2_win[1] file on it not a .exe file
    Hmm... It sounds like you probably have file extensions hidden. Which version of Windows are you using?
  • CgpnzCgpnz Posts: 455
    you have to rename the file in a command line, as renaming in the win7 file explorer
    does not work as the wacky file association is still present.
  • Cgpnz wrote:
    you have to rename the file in a command line, as renaming in the win7 file explorer
    does not work as the wacky file association is still present.
    Or you turn off "Hide extension for known file types"
    NZ DK2 Order: May 26, 2014 06:00 PM PDT
    Status:Delivery Complete
  • ThreeEyesThreeEyes Posts: 2,230
    NerveGear
    Vylen wrote:
    Just add .exe to the end of the name.

    THIS!

    Windows has been pwned so much by people downloading viruses and malware that Microsoft's response was to remove the .exe extension for executables and make users explicitly add it back.

    It's why you now can't email executables without Windows quarentining it, or whatever it does now. It is just Microsoft's lame way of dealing with their operating system being so full of holes and vulnerabilities.
  • klasodethklasodeth Posts: 128
    Hiro Protagonist
    ThreeEyes wrote:
    Vylen wrote:
    Just add .exe to the end of the name.

    THIS!

    Windows has been pwned so much by people downloading viruses and malware that Microsoft's response was to remove the .exe extension for executables and make users explicitly add it back.

    It's why you now can't email executables without Windows quarentining it, or whatever it does now. It is just Microsoft's lame way of dealing with their operating system being so full of holes and vulnerabilities.
    I've been using Windows since before it was an operating system, and I've never seen that sort of behavior on downloaded files. As for having to do that sort of thing with email, that's because the biggest security hole is the actual users themselves. That's going to be true no matter how secure a system theoretically is.
  • CgpnzCgpnz Posts: 455
    klasodeth wrote:
    I've been using Windows since before it was an operating system,...
    If windows were an operating system, the surgeon is Dr Frankenstein.
  • ThreeEyesThreeEyes Posts: 2,230
    NerveGear
    klasodeth wrote:
    I've been using Windows since before it was an operating system, and I've never seen that sort of behavior on downloaded files.

    Not sure why. What SMOK3Y describes is the exact same behavior I have under Windows 8.1. All I did was add a .exe extension and the next time I clicked on it, it installed just fine.

    I've been out of the Windows world since mid-XP but came back to 8.1 64 bit just for the Rift. I don't know when they implemented this behavior but it's what I see and I bet it's what is confusing SMOK3Y.
  • kojackkojack Posts: 5,449 Volunteer Moderator
    Or just use a good browser instead of Internet Explorer. As I posted in another thread on this same issue yesterday, Firefox and Chrome download the file correctly, Internet Explorer strips the .exe

    If you search on the net, this has been an issue since at least 2010 with Internet Explorer, it is overly sensitive to how files are hosted (some people say the content type for files on the server must be set to application/octet-stream for IE to not rename them, but the Oculus file already seems to be that).
  • VylenVylen Posts: 209
    Well, it's not really a case of IE stripping out the .exe extension, it's more likely that it got confused with the .2_win in the filename most likely assuming the first instance of the full-stop indicating the beginning of the extension.
  • klasodethklasodeth Posts: 128
    Hiro Protagonist
    ThreeEyes wrote:
    klasodeth wrote:
    I've been using Windows since before it was an operating system, and I've never seen that sort of behavior on downloaded files.

    Not sure why. What SMOK3Y describes is the exact same behavior I have under Windows 8.1. All I did was add a .exe extension and the next time I clicked on it, it installed just fine.

    I've been out of the Windows world since mid-XP but came back to 8.1 64 bit just for the Rift. I don't know when they implemented this behavior but it's what I see and I bet it's what is confusing SMOK3Y.
    I'm also running Windows 8.1, but I did not have that problem when downloading the Oculus Runtime. What browser did you use to download the runtime?
    Vylen wrote:
    Well, it's not really a case of IE stripping out the .exe extension, it's more likely that it got confused with the .2_win in the filename most likely assuming the first instance of the full-stop indicating the beginning of the extension.
    If that were the case, it would be a far more common problem. One of the more common ways to "disable" a file is to stick an extension like .bak at the end. If Windows used the first full-stop as a way of detecting the extension, that trick wouldn't work.
  • goldenegggoldenegg Posts: 552
    Trinity
    ThreeEyes wrote:
    klasodeth wrote:
    I've been using Windows since before it was an operating system, and I've never seen that sort of behavior on downloaded files.

    Not sure why. What SMOK3Y describes is the exact same behavior I have under Windows 8.1. All I did was add a .exe extension and the next time I clicked on it, it installed just fine.

    I've been out of the Windows world since mid-XP but came back to 8.1 64 bit just for the Rift. I don't know when they implemented this behavior but it's what I see and I bet it's what is confusing SMOK3Y.

    That behaviour has absolutely nothing to do with Windows. You have another application running in the background which is causing your problem.
  • SMOK3YSMOK3Y Posts: 259
    Vylen wrote:
    Just add .exe to the end of the name.
    this worked :) after doing a restore to earlier time on desktop PC it runs W7 & the lappy runs 8.1

    sorry for being late to reply fellas thanks for help all
  • ThreeEyesThreeEyes Posts: 2,230
    NerveGear
    goldenegg wrote:
    That behaviour has absolutely nothing to do with Windows. You have another application running in the background which is causing your problem.

    Bzzt. Wrong.
  • CgpnzCgpnz Posts: 455
    So IE renaming off the .exe as a means of attempting better security. HeHe.
  • ThreeEyesThreeEyes Posts: 2,230
    NerveGear
    Cgpnz wrote:
    So IE renaming off the .exe as a means of attempting better security. HeHe.

    Absolutely true.

    And by their own hand an admission (though this is about Outlook): http://office.microsoft.com/en-us/outlook-help/blocked-attachments-in-outlook-HA102749484.aspx
    To help protect your computer, Microsoft Outlook 2013 doesn’t allow you to receive files of certain types (such as .exe files) as attachments, because of their potential for introducing a virus into your computer. By default, Outlook blocks these files. See the section Attachment file types blocked in Outlook for a list of the file types blocked.

    As for Internet Explorer, in just a quick search I was only able to find non-Microsoft discussions and instructions on how to defeat the protection. Basically you just go into IE's security settings and tell it you don't care what it does. So from one extreme to the other. Nanny state to letting IE run wild and expose your system to whatever it finds on the internet. Prude to, well, you get the idea.
  • CgpnzCgpnz Posts: 455
    Reminds we of something about sit-down VR.
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    This is a bug with Internet Explorer. You can use Firefox or Chrome, and they should work fine.

    Or you can just add the ".exe" to the end of the filename.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • CgpnzCgpnz Posts: 455
    This is a bug with Internet Explorer.
    No it is how MicroSoft implements security, in an attempt to fool the user as to where the hell did my download go.
    And oh that must not have been an exe, I cannot click on it.
Sign In or Register to comment.