Unable to get rid of stuttering — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Unable to get rid of stuttering

aragdunaragdun Posts: 14
NerveGear
edited October 2014 in General
Hi, i've being trying for like 4 hours and searching the web for answers with no result
i'm getting stuttering specially on unity demos. tried this so far:
diferent usb port
USB port 2.0 instead of 3.0
connect camera to external usb charger
updated graphic drivers, and reinstall oculus runtime 0.4.2
different camera positions. close, 1.4 meters, etc

my computer have no problems with frame rates. my system
CPU: Core i7 5960x
Mobo: ASUS RAMPAGE V EXTREME
RAM: 16 GB Corsair Dominator
Video: evga Geforce GTX 980 x 2

i try both sli and none sli configurations
I try it out on other PC the oculus with no problems.
not matter what i do always get stuttering when turning my head. would appreciate any input. thank you

Comments

  • DeadlyJoeDeadlyJoe Posts: 775
    3Jane
    Which OS are you running? Many people with high-end-ish machines, including myself, who have had a lot of stuttering/judder issues in Windows 7 have seen tremendous improvements after moving to Windows 8. Many of the stuttering issues in Elite Dangerous are completely gone.

    Some people have seen improvements by disabling Hyperthreading (BIOS option).

    In some Unity demos, I've noticed that the driver can get "stuck" in a state that will cause stuttering issues, and it seems to impossible to get out of until the driver is completely unloaded and re-loaded. The easiest way to do that is to restart the machine. Simply restarting the OVR service (which I THOUGHT was supposed to restart the driver.. and maybe it does) doesn't seem to solve it. There may be more to the problem than is obvious. You might also be able to do it via the Device Manager, but I haven't played around with that yet.
  • aragdunaragdun Posts: 14
    NerveGear
    Thank for the reply, im running Windows 8.1 64bit
    i have another pc that i use as sever is a core i5 3570k, asrock z77 mobo, GTX 750 Ti SC. also with windows 8.1 it runs with no problems there. sometimes a have to restart to clear up. but it runs very well. i cant figure out what it could be. the other unusual thing i have in the pc is a samsung M2 card not sure if have anything to do with it since is PCIE x4. gonna try the hyperthreading setting. but the other pc has it on. i want to get it to work on my rig cuz my server pc is without monitor in a difficult location. thanks again
  • Paul33993Paul33993 Posts: 406
    aragdun wrote:
    Thank for the reply, im running Windows 8.1 64bit
    i have another pc that i use as sever is a core i5 3570k, asrock z77 mobo, GTX 750 Ti SC. also with windows 8.1 it runs with no problems there. sometimes a have to restart to clear up. but it runs very well. i cant figure out what it could be. the other unusual thing i have in the pc is a samsung M2 card not sure if have anything to do with it since is PCIE x4. gonna try the hyperthreading setting. but the other pc has it on. i want to get it to work on my rig cuz my server pc is without monitor in a difficult location. thanks again

    An i5 doesn't actually have hyperthreading though. Only i3 and i7's do. So it may be enabled in the BIOS, but it's not doing anything with an i5.

    Not that I'm saying this is the issue, just that an i5 would be immune to it.
  • aragdunaragdun Posts: 14
    NerveGear
    I Can confirm the stuttering was related to hyper-threading.

    i disable it in bios and now unity demos runs perfect!
    Thanks a lot. you guys were right on the spot. I researched this for several hours but didn't find any reference to this problem.

    is there any work around for this without disabling the hyper-threading. or software tool to disable it without hard reset and bios change?. i will check asus utilities to see.
    again, thanks a lot
  • VercciVercci Posts: 85
    aragdun wrote:
    I Can confirm the stuttering was related to hyper-threading.

    i disable it in bios and now unity demos runs perfect!
    Thanks a lot. you guys were right on the spot. I researched this for several hours but didn't find any reference to this problem.

    is there any work around for this without disabling the hyper-threading. or software tool to disable it without hard reset and bios change?. i will check asus utilities to see.
    again, thanks a lot
    The oculus SDK is in its early days yet. Issues like that will probably be worked on when they've got basic functionality fully working first.

    But I imagine the guys at Unity would like to hear how turning off hyper-threading helped you now.
    NZ DK2 Order: May 26, 2014 06:00 PM PDT
    Status:Delivery Complete
  • tamontetamonte Posts: 291
    Oh...will try this on my system too.
    I thought my 270x wasnt enough for some demos but maybe the problem is the i7 is too much :P

    Thx for the info!
  • 4lx4lx Posts: 26
    In the Task Manager under details you can "Set Affinity" for each program individually. I believe the they come in the order phyiscal cores/hyper threads. Google it...

    If this helps we should let Bilago know about it.
    DK2, Asus X99 Deluxe, MSI GTX 970 Gaming, Intel 5820K, 16GB DDR4 RAM, 500GB SSD, Windows 8.1 updated.
  • CgpnzCgpnz Posts: 455
    remove one of those 980's and lend to a mate. sli for vr direct is not out yet.

    But dx12 is! What's that all about.
  • GameOutLoudGameOutLoud Posts: 29
    Brain Burst
    I'm having a hell of a time removing judder from Unreal engine demos. Unity/Source/idtech games run like a dream. I'm wondering if has something to do with my POS bulldozer processor. I'm running an Fx6100 "6" core 3.3gHz processor with a Gtx 970 on Windows 7.

    Anyone with a similar setup have any thoughts?
Sign In or Register to comment.