New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

HMD Sensor Detected, check HDMI connection

MOD46MOD46 Posts: 31
Brain Burst
edited September 2015 in Support
Lol new runtime and sdk new error message in the config util

with version 4.4 and 5.01 I had the "No HMD detected" error

now with version 6 I get a new error message "HMD Sensor Detected, check HDMI connection"

I cannot make sense of this message as it seems a little contradictory. I tried connecting the hdmi cable to another port with the dvi adapter and it still showed the same message. Very frustrating as I have not been able to get the rift to run on my new high end computer I purchased in January. BTW the hdmi cable is fine as the rift works on another family members computer with runtime 5.01 but as it is somebody else's computer I have very limited access to it.

Comments

  • Jonb3331Jonb3331 Posts: 11
    I am having the same problem. To complicate things even further this only happen while I am in extended mode. When the rift is in direct mode all demos work fine. So I know my rift works.
  • VegasGh0stVegasGh0st Posts: 50
    Hiro Protagonist
    your not alone been having detection issues since 5.0.1 and nothing works, except going back to runtime 4.4 which works perfectly, besides the main fact its incompatible with Vorpx, Virtual Desktop and many other new games apps and demos.
    Still awaiting help.
    Nothing is impossible, just time consuming.
  • I am having this exact same issue. Anything run straight to the rift runs perfectly fine, but if I extend the display then it just disconnects. It was working alright (except I still cant seem to get Elite running) up until 20 minutes ago, and now I cant get it working again.
  • MOD46MOD46 Posts: 31
    Brain Burst
    Just to clarify my issue is that I get the message in both direct and extended mode
  • cleakcleak Posts: 15 Oculus Staff
    There are many issues that this particular message can point to. This issue as a regression from 0.4.4 (which is a minority of the times this error message is displayed) should be resolved in 0.6 (I'll give an update about that later in https://forums.oculus.com/viewtopic.php?f=34&t=22006).

    Is your Rift being detected in Windows while in extended mode? That is, can you see it in Windows' "Screen Resolution" configuration? Mind posting a screenshot with the DK2 display selected if so? This will give us some info to go on.

    The message itself (now more specific in 0.6) can mean anything from incompatible 3rd party drivers, to bad cables, to loose cables, to a hardware failure. The easiest place to start is with a different set of cables plugged into different video and USB ports.
  • Jonb3331Jonb3331 Posts: 11
    cleak wrote:
    There are many issues that this particular message can point to. This issue as a regression from 0.4.4 (which is a minority of the times this error message is displayed) should be resolved in 0.6 (I'll give an update about that later in https://forums.oculus.com/viewtopic.php?f=34&t=22006).

    Is your Rift being detected in Windows while in extended mode? That is, can you see it in Windows' "Screen Resolution" configuration? Mind posting a screenshot with the DK2 display selected if so? This will give us some info to go on.

    The message itself (now more specific in 0.6) can mean anything from incompatible 3rd party drivers, to bad cables, to loose cables, to a hardware failure. The easiest place to start is with a different set of cables plugged into different video and USB ports.

    Cleak with my problem specifically, I am having this issue only while in extended mode. I am posting two pics for you one when in direct and on with extended selected.

    http://imgur.com/j6tuZn3 (extended)
    http://imgur.com/OCDiFYt (direct)
    http://imgur.com/7MHf7xR (direct showing the headset working)
    As you can see for me at least this would rule out it being a cable or hardware issue. I am about to bash my head against a wall trying to figure out how to make this work. If anyone on the Rift team would like to remote into my computer I would be fine with that as well.
  • Jonb3331's screenshots would look exactly like mine.

    Other forums and reddit have said the only way they have fixed this issue in the past is a complete windows wipe and reinstall. (Which seems quite dramatic.) but if that has worked for others, I dont know if that means hardware or cable failure.

    I've tried different ports. but since it works flawlessly in direct mode, that means the hardware is fine right?



    EDIT: I've just installed 4.4 runtime, and it seems to work fine on extended mode there. The hardware is running okay. seems to simply be an issue at 5.0.1 and above.
  • Jonb3331Jonb3331 Posts: 11
    Looks like we are both in the same boat Valorumguygee. I certainly do not want to uninstall windows as that is just going to be a nasty headache. 4.4 works fine for me as well and I would use it but software like vorpx or virtual desktop wont work with 4.4 so I am at a bit of a stalemate.
  • VidjayVidjay Posts: 11
    NerveGear
    Got the same problem. I got my DK2 last christmas and was able to use it for maximum 4h. Then orange light came up and the rift was gone. "No HMD detected". Since then I tried everything (Win 8.1 to Win7, changing cables HDMI+USB, changing graphic card drivers, using various USB2 hubs, changing ports, changing from direct to extended with various runtime versions etc...) to get it back blue I found only one solution :

    To plug in to another computer. The rift wakes up, get detected and then I plug it back to my original PC. I can play for about 4h and then the rift gets back to "HMD Sensor Detected, check HDMI connection"

    I am using the rift on an ASUS ROG G750JH (Gforce GT780M 3go / 16Gb DDR3)
  • starsky396starsky396 Posts: 9
    NerveGear
    I seem to be getting the same problems. I posted my debug log too.
    {
    	"Time":	"2015-05-20_17:57:21",
    	"SDK Version":	"0.6.0.0",
    	"Service Protocol":	{
    		"Major":	1,
    		"Minor":	5,
    		"Patch":	0
    	},
    	"RemoteProtocolVersion":	{
    		"Major":	1,
    		"Minor":	5,
    		"Patch":	0
    	},
    	"Service Running Time":	{
    		"Hours":	0,
    		"Minutes":	8,
    		"Seconds":	39
    	},
    	"System Specifications":	{
    		"Operating System":	"Microsoft Windows 7 Home Premium ",
    		"Processor":	"Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz",
    		"Graphics Adapters":	[{
    				"Name":	"NVIDIA GeForce GTX 980",
    				"Video Controller RAM (MB)":	4095,
    				"Driver Version":	"9.18.13.4788",
    				"Video Mode":	"1680 x 1050 x 4294967296 colors"
    			}, {
    				"Name":	"Intel(R) HD Graphics 3000",
    				"Video Controller RAM (MB)":	2108,
    				"Driver Version":	"9.17.10.3347",
    				"Video Mode":	"1080 x 1920 x 4294967296 colors"
    			}],
    		"Total RAM (GB)":	16,
    		"USB Tree":	[{
    				"name":	"Etron USB 3.0 Extensible Host Controller",
    				"deviceid":	"PCI\\VEN_1B6F&DEV_7023&SUBSYS_50071458&REV_01\\4&18803EC9&0&00E4",
    				"caption":	"Etron USB 3.0 Extensible Host Controller",
    				"manufacturer":	"Etron Technology Inc.",
    				"Devices":	[{
    						"manufacturer":	"Etron Technology Inc.",
    						"name":	"Etron USB 3.0 Extensible Root Hub"
    					}]
    			}, {
    				"name":	"Etron USB 3.0 Extensible Host Controller",
    				"deviceid":	"PCI\\VEN_1B6F&DEV_7023&SUBSYS_50071458&REV_01\\4&1B0D22A2&0&00E5",
    				"caption":	"Etron USB 3.0 Extensible Host Controller",
    				"manufacturer":	"Etron Technology Inc.",
    				"Devices":	[{
    						"manufacturer":	"Etron Technology Inc.",
    						"name":	"Etron USB 3.0 Extensible Root Hub"
    					}, {
    						"manufacturer":	"(Standard system devices)",
    						"name":	"USB Input Device"
    					}, {
    						"manufacturer":	"Microsoft",
    						"name":	"HID-compliant mouse"
    					}]
    			}, {
    				"name":	"Intel(R) 6 Series/C200 Series Chipset Family USB Enhanced Host Controller - 1C26",
    				"deviceid":	"PCI\\VEN_8086&DEV_1C26&SUBSYS_50061458&REV_05\\3&13C0B0C5&0&E8",
    				"caption":	"Intel(R) 6 Series/C200 Series Chipset Family USB Enhanced Host Controller - 1C26",
    				"manufacturer":	"Intel",
    				"Devices":	[{
    						"manufacturer":	"(Standard USB Host Controller)",
    						"name":	"USB Root Hub"
    					}, {
    						"manufacturer":	"(Generic USB Hub)",
    						"name":	"Generic USB Hub"
    					}]
    			}, {
    				"name":	"Intel(R) 6 Series/C200 Series Chipset Family USB Enhanced Host Controller - 1C2D",
    				"deviceid":	"PCI\\VEN_8086&DEV_1C2D&SUBSYS_50061458&REV_05\\3&13C0B0C5&0&D0",
    				"caption":	"Intel(R) 6 Series/C200 Series Chipset Family USB Enhanced Host Controller - 1C2D",
    				"manufacturer":	"Intel",
    				"Devices":	[{
    						"manufacturer":	"(Standard USB Host Controller)",
    						"name":	"USB Root Hub"
    					}, {
    						"manufacturer":	"(Generic USB Hub)",
    						"name":	"Generic USB Hub"
    					}, {
    						"manufacturer":	"(Generic USB Hub)",
    						"name":	"Generic USB Hub"
    					}, {
    						"manufacturer":	"(Standard USB Host Controller)",
    						"name":	"USB Composite Device"
    					}, {
    						"manufacturer":	"(Standard system devices)",
    						"name":	"USB Input Device"
    					}, {
    						"manufacturer":	"(Standard keyboards)",
    						"name":	"HID Keyboard Device"
    					}, {
    						"manufacturer":	"(Standard system devices)",
    						"name":	"USB Input Device"
    					}, {
    						"manufacturer":	"Microsoft",
    						"name":	"HID-compliant consumer control device"
    					}, {
    						"manufacturer":	"(Standard system devices)",
    						"name":	"HID-compliant device"
    					}, {
    						"manufacturer":	"(Standard system devices)",
    						"name":	"HID-compliant device"
    					}, {
    						"manufacturer":	"(Standard system devices)",
    						"name":	"HID-compliant device"
    					}, {
    						"manufacturer":	"(Standard USB Host Controller)",
    						"name":	"USB Composite Device"
    					}, {
    						"manufacturer":	"Oculus VR",
    						"name":	"Oculus DK2 Tracker"
    					}, {
    						"manufacturer":	"(Generic USB Hub)",
    						"name":	"Generic USB Hub"
    					}, {
    						"manufacturer":	"(Standard system devices)",
    						"name":	"USB Input Device"
    					}, {
    						"manufacturer":	"(Standard system devices)",
    						"name":	"HID-compliant device"
    					}]
    			}]
    	},
    	"Drivers":	[{
    			"Path":	"\\system32\\OVRDisplay64.dll",
    			"Version":	"1.2.5.0"
    		}, {
    			"Path":	"\\system32\\OVRDisplayRT64.dll",
    			"Version":	"1.2.5.0"
    		}, {
    			"Path":	"\\syswow64\\OVRDisplay32.dll",
    			"Version":	"1.2.5.0"
    		}, {
    			"Path":	"\\syswow64\\OVRDisplayRT32.dll",
    			"Version":	"1.2.5.0"
    		}, {
    			"Path":	"\\system32\\drivers\\RiftEnabler.sys",
    			"Version":	"1.2.5.0"
    		}, {
    			"Path":	"\\system32\\OVRDisplay32.dll",
    			"Version":	"1.2.5.0"
    		}, {
    			"Path":	"\\system32\\OVRDisplayRT32.dll",
    			"Version":	"1.2.5.0"
    		}, {
    			"Path":	"\\system32\\drivers\\OCUSBVID.sys",
    			"Version":	"1.0.10.0"
    		}],
    	"Video Device Tree":	[{
    			"Name":	"NVIDIA GeForce GTX 980",
    			"VRAM (MB)":	3072,
    			"Monitors":	[{
    					"Name":	"\\\\.\\DISPLAY1",
    					"Width":	1680,
    					"Height":	1050,
    					"Refresh Rate":	59
    				}, {
    					"Name":	"\\\\.\\DISPLAY2",
    					"Width":	1920,
    					"Height":	1080,
    					"Refresh Rate":	75
    				}]
    		}],
    	"Devices":	[]
    }
    
  • skylarmbskylarmb Posts: 1
    This stumped me for hours. I ended up solving it by simply setting the rift to extended mode in the config util and then TURNING ON THE RIFT! For some reason my rift didn't turn on when I plugged it in. I saw the orange light and assumed that it was in "sleep" mode or whatever, but hitting the power button instantly made it show up in the util. All is well. :D
  • sfaxosfaxo Posts: 9
    Brain Burst
    Same issue. I have a g-sync monitor. Anyone figure out what the problem is? I don't want to reinstall windows. The DK2 works fine in direct to rift mode.
  • sfaxosfaxo Posts: 9
    Brain Burst
    sfaxo wrote:
    Same issue. I have a g-sync monitor. Anyone figure out what the problem is? I don't want to reinstall windows. The DK2 works fine in direct to rift mode.

    Unplugging everything and replugging everything seemed to work. Strange that the connection issue only affects extended mode.
  • AnkaronAnkaron Posts: 3
    Hi

    i have also the same problem on 0.6.0.0 on "Extended Mode" .. everything works fine with older runtimes both Direct and Extended.

    using gtx980 on asus VH238 monitor with Win 7 64bit. ... for dedails see dxdiag.txt attached.

    also running all sorts of software like skype, steam, nvidia experience, evga precision etc.

    regards
  • sfaxosfaxo Posts: 9
    Brain Burst
    sfaxo wrote:
    sfaxo wrote:
    Same issue. I have a g-sync monitor. Anyone figure out what the problem is? I don't want to reinstall windows. The DK2 works fine in direct to rift mode.

    Unplugging everything and replugging everything seemed to work. Strange that the connection issue only affects extended mode.

    The issue came up again. I tried turning off g-sync, swapping usb ports (I can't swap HDMI ports since the 980 only has one), and even replacing the HDMI cable with another but I still get the same issue. Attached are my DxDiag.txt and screenshot. Any help would be appreciated.
  • sfaxosfaxo Posts: 9
    Brain Burst
    sfaxo wrote:
    sfaxo wrote:
    sfaxo wrote:
    Same issue. I have a g-sync monitor. Anyone figure out what the problem is? I don't want to reinstall windows. The DK2 works fine in direct to rift mode.

    Unplugging everything and replugging everything seemed to work. Strange that the connection issue only affects extended mode.

    The issue came up again. I tried turning off g-sync, swapping usb ports (I can't swap HDMI ports since the 980 only has one), and even replacing the HDMI cable with another but I still get the same issue. Attached are my DxDiag.txt and screenshot. Any help would be appreciated.

    lol and it mysteriously went away. Extended mode works fine again. Seems like an intermittent issue. Maybe cabling? But then why does direct to rift always work.
  • AnkaronAnkaron Posts: 3
    Hi is there any news, any progress regarding this issue?

    here is the rift diag
  • I got my DK2 a couple of days back. Initially after installing everything was working fine however suddenly I have landed up in the same boat.

    My configs:
    1. Windows 7, Aero Disabled.
    2. Asus Graphics Card
    3. Logitech Wireless keyboard and mouse (Read somewhere there is a conflict with these drivers)
    3. SDK: 0.6.0.0

    When in direct mode - HMD is detected and shown in config-utility tool. However, in extended mode it says - HMD sensor detected check HDMI connection. Please note that I can still experience VR in extended mode by running content in main desktop and then pressing windows+P repeatedly to select extended mode in display settings.

    Another strange thing that has happened along with this is that the demo and the measure IPD no no longer work in either mode and I just get a blank screen.

    I tested an older version of runtime 0.4 and it worked perfectly but since it is not compatible with many tools like virtual desktop had to revert back to find the problem persists. Has anybody find a solution to this strange behavior?
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    Well, you need to enable Aero. Also, if Direct Mode is working, why not just use that?

    In Extended Mode it's possible the display configuration is wrong. Make sure the DK2 is set to 1920x1080 @ 75Hz in portrait orientation. Also be sure that the position of the Rift is to the right and on the same level as your monitor (none of the coordinates can be negative).
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • dustumsdustums Posts: 16
    I've got the "check HDMI connection" issue consistently the moment I turn off the HMD, my machine sleeps, or sometimes just randomly. My only consistent solution is to unplug the power cable to the rift and replug. That seems to always reconnect it properly. I just spend a lot of time under my desk. :D
  • @Cybereality - HMD not being discovered in extended mode leads to several problems like opening/running apps that do not have a direct to rift executable.

    I installed WebVR enabled versions of both chrome and firefox and tried to test the mozvr demos. If I am on the direct display mode in config tool head tracking does not work but the screen shows up in HMD. On the other hand, in the extended mode no screen shows up since HMD is not detected - but the head tracking works. Not sure if this is a bug related to the thread's topic but it seems so.

    I am guessing, the HMD not being detected in both the direct and extended modes is a big problem as many others have been reporting this and if a sure shot solution can be ascertained it will possibly lead to solutions of many other problems as well.
  • thatdude90210thatdude90210 Posts: 147
    Art3mis
    I just started seeing this issue today. I've had the DK2 since july/aug last year and it's worked fine til today. I was using runtime 5.0.1 and suddenly got the "HMD not detected, tracking camera connected." So I decided to try the latest 6.0.1 runtime, and upgrade my videocard driver. Same issue, only now the error message is "HMD powered off, check HDMI connection." I tried reconnecting the hdmi and usb cables but no difference. And either extended or direct mode makes no difference.

    Then I tried a different HDMI cable, and it worked. But it's a short cable so obviously it's not a workable solution. Plus I don't want an extra wire hanging off my DK2. So if my issue is the hdmi cable, how do I go about getting a replacement?

    My system is i5 2500k, amd r9 290, windows 7 64-bit. And I don't have teamviewer, plus tried some of the trouble shooting like restarting ovr service that I found googling around.
  • Knightshade.SteveKnightshade.Steve Posts: 80
    Hiro Protagonist
    For the count.

    I had the same problem, directmode = HMD works fine, Extended - it doesn't power up.;
    Elite Dangerous's performance in DirectHMD mode is apalling on a phenom II x4.

    here is team oculus's most recent responce from another thread;
    viewtopic.php?f=34&t=22006&start=80
    This issue as a regression from 0.4.4 should be solved in 0.6. Note that the majority of users seeing this error message are not actually experiencing the issue as a regression, but fortunately customer support can help with such cases.

    If you're getting this error message, please do the following:

    Uninstall the Oculus Runtime, Display Drivers, and Tracking Driver (you can just uninstall everything made by Oculus from "Programs and Features").
    Reboot.
    Log into your machine and give it several minutes. This will make sure that it picks up default drivers for your hardware.
    Install the 0.6 Runtime. This can be found at https://developer.oculus.com/downloads/. If something newer happens to available by the time you see this, use the newer version.
    Reboot again after installation.
    Switch to Extended mode with Rift Saver off.
    Reboot once more.
    Open up Config Util and enter into the demo scene. If you can see the demo scene, then the issue is resolved.


    If the above steps do not resolve your issue, then do the following (same as above, but this time installing 0.4.4):

    Uninstall the Oculus Runtime, Display Drivers, and Tracking Driver (you can just uninstall everything made by Oculus from "Programs and Features").
    Reboot.
    Log into your machine and give it several minutes. This will make sure that it picks up default drivers for your hardware.
    Install the 0.4.4 Runtime. This can be found at https://developer.oculus.com/downloads/ ... 0.4.4-beta.
    Reboot again after installation.
    Switch to Extended mode with Rift Saver off.
    Reboot once more.
    Open up Config Util and enter into the demo scene. If still you can not see the demo scene, then you are experiencing a different issue than the main one being discussed here. There can be many causes for this, so please contact Customer Support (https://support.oculus.com/hc/en-us/requests/new) and they should be able to get you sorted out.

    If both of the above fail, please contact Customer Support. If the first fails and the second succeeds, then please reply back so we know there's an on-going regression. Thanks everyone for your patience with this!

    MY FIX;

    i followed the instructions
    (installing the runtime with the rift turned on seemed to be the only thing i hadnt tried)

    I also unplugged an unused monitor from my graphics card (750ti, 3 ports)

    Either unplugging the monitor or installing the runtime with the dk2 turned on.. fixed the issue.

    I hope this helps someone

    (unfortunately now, in extended mode, the HMD powers up but the headset doesn't.. amber light, staring at me.
    which has happened many times before.
    too tired to tackle the issue. Least the HMD is working.)
  • thatdude90210thatdude90210 Posts: 147
    Art3mis
    I just started seeing this issue today. I've had the DK2 since july/aug last year and it's worked fine til today. I was using runtime 5.0.1 and suddenly got the "HMD not detected, tracking camera connected." So I decided to try the latest 6.0.1 runtime, and upgrade my videocard driver. Same issue, only now the error message is "HMD powered off, check HDMI connection." I tried reconnecting the hdmi and usb cables but no difference. And either extended or direct mode makes no difference.

    Then I tried a different HDMI cable, and it worked. But it's a short cable so obviously it's not a workable solution. Plus I don't want an extra wire hanging off my DK2. So if my issue is the hdmi cable, how do I go about getting a replacement?

    My system is i5 2500k, amd r9 290, windows 7 64-bit. And I don't have teamviewer, plus tried some of the trouble shooting like restarting ovr service that I found googling around.
    Followup on this. I emailed support and they said that it does appear to be a faulty HDMI cable, but I won't be able to buy a replacement from Oculus, and to just substitute my own HDMI cable. So I bought one, a 10ft thin one with Redmere tech from Amazon for about $14. It's not ideal but it works.
  • This fixed the problem for me

    http://res2.windows.microsoft.com/resbo ... e92_52.jpg

    Oculus was accidentally set to disabled
Sign In or Register to comment.