New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

black noise-- Standard Shader Unity 5 issues

bauervisionbauervision Posts: 13
edited February 2016 in Samsung Gear VR
In every one of my projects for Gear VR, I get these black dots, they look like some sort of banding artifact, over all of my surfaces. They extend away from the camera and get less and less apparent as they proceed into the distance.

They also only show up in lit areas of the scene. If there is a shadow on the ground, these dots vanish. If light is hitting a surface, they show up.

I've turned off GI, I've turned it on. I have changed just about setting I can find and I am at a loss as to what is causing this artifact to appear.

There is no way I can show this to our clients.

Any help is greatly appreciated.

I'm using the latest Unity build

UPDATE:SOLVED

So it had to do with Pixel Light Count being set to 1.

Setting it to zero got rid of the black dots, and gave me back Forward rendering.

Comments

  • So far it seems as though having an actual Directional Light plugged into the Sun parameter under the Environmental Lighting dialog is what is causing some of the issue.

    Setting it back to None, the black dots are gone from my main terrain model, but they still exist on other models.
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    Is there any way you can take a screenshot of the issue?

    Also, I assume you're on Unity. Which version of Unity and which SDK are you using?
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • I would love to figure out a way of getting a screenshot, but as of right now, I have no idea how to get one from the headset.

    Latest build of Unity, 5.1.2f1

    Android SDK 24.3.3
  • Upon further investigation, it appears that if I switch the shaders back to Legacy, the black dots go away completely.

    So there is something with using the Standard shader that GearVR isn't happy about.
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    Yes, I've heard of shader issues on Unity 5. You're not the first one to run into this.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • So Legacy doesn't really solve it either. So far the only shader I can use to get rid of the issue is Legacy/Diffuse Fast.

    If the shader can receive a shadow (Diffuse Fast does not), black dots everywhere.
  • mallmagicianmallmagician Posts: 297 Oculus Start Member
    If you plug a usb keyboard into the charging port on the S6 gearvr, using an on the go cable (otg), THEN plug the S6 into the gvr, you should be able to screenshot by just hitting print screen on the keyboard.
  • I don't have the S6
  • StudioMaxStudioMax Posts: 3
    NerveGear
    I had the same problem. In my case it was caused by the export of my geometry from sketchup.
    'Export 2-sided faces' was on for everything. It only should be on for transparant (glass) materials.
  • kavskavs Posts: 13
    Apologies for the semi-necro, but I'm getting this too (or at least some sort of manifestation of it). Here's my details and a screenshot. It runs fine on PC.

    I only have one light source, and it's the default directional light.

    The models are all basic 3D primitives with Standard shaders using only color. I thought it might just be my materials (as I made some basic colorized ones), but reverting to Default-Material on the ground still shows the artifacting.

    This is with Unity 5.3.0f4 building to my Samsung Galaxy S6 running Android 5.1.1. I built it on a 64-bit Windows 10 machine and my installed Android SDK is 5.0.

    Setting Pixel Light Count to 0 didn't seem to do anything, as suggested by the OP.

    Anything in shadow doesn't have this effect which makes me think it's something with the lights.

    Any ideas, or any other information I can provide to help debug this?

    Curiously, my first 'room' project with not much in it doesn't have this problem and it uses primitives and the Default-material as well. I checked everything I could reasonably think of (light settings, render settings, quality settings) and everything seems identical. Happy to send these projects somewhere for someone to break apart if needed.
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    Does it look fine if you uncheck VR supported?
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • kavskavs Posts: 13
    Nope, I just tested that and it's still artifacting. I'll take this to the Unity forums, then post the solution here incase anyone stumbles across this later.
  • khybotkhybot Posts: 3
    I'm having the same issues with the standard shaders too. Mobile vertex lit works ok though. (Note 5)
  • kontisleapkontisleap Posts: 2
    NerveGear
    Hey, I encountered a similar issue. The solution for me was to raise the Bias value in my Directional Light settings. This setting is basically like a cut-off filter for shadow details, and when it's too low (like 0.05 which is the default) it can show as dark artifacts on objects. I raised it all the way to 1 and artifacts where gone, though probably just a small change could have worked as well.

    Hope this is helpful!
  • Bias up to 1 fixed my noise as well. Thanks for posting that.
Sign In or Register to comment.