New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Disable "Your computer doesn't meet Rift's recommended specifications" message in Oculus Home?

BigRobCoderBigRobCoder Posts: 48
Brain Burst
Just got my Rift, using an older overclocked CPU. I know it is not one of the recommended CPUs, but it works just fine with all the apps I've tried so far. Is there any way to disable the "doesn't meet recommended specifications" message in Oculus Home (which is present in VR as well as on the desktop window)? It's very annoying.
Tagged:
«134567

Comments

  • TheOnlyRealConanTheOnlyRealConan Posts: 25
    Brain Burst
    Yeah, I saw that on a couple of reviews (That you could not turn it off). I am going to have the same problem, since I have OC i5-3570k. Hopefully they will fix it in the future. But as of right now, they say you cannot turn it off.
  • BigRobCoderBigRobCoder Posts: 48
    Brain Burst
    Thanks! I'll definitely give that a try.
  • PopopinselPopopinsel Posts: 179
    Art3mis
    No problem, working fine here. I've got an i5-2500k @ 4.2 GHz and wanted to get rid of this message was well ;-)
  • No problem, working fine here. I've got an i5-2500k @ 4.2 GHz and wanted to get rid of this message was well ;-)
    I've got a 2500k and looking forward to playing with the Rift. I've got mine at 4.6ghz, so I'm glad to hear 4.2 works great. 
  • MisterNegativeMisterNegative Posts: 47
    Brain Burst
    Thank you for this tip! I'm sick of seeing the message already about my i5-4278
  • MisterNegativeMisterNegative Posts: 47
    Brain Burst
    I changed it for all four cores in the registry but still get it, likely because the DK2 uses USB 2. Good to know how to fix it when my CV1 arrives!!! Thanks again!
  • BigRobCoderBigRobCoder Posts: 48
    Brain Burst
    The registry trick worked great for the processor, thanks! The Rift compatibility tool now shows it in compliance.

    Unfortunately, I still get the message in Oculus home because of a USB controller on my system (I bought the USB3 card that Oculus recommended and it works fine with the Rift, so don't know why the tool thinks there's a problem). I'm trying to rename the USB controller in the registry too to fool the compatibility check, but no luck yet.
  • PopopinselPopopinsel Posts: 179
    Art3mis
    The registry trick worked great for the processor, thanks! The Rift compatibility tool now shows it in compliance.

    Unfortunately, I still get the message in Oculus home because of a USB controller on my system (I bought the USB3 card that Oculus recommended and it works fine with the Rift, so don't know why the tool thinks there's a problem). I'm trying to rename the USB controller in the registry too to fool the compatibility check, but no luck yet.

    Do you have any other (incompatible) USB 3.0 controllers installed like an Etron or Intel one from your motherboard? You could try to uninstall or disable these in Device Manager.
  • BigRobCoderBigRobCoder Posts: 48
    Brain Burst
    Do you have any other (incompatible) USB 3.0 controllers installed like an Etron or Intel one from your motherboard? You could try to uninstall or disable these in Device Manager.
    Disabling the incompatible controller and restarting Oculus software did the trick, yay! Thanks again friend!
  • Percy1983Percy1983 Posts: 1,410
    Wintermute
    I can understand the message coming up, but surely an acknowledgement should be enough to cancel it.

    I guess the point is when somebody says its not working well it will be clear why.

    But as above I have a 3570K at 4.6ghz and an incompatible USB3 controller (alongside a compatible one) so know I am fine so should be able to remove the message.
    Asrock Z77 Extreme 4 + 16GB RAM 1866mhz + i5-3570K at 4.5Ghz + Coolermaster Nepton 140XL cooler
    Sapphire 8GB RX 580 Nitro+
    256Gb SDD Samsung Evo 850 +3x2TB in raid 0 with 64GB SSD cache
    Thermaltake Level 10 GT Snow Edition + Toughpower 875w
  • MisterNegativeMisterNegative Posts: 47
    Brain Burst
    Yeah hopefully they'll allow for this in an update. Even if it's something as esoteric as a registry edit so everyday people don't dismiss it and then wonder why they're having issues.
  • PopopinselPopopinsel Posts: 179
    Art3mis
    Do you have any other (incompatible) USB 3.0 controllers installed like an Etron or Intel one from your motherboard? You could try to uninstall or disable these in Device Manager.
    Disabling the incompatible controller and restarting Oculus software did the trick, yay! Thanks again friend!
    You're welcome! :smile: 
  • ThunderSqueakThunderSqueak Posts: 4
    NerveGear
    edited March 2016
    I was curious on this, as it is a seriously annoying thing.  I hope it is addressed in the next revision with a simple "I understand" checkbox.  I would rather have a proper option to disable it rather than a workaround.  
  • ima747ima747 Posts: 25
    edited March 2016
    There's probably a way to disable it with a registry key (like you could disable the health and safety warning in 0.8) but no one has found it yet (different than modding your hardware descriptors which is just not a great solution, but sadly the only known one at the moment). Either it will get sorted, or they'll add a proper toggle to the settings. Whitelisting hardware combined with a mandatory warning is just going to piss people off in a big way long term. It's an understandable, if silly, oversight for the first public release, but quite annoying.
  • GanjaroachGanjaroach Posts: 449
    Hiro Protagonist
    This fixed work but only after I closed the OVRserver_x64 in task manager and let it restart. Thanks tho that crap was annoying as hell!
  • Any News about a better Solution ?, maybe the Developers can add such a Feature in on of there next Releases

  • LexiconAlphaLexiconAlpha Posts: 3
    NerveGear
    Any News about a better Solution ?, maybe the Developers can add such a Feature in on of there next Releases

    I second a request to get this implemented as an official toggle switch e.g. Dont remind me again. In the event Oculus get around to shipping my device I too will be in the overclocked CPU club  which flags due to not being on the official list. I would like to know that between now and getting the device teething problems like this can improve the experience,
  • jonjon Posts: 297
    Nexus 6
    Overclocked i7-3770k also reporting annoyance with persistent overly simplified and thus inaccurate warning.

    Let us disable it please.
  • FDPFDP Posts: 24
    Brain Burst
    Yes! This should be able to be turned off! Some of us are using machines that should do perfectly fine with gaming but still get flagged with this stupid message of shame. I realize it is a single core performance metric, but we live in 2016... i7-3930K here.
  • edmgedmg Posts: 1,149
    Wintermute
    edited March 2016
    It may be something the lawyers force them to put in, so if people complain about getting sick, they can point out that the UI warned them their PC wasn't compatible.

    To be fair, at least it doesn't seem to cover up anything useful in the window, unlike the equivalent Steam messages ('Verify your email again! Give us your phone number!' etc).
  • ThunderSqueakThunderSqueak Posts: 4
    NerveGear
    So far, everything has been running at 90fps,  I really wish that I could disable the silly message that shows up because "I don't meet the minimum specs" when in fact my PC is faster than what is required, the CPU simply isn't in their list :(
  • Vash63Vash63 Posts: 3
    NerveGear
    I would also like a way to disable this message. I have a 4GHz i7 3930k and a 980 ti, with the Rift and sensor plugged into the Inateck controller. I'm not modifying my registry or disabling USB controllers that I actively use for other devices. We need a better solution.
  • chrispiechrispie Posts: 1
    same here, everthing works smooth with i3-4710 + gtx 960
    but it feels like that I am not getting the full resolution on the rift. more like half...
  • ByshopByshop Posts: 5
    NerveGear
    jon said:
    Overclocked i7-3770k also reporting annoyance with persistent overly simplified and thus inaccurate warning.

    Let us disable it please.
    Same here. Too bad the Oculus performance measurement is based on specifications and not actual perf. A 3770K @ 4.2 is way better than their min spec.
  • StairmandStairmand Posts: 103
    Art3mis

    Still nothing? My USB controller triggers it even though I'm not using the onboard one and using the one recommended by Oculus. I cant disable the controller causing the issue as it's used for my KB+M.


    Stupid message. Make a toggle off in the settings please!

  • jonjon Posts: 297
    Nexus 6
    edited May 2016
    Stairmand said:

    Still nothing? My USB controller triggers it even though I'm not using the onboard one and using the one recommended by Oculus. I cant disable the controller causing the issue as it's used for my KB+M.


    Stupid message. Make a toggle off in the settings please!

    I agree, it would be nice to be able to toggle off display of this highly inaccurate warning.
  • ToxicAdamToxicAdam Posts: 27
    edited May 2016
    Yes, Make a toggle off in the settings please!

    3770K here with an 980ti

Sign In or Register to comment.