CPU Usage always 100% after installing Rift software — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

CPU Usage always 100% after installing Rift software

This is a weird one. What I'm experiencing is very similar to what's described here:

https://www.reddit.com/r/oculus/comments/32e7w0/check_your_system_interrupts/

Basically, whatever I'm running, will appear to use all of my CPU, and my fans are running at a higher volume all the time as a result. My system isn't running slowly... and it isn't an Oculus service that is at 100%, but finding someone else report a similar symptom caused by an older version of the SDK has me fairly convinced that the issue is indeed related to the Rift. I haven't tried reinstalling the software yet and I didn't notice it until after playing Eve Valkyrie (I had tried a number of other games before, but wasn't totally paying attention to what my CPU was doing or how loudly my PC was running).

Ideally I don't want to have to redownload and reinstall all the Rift apps I downloaded yesterday, but I'll give that a try if it's felt best.

Anyone else run into this?

I'm running Windows 10 64 bit on an i7 5930K, with the latest Nvidia (364.72) drivers for my 3 x GTX980s.

Help would be greatly appreciated!
«1

Comments

  • SyntheticSynthetic Posts: 704
    Trinity
    DK2 or CV1?
  • CV1. It only happens if my PC is set to high performance instead of balanced in the power options in control panel. I saw another thread with the same complaint after posting this. I tried uninstalling Eve Valkyrie, but that didn't fix the issue. They report the issue occurring after installing Eve Valkyrie too.

    https://forums.oculus.com/community/discussion/32628/windows-system-at-100
  • WolfleoWolfleo Posts: 15
    NerveGear
    yeah I have the same problem. OVRserver_64.exe is causing my cpu to run at 100%. Im running a i7 4770k 
  • dontlooksoworrieddontlooksoworried Posts: 2
    NerveGear
    edited March 2016
    Also have the same exact problem, glad it's not just me! (sorry guys D:) The balanced power setting did appear to completely resolve this issue, but this is definitely a bug.

    i5 4670k
  • alexcorscaddenalexcorscadden Posts: 6
    NerveGear
    I normally run on a balanced power setting (electricity is expensive where I am) and that profile got messed up too.  I ended up having to create a new profile entirely to get my CPU back into good shape, resetting the profile to defaults in the power options did nothing.

    I've installed Valkyrie but only played it once, rebooted a few times in there as well.  Nothing is actually using 100% of the CPU, it's just stuck in a high power state.

    System is:
    - Windows 10, 64-bit, current updates. 
    - Core i7-4790k
    - Radeon R9-390 (16.15.2211 driver)
    - Oculus CV1
  • I'll try that when I get home Alex. I hate to think I'm losing some performance just because I don't want my CPU and coolers being over worked all the time. I'm not touching Eve Valkyrie again though. Fortunately for me it's not a game I was too excited about.
  • bizjerbizjer Posts: 118
    Art3mis
    Same here, pc runs fine but fans blowing like billyo. Will try the power plan!
  • bizjerbizjer Posts: 118
    Art3mis
    switching to balanced just dropped cpu load to 1% phew.

  • bizjerbizjer Posts: 118
    Art3mis
    and booting the oculus home just put it back at 100% but quitting home dropped it again. bug maybe.
  • ima747ima747 Posts: 25
    edited March 2016
    Seeing the same issue today all of a sudden. Switching to balanced also fixed it for me. Looking at process monitor it looks like the service is going crazy checking registry keys. Certainly seems like a bug. The 100% CPU usage didn't appear to actually slow down my computer, but it was showing at 100% usage on all cores (real and virtual). Definitely a bug, and a pretty ugly one too. Looks like it was basically taking 100% of the systems sleep time, so it was flogging the registry instead of idling. No idea why balanced power settings quiets it down.
    Also to note, I installed eve valkyrie last night so perhaps eve is causing the service to freak out? Odd coincidence if not.
  • emperorofspaceemperorofspace Posts: 1
    NerveGear
    I want to chime in and say this is happening to me too. I noticed my fans were blowing really hot air, and I checked my CPU temp and noticed it was getting pretty hot. I looked at task manager and saw that I was using 100% CPU. I have a hyperthreaded hexacore i7, so that pretty much never happens. I suspected it might be the Oculus, but killing the processes did not fix it. Switching my power plan to balanced, however, did seem to fix it.
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    edited March 2016
    I will have someone investigate this. Can you please provide the log zip created by "OculusLogGatherer.exe" in "C:\Program Files (x86)\Oculus\Support\oculus-diagnostics"? Thanks.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • ima747ima747 Posts: 25
    Logs sent directly. not comfortable posting all that system info publicly.
  • jaydsadjaydsad Posts: 1
    Same issue here! It was driving me crazy so thanks for posting this. I even went so far as to uninstall all the Oculus stuff and my new USB 3.0 pci-e card in case that was causing it. In the end just changing to Balanced from High Performance in Windows Power Options fixed it as suggested here.
  • macd81macd81 Posts: 11
    NerveGear
    Changing the plans is addressing a symptom of something getting changed in the plan itself.  Use the 'restore default settings for this plan' option also fixes it.

    So relieved I found this thread today.  Like others, it caught me unaware last night and I wasted 2-3 hours of my life worrying about and rooting around for a virus and then going thru driver settings, bootup settings, services, I had an nvidia driver update so I spent time downgrading and then re-upgrding, unplugging stuff, etc etc. I saw task manager pegged at 100% with various processes at 100%, while resource monitor showed CPU at 100% but no specific process using it - but then other things like CPU-Z showed nothing going on with the actual cores.

    Glad to have a workaround for this issue, but now I also have to worry about turning back on a variety of stuff I tweaked in the process of fighting this and hope I don't wind up with a new issue due to shutting off a service or boot program I needed and forgot to reenable, or the like.

    OculusVR Guys:  Please issue a patch or advisory on something. If this threw me for a loop, it will certainly do so for others. Not confidence inspiring. Glad to find the solution regardles..
  • FishloveFishlove Posts: 25
    Brain Burst
    edited March 2016
    Hey @macd81, this is what I was thinking as well. Luckily restoring the plan works for me.
    Coffee, coding, exploring the universe
  • ima747ima747 Posts: 25
    Resetting the defaults on the high performance plan does quiet the CPU down for me as well. Side note: my system won't auto sleep any more. OVRServer_x64.exe maintains the displays active even when the oculus store is closed, I'm guessing it's related to all the hammering it tries to do after borking the power plan.
  • czero69czero69 Posts: 1
    NerveGear
    edited April 2016
    Hello, I have similar problem with DK2. When the rift is off, CPU works at 100%. I am looking into it.
    EDIT:
    I had similar issue, my cpu was at 100%, until i play any aplication in the rift, then it came back to normal usage 5-20%. It eventually dissapeared, now my cpu works fine when the rift is off. I don't know what was the issue.
    EDIT2:
    My issue now, dk2, 0.8 runtime. I have OculusConfigUtil.exe disabled in startup manager. When I run computer cpu works at 100% all the time. When I run OculusConfigUtil and TURN ON the rift, everything is getting fine and cpu is working at ~4%. And it's not april's fools joke :)
    EDIT3:
    Can confirm this fixes the issue:
    Power Options -> Change plan settings -> Restore default settings for this plan.
  • Can confirm this fixes the issue:
    Power Options -> Change plan settings -> Restore default settings for this plan.
  • tmektmek Posts: 103
    Hiro Protagonist
    edited April 2016
    While the "balanced" work around seems to work this is concerning to me because I uninstalled Oculus software and unplugged all CV1 hardware and still get 100% even after shutting off and powering on (when not in balanced)

    When not in "balanced" my CPU shows ~85% on 2700k i7 yet nothing is really running.

    My CPU temp was running at 98 deg c constantly due to this.

    Edit:  Ok so doing the plan reset above fixes it even when in high performance profile.  But does this mean Oculus software is quietly changing my Windows power performance profiles on installation?  That seems... not right.
  • ThreeDeeVisionThreeDeeVision Posts: 2,087
    edited April 2016
    This just happened to me as well.  My CPU was running about 10 degrees higher than usual and my fans were making some serious noise.  Everything was perfect until I tried Eve.  Apon exciting Eve my CPU was showing maxed out in task manager.  I tried a reboot and it was still maxed when I returned.  Setting the power mode to balance fixed it (thankfully, that was scary).

    Update: Set the performance mode back to defaults and now performance mode is working again (which is good because that means my overclock is on).  Thanks for the heads up on that @tmek 
    i7 5960X @ 3.8 GHz | Corsair Vengeance LPX 16GB DDR4 PC2800 | GTX Titan X Pascal | Win 10 64 bit | Asus ROG PG348Q | EVGA X99 Classified
  • ColinBColinB Posts: 236
    Nexus 6
    Good thing you guys are developers !
    Imagine a "consumer" coming across this sort of thing.
    I wonder how long it will be before we can just actually use VR out of the box?
    CV5 perhaps?
  • pittsburghjoepittsburghjoe Posts: 514
    Art3mis
    i7 skylake, EVGA Classified, 2 EVGA 980 sc's, Thermaltake TR2 RX(1000W), 32GB DDR4, Win 10 on an SSD
  • Andersenc159753Andersenc159753 Posts: 8
    NerveGear
    Yep, switched to balanced and it fixed it for me, same issue.
  • PuzzlarPuzzlar Posts: 1
    NerveGear
    So it looks like Eve was patched to fix the issue, but it doesn't repair the plan settings if the bug has already happened.

    Any plan to do this?  It seems pretty bad to abandon who knows how many unfortunate people sitting with 100% CPU utilization who haven't noticed or don't know how to fix it.
  • OO7zmanOO7zman Posts: 1
    I had the same problem. CPU at 100% usage, but 99% system idle process. it was cooking my CPU at 85c, but after switching from power saver to balanced mode it fixed the problem. i now have 1% CPU usage at idle and temps back down to normal (around 35c)
  • rmcclellandrmcclelland Posts: 146
    Art3mis
    edited April 2016
    I had this same issue and it cost me $30 since I though I wasn't getting enough CPU cooling and replaced my stock cooler.  Waste of time and money.  I guess that is the cost of the cutting edge!  No I can push my 2500K even harder...
  • DavidCDavidC Posts: 39
    Brain Burst
    This happened to me this week, but only after I got my CV1. I'd been running 1.3 and 1.3.1 on my DK2 with no issue. When I switched it for a CV1 I started to get the 100% CPU usage. I kept killing whatever process Task Manager was blaming at the time, but the total load stayed at 100%.

    I went semi-extreme and just did a fresh OS reinstall. My PC was a new build in January so apart from my Oculus software, Steam and Adobe CC I didn't have anything on there that I was going to lose. 

    Now it works without trying to cook a CPU. I'll flag if it starts up again.
  • MattasmackMattasmack Posts: 2
    NerveGear
    I ran into this for the first time after trying Eve Valkyrie recently, and I want to highlight the article linked by pittsburghjoe up above.  The problem is that Eve Valkyrie (and maybe other programs too) changes a power setting to prevent the CPU from idling when it is running, and then fails to change the setting back again when it exits.

    You don't need to change any hardware or reinstall anything.  Switching power plans or resetting your current power plan resets the setting and fixes the problem, but a better solution is the pair of commands listed in the article.  You can put them into a little two-line batch file and put a link to it on your desktop.  Then when the problem surfaces, just double click on it to run the batch file.

    The commands are:
    PowerCfg /SETACVALUEINDEX SCHEME_CURRENT SUB_PROCESSOR IDLEDISABLE 000
    PowerCfg /SETACTIVE SCHEME_CURRENT

    Probably the easiest fix, short of CCP fixing their software.
Sign In or Register to comment.