New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

No sound in Farlands with CV1

Rich.OkereRich.Okere Posts: 5
NerveGear
PC - 3570K / 16GB / 980Ti / Win10

I'm getting no sound in the headset, but only with Farlands so far. I have checked sound settings in the Devices tab, reinstalled Farlands, and tried switching my default audio device to the Rift Headphones, with no luck.

The only other playback device I have is a USB DAC.

If I leave the Playback Devices window open, I can see that it seems to be trying to play sound, but nothing is playing.

Other apps and games don't seem to have this problem.

Any ideas?

Comments

  • Rich.OkereRich.Okere Posts: 5
    NerveGear
    UPDATE - I was able to solve this.

    This was especially weird because audio some apps worked, and some didn't.

    Turns out that the Rift playback device was set to the wrong Default Format - it was set to 16/48; as soon as I switched it to 16/44, audio popped right back on.
  • ZonetripperZonetripper Posts: 19
    NerveGear
    edited April 2016
    Thank you so much, this solved my issue as well. I was getting audio for about two minutes before it just stopped. Using my old headset worked fine but setting the rift speakers to 44k seems to have fixed them. Less cables to worry about :D
     - Edit -
     celebrated too early, the problem is still there, but for some reason it now seems like it takes longer for the sound to disappear.
  • servili007servili007 Posts: 14
    NerveGear
    I would leave the default format as is. What you did was force the audio device to reset, which you can achieve by right clicking it in the volume mixer and disabling then enabling it (might need to right click in the empty space to turn on visibility of disabled devices). It is frustrating, but at least it seems like a software/firmware issue that they'll be able to work out, hopefully soon.
  • OimannOimann Posts: 6
    NerveGear
    I have the same Problem as Zonetripper my headphones run fine for some minutes and then there is no Sound. When i Close Oculus home and start it again, the Sound is back. I also Hope this is an Software/Firmware issue witch will be fixed soon and no hardwareproblem
  • ZonetripperZonetripper Posts: 19
    NerveGear
    Oimann: Do you have an external soundcard of some kind? I have a Line 6 soundcard an thought it might be the problem. I have tried disabling it and the problem remains, so probably not.
  • Rich.OkereRich.Okere Posts: 5
    NerveGear
    As an update on my situation:

    Farlands via Oculus Home: This was solved by going into Playback Devices and changing the audio format to 16/44 (it defaulted to 16/48).

    Euro Truck Simulator 2 via Steam - i was again getting no sound. This was apparently solved in Playback Device by unchecking "Allow applications take exclusive control of this device".

    Maybe Oculus Home is hogging the audio device and not playing well with Steam games, but in any event I hope this helps someone out there.

  • TFWPrimusTFWPrimus Posts: 10
    NerveGear
    We've been seeing a number of audio issues now and no comments from Oculus. It would be really nice to hear from them considering how much immersion breaking it is to not have audio work correctly.
  • jmt316jmt316 Posts: 1
    NerveGear
    Just for everyone else out there, the following is my instructions for how I got the sound to work with the Rift in virtually everything I play.  I was having the same audio issues so I felt compelled to share once I solved the mystery.  I know some of you have already alluded to the solution above but figured the step-by-step will help someone else.  Please feel free to modify my instructions if you have an easier way to do it.  I won't be offended!

    1) Open your playback devices, set your rift headset as the default device.
    2) Right click on your Rift audio device, and select Properties
    3) Select the tab that reads Advanced, and change the drop down to CD Quality. (I believe the default is DVD quality.) 
    4) Open your Oculus Software. Select the settings Icon in the upper right. (Looks like a gear.) 
    5) Select Devices on the left, then select the headset. In the "VR Audio Output" change it from Rift Headset to "Windows Default." 
    6) Launch your game.

    Hopefully this works for you. Just as a side note, I only recently figured this all out and one thing I noticed as I type this out is when I exit the game (Skyrim, in my case) windows resets the default speakers from Rift to Regular Speakers, so it seems you might need to set the default headphones as the rift every time you want to launch a game. I hope this fixes your problems. Good luck everybody!
  • kernowkernow Posts: 733
    Trinity
    Where is this "Playback Devices" everyone above is mentioning? Are you referring to Sound settings in the Control Panel (the first tab after opening the Sound settings is called "Playback")? If so, Rift doesn't show up as a device under the Playback tab under Sound.
  • DocsteelDocsteel Posts: 31
    Brain Burst
    @kernow ;

    If you're in Windows 7, go to control panel->hardware and sound and you can then set the device as default and follow from there.
  • EraromikEraromik Posts: 2
    NerveGear
    If you are still having sound issues it can be your usb 3 controller getting overloaded. Just put the headset in usb 2 instead, shouldn't affect performance. Leave 2 sensors in usb 3.
  • daricksterdarickster Posts: 2
    NerveGear
    jmt316 said:
    Just for everyone else out there, the following is my instructions for how I got the sound to work with the Rift in virtually everything I play.  I was having the same audio issues so I felt compelled to share once I solved the mystery.  I know some of you have already alluded to the solution above but figured the step-by-step will help someone else.  Please feel free to modify my instructions if you have an easier way to do it.  I won't be offended!

    1) Open your playback devices, set your rift headset as the default device.
    2) Right click on your Rift audio device, and select Properties
    3) Select the tab that reads Advanced, and change the drop down to CD Quality. (I believe the default is DVD quality.) 
    4) Open your Oculus Software. Select the settings Icon in the upper right. (Looks like a gear.) 
    5) Select Devices on the left, then select the headset. In the "VR Audio Output" change it from Rift Headset to "Windows Default." 
    6) Launch your game.

    Hopefully this works for you. Just as a side note, I only recently figured this all out and one thing I noticed as I type this out is when I exit the game (Skyrim, in my case) windows resets the default speakers from Rift to Regular Speakers, so it seems you might need to set the default headphones as the rift every time you want to launch a game. I hope this fixes your problems. Good luck everybody!
    jmt316 said:
    Just for everyone else out there, the following is my instructions for how I got the sound to work with the Rift in virtually everything I play.  I was having the same audio issues so I felt compelled to share once I solved the mystery.  I know some of you have already alluded to the solution above but figured the step-by-step will help someone else.  Please feel free to modify my instructions if you have an easier way to do it.  I won't be offended!

    1) Open your playback devices, set your rift headset as the default device.
    2) Right click on your Rift audio device, and select Properties
    3) Select the tab that reads Advanced, and change the drop down to CD Quality. (I believe the default is DVD quality.) 
    4) Open your Oculus Software. Select the settings Icon in the upper right. (Looks like a gear.) 
    5) Select Devices on the left, then select the headset. In the "VR Audio Output" change it from Rift Headset to "Windows Default." 
    6) Launch your game.

    Hopefully this works for you. Just as a side note, I only recently figured this all out and one thing I noticed as I type this out is when I exit the game (Skyrim, in my case) windows resets the default speakers from Rift to Regular Speakers, so it seems you might need to set the default headphones as the rift every time you want to launch a game. I hope this fixes your problems. Good luck everybody!
    jmt316 said:
    Just for everyone else out there, the following is my instructions for how I got the sound to work with the Rift in virtually everything I play.  I was having the same audio issues so I felt compelled to share once I solved the mystery.  I know some of you have already alluded to the solution above but figured the step-by-step will help someone else.  Please feel free to modify my instructions if you have an easier way to do it.  I won't be offended!

    1) Open your playback devices, set your rift headset as the default device.
    2) Right click on your Rift audio device, and select Properties
    3) Select the tab that reads Advanced, and change the drop down to CD Quality. (I believe the default is DVD quality.) 
    4) Open your Oculus Software. Select the settings Icon in the upper right. (Looks like a gear.) 
    5) Select Devices on the left, then select the headset. In the "VR Audio Output" change it from Rift Headset to "Windows Default." 
    6) Launch your game.

    Hopefully this works for you. Just as a side note, I only recently figured this all out and one thing I noticed as I type this out is when I exit the game (Skyrim, in my case) windows resets the default speakers from Rift to Regular Speakers, so it seems you might need to set the default headphones as the rift every time you want to launch a game. I hope this fixes your problems. Good luck everybody!
    jmt316 said:
    Just for everyone else out there, the following is my instructions for how I got the sound to work with the Rift in virtually everything I play.  I was having the same audio issues so I felt compelled to share once I solved the mystery.  I know some of you have already alluded to the solution above but figured the step-by-step will help someone else.  Please feel free to modify my instructions if you have an easier way to do it.  I won't be offended!

    1) Open your playback devices, set your rift headset as the default device.
    2) Right click on your Rift audio device, and select Properties
    3) Select the tab that reads Advanced, and change the drop down to CD Quality. (I believe the default is DVD quality.) 
    4) Open your Oculus Software. Select the settings Icon in the upper right. (Looks like a gear.) 
    5) Select Devices on the left, then select the headset. In the "VR Audio Output" change it from Rift Headset to "Windows Default." 
    6) Launch your game.

    Hopefully this works for you. Just as a side note, I only recently figured this all out and one thing I noticed as I type this out is when I exit the game (Skyrim, in my case) windows resets the default speakers from Rift to Regular Speakers, so it seems you might need to set the default headphones as the rift every time you want to launch a game. I hope this fixes your problems. Good luck everybody!
    jmt316 said:
    Just for everyone else out there, the following is my instructions for how I got the sound to work with the Rift in virtually everything I play.  I was having the same audio issues so I felt compelled to share once I solved the mystery.  I know some of you have already alluded to the solution above but figured the step-by-step will help someone else.  Please feel free to modify my instructions if you have an easier way to do it.  I won't be offended!

    1) Open your playback devices, set your rift headset as the default device.
    2) Right click on your Rift audio device, and select Properties
    3) Select the tab that reads Advanced, and change the drop down to CD Quality. (I believe the default is DVD quality.) 
    4) Open your Oculus Software. Select the settings Icon in the upper right. (Looks like a gear.) 
    5) Select Devices on the left, then select the headset. In the "VR Audio Output" change it from Rift Headset to "Windows Default." 
    6) Launch your game.

    Hopefully this works for you. Just as a side note, I only recently figured this all out and one thing I noticed as I type this out is when I exit the game (Skyrim, in my case) windows resets the default speakers from Rift to Regular Speakers, so it seems you might need to set the default headphones as the rift every time you want to launch a game. I hope this fixes your problems. Good luck everybody!
    jmt316 said:
    Just for everyone else out there, the following is my instructions for how I got the sound to work with the Rift in virtually everything I play.  I was having the same audio issues so I felt compelled to share once I solved the mystery.  I know some of you have already alluded to the solution above but figured the step-by-step will help someone else.  Please feel free to modify my instructions if you have an easier way to do it.  I won't be offended!

    1) Open your playback devices, set your rift headset as the default device.
    2) Right click on your Rift audio device, and select Properties
    3) Select the tab that reads Advanced, and change the drop down to CD Quality. (I believe the default is DVD quality.) 
    4) Open your Oculus Software. Select the settings Icon in the upper right. (Looks like a gear.) 
    5) Select Devices on the left, then select the headset. In the "VR Audio Output" change it from Rift Headset to "Windows Default." 
    6) Launch your game.

    Hopefully this works for you. Just as a side note, I only recently figured this all out and one thing I noticed as I type this out is when I exit the game (Skyrim, in my case) windows resets the default speakers from Rift to Regular Speakers, so it seems you might need to set the default headphones as the rift every time you want to launch a game. I hope this fixes your problems. Good luck everybody!
    jmt316 said:
    Just for everyone else out there, the following is my instructions for how I got the sound to work with the Rift in virtually everything I play.  I was having the same audio issues so I felt compelled to share once I solved the mystery.  I know some of you have already alluded to the solution above but figured the step-by-step will help someone else.  Please feel free to modify my instructions if you have an easier way to do it.  I won't be offended!

    1) Open your playback devices, set your rift headset as the default device.
    2) Right click on your Rift audio device, and select Properties
    3) Select the tab that reads Advanced, and change the drop down to CD Quality. (I believe the default is DVD quality.) 
    4) Open your Oculus Software. Select the settings Icon in the upper right. (Looks like a gear.) 
    5) Select Devices on the left, then select the headset. In the "VR Audio Output" change it from Rift Headset to "Windows Default." 
    6) Launch your game.

    Hopefully this works for you. Just as a side note, I only recently figured this all out and one thing I noticed as I type this out is when I exit the game (Skyrim, in my case) windows resets the default speakers from Rift to Regular Speakers, so it seems you might need to set the default headphones as the rift every time you want to launch a game. I hope this fixes your problems. Good luck everybody!
    That worked for me! thanks
  • daricksterdarickster Posts: 2
    NerveGear
    jmt316 said:
    Just for everyone else out there, the following is my instructions for how I got the sound to work with the Rift in virtually everything I play.  I was having the same audio issues so I felt compelled to share once I solved the mystery.  I know some of you have already alluded to the solution above but figured the step-by-step will help someone else.  Please feel free to modify my instructions if you have an easier way to do it.  I won't be offended!

    1) Open your playback devices, set your rift headset as the default device.
    2) Right click on your Rift audio device, and select Properties
    3) Select the tab that reads Advanced, and change the drop down to CD Quality. (I believe the default is DVD quality.) 
    4) Open your Oculus Software. Select the settings Icon in the upper right. (Looks like a gear.) 
    5) Select Devices on the left, then select the headset. In the "VR Audio Output" change it from Rift Headset to "Windows Default." 
    6) Launch your game.

    Hopefully this works for you. Just as a side note, I only recently figured this all out and one thing I noticed as I type this out is when I exit the game (Skyrim, in my case) windows resets the default speakers from Rift to Regular Speakers, so it seems you might need to set the default headphones as the rift every time you want to launch a game. I hope this fixes your problems. Good luck everybody!
    jmt316 said:
    Just for everyone else out there, the following is my instructions for how I got the sound to work with the Rift in virtually everything I play.  I was having the same audio issues so I felt compelled to share once I solved the mystery.  I know some of you have already alluded to the solution above but figured the step-by-step will help someone else.  Please feel free to modify my instructions if you have an easier way to do it.  I won't be offended!

    1) Open your playback devices, set your rift headset as the default device.
    2) Right click on your Rift audio device, and select Properties
    3) Select the tab that reads Advanced, and change the drop down to CD Quality. (I believe the default is DVD quality.) 
    4) Open your Oculus Software. Select the settings Icon in the upper right. (Looks like a gear.) 
    5) Select Devices on the left, then select the headset. In the "VR Audio Output" change it from Rift Headset to "Windows Default." 
    6) Launch your game.

    Hopefully this works for you. Just as a side note, I only recently figured this all out and one thing I noticed as I type this out is when I exit the game (Skyrim, in my case) windows resets the default speakers from Rift to Regular Speakers, so it seems you might need to set the default headphones as the rift every time you want to launch a game. I hope this fixes your problems. Good luck everybody!
    jmt316 said:
    Just for everyone else out there, the following is my instructions for how I got the sound to work with the Rift in virtually everything I play.  I was having the same audio issues so I felt compelled to share once I solved the mystery.  I know some of you have already alluded to the solution above but figured the step-by-step will help someone else.  Please feel free to modify my instructions if you have an easier way to do it.  I won't be offended!

    1) Open your playback devices, set your rift headset as the default device.
    2) Right click on your Rift audio device, and select Properties
    3) Select the tab that reads Advanced, and change the drop down to CD Quality. (I believe the default is DVD quality.) 
    4) Open your Oculus Software. Select the settings Icon in the upper right. (Looks like a gear.) 
    5) Select Devices on the left, then select the headset. In the "VR Audio Output" change it from Rift Headset to "Windows Default." 
    6) Launch your game.

    Hopefully this works for you. Just as a side note, I only recently figured this all out and one thing I noticed as I type this out is when I exit the game (Skyrim, in my case) windows resets the default speakers from Rift to Regular Speakers, so it seems you might need to set the default headphones as the rift every time you want to launch a game. I hope this fixes your problems. Good luck everybody!
    jmt316 said:
    Just for everyone else out there, the following is my instructions for how I got the sound to work with the Rift in virtually everything I play.  I was having the same audio issues so I felt compelled to share once I solved the mystery.  I know some of you have already alluded to the solution above but figured the step-by-step will help someone else.  Please feel free to modify my instructions if you have an easier way to do it.  I won't be offended!

    1) Open your playback devices, set your rift headset as the default device.
    2) Right click on your Rift audio device, and select Properties
    3) Select the tab that reads Advanced, and change the drop down to CD Quality. (I believe the default is DVD quality.) 
    4) Open your Oculus Software. Select the settings Icon in the upper right. (Looks like a gear.) 
    5) Select Devices on the left, then select the headset. In the "VR Audio Output" change it from Rift Headset to "Windows Default." 
    6) Launch your game.

    Hopefully this works for you. Just as a side note, I only recently figured this all out and one thing I noticed as I type this out is when I exit the game (Skyrim, in my case) windows resets the default speakers from Rift to Regular Speakers, so it seems you might need to set the default headphones as the rift every time you want to launch a game. I hope this fixes your problems. Good luck everybody!
    jmt316 said:
    Just for everyone else out there, the following is my instructions for how I got the sound to work with the Rift in virtually everything I play.  I was having the same audio issues so I felt compelled to share once I solved the mystery.  I know some of you have already alluded to the solution above but figured the step-by-step will help someone else.  Please feel free to modify my instructions if you have an easier way to do it.  I won't be offended!

    1) Open your playback devices, set your rift headset as the default device.
    2) Right click on your Rift audio device, and select Properties
    3) Select the tab that reads Advanced, and change the drop down to CD Quality. (I believe the default is DVD quality.) 
    4) Open your Oculus Software. Select the settings Icon in the upper right. (Looks like a gear.) 
    5) Select Devices on the left, then select the headset. In the "VR Audio Output" change it from Rift Headset to "Windows Default." 
    6) Launch your game.

    Hopefully this works for you. Just as a side note, I only recently figured this all out and one thing I noticed as I type this out is when I exit the game (Skyrim, in my case) windows resets the default speakers from Rift to Regular Speakers, so it seems you might need to set the default headphones as the rift every time you want to launch a game. I hope this fixes your problems. Good luck everybody!
    jmt316 said:
    Just for everyone else out there, the following is my instructions for how I got the sound to work with the Rift in virtually everything I play.  I was having the same audio issues so I felt compelled to share once I solved the mystery.  I know some of you have already alluded to the solution above but figured the step-by-step will help someone else.  Please feel free to modify my instructions if you have an easier way to do it.  I won't be offended!

    1) Open your playback devices, set your rift headset as the default device.
    2) Right click on your Rift audio device, and select Properties
    3) Select the tab that reads Advanced, and change the drop down to CD Quality. (I believe the default is DVD quality.) 
    4) Open your Oculus Software. Select the settings Icon in the upper right. (Looks like a gear.) 
    5) Select Devices on the left, then select the headset. In the "VR Audio Output" change it from Rift Headset to "Windows Default." 
    6) Launch your game.

    Hopefully this works for you. Just as a side note, I only recently figured this all out and one thing I noticed as I type this out is when I exit the game (Skyrim, in my case) windows resets the default speakers from Rift to Regular Speakers, so it seems you might need to set the default headphones as the rift every time you want to launch a game. I hope this fixes your problems. Good luck everybody!
    jmt316 said:
    Just for everyone else out there, the following is my instructions for how I got the sound to work with the Rift in virtually everything I play.  I was having the same audio issues so I felt compelled to share once I solved the mystery.  I know some of you have already alluded to the solution above but figured the step-by-step will help someone else.  Please feel free to modify my instructions if you have an easier way to do it.  I won't be offended!

    1) Open your playback devices, set your rift headset as the default device.
    2) Right click on your Rift audio device, and select Properties
    3) Select the tab that reads Advanced, and change the drop down to CD Quality. (I believe the default is DVD quality.) 
    4) Open your Oculus Software. Select the settings Icon in the upper right. (Looks like a gear.) 
    5) Select Devices on the left, then select the headset. In the "VR Audio Output" change it from Rift Headset to "Windows Default." 
    6) Launch your game.

    Hopefully this works for you. Just as a side note, I only recently figured this all out and one thing I noticed as I type this out is when I exit the game (Skyrim, in my case) windows resets the default speakers from Rift to Regular Speakers, so it seems you might need to set the default headphones as the rift every time you want to launch a game. I hope this fixes your problems. Good luck everybody!
    That worked for me! thanks
Sign In or Register to comment.