New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

ASW causes screen flickering on the edges

assettomioassettomio Posts: 413
Trinity
ASW works great, it enables me to play project cars on max settings (doesn't seem to make a difference on edge of nowhere though).
But I've noticed something very annoying, when looking at a bright area, for example this webpage in virtual desktop, the screen will start to flicker very annoyingly on the left edges of both screens in the headset if ASW is enabled. (app forced to 45fps and asw enabled).
As soon as I switch asw off though, and let the app go back to the native 90fps, the flickering is immediatly gone..
Is anyone else seeing this too?

Comments

  • DeanOfTheDriversDeanOfTheDrivers Posts: 144 Oculus Staff
    Good catch with Virtual Desktop. Because of how it uses layers ASW is not being applied to the images and you're seeing 45 fps with ATW alone. I'll look into what Virtual Desktop is doing and get it operating under ASW.
  • assettomioassettomio Posts: 413
    Trinity
    The image still seems smooth though when it goes down to 45fps, are you sure it doesn't use asw?
  • KillCardKillCard Posts: 1,078
    Wintermute
    Sorry for the ignorance,

    What is ASW?
  • assettomioassettomio Posts: 413
    Trinity
    Asynchronous space warp, from what I understood of it, it's supposed to cut the app framerate in half and force it to 45fps, and then after each frame insert a frame based on guessing what will come next, making the steady 45fps look like a steady 90fps at half the effort
  • KillCardKillCard Posts: 1,078
    Wintermute
    Asynchronous space warp, from what I understood of it, it's supposed to cut the app framerate in half and force it to 45fps, and then after each frame insert a frame based on guessing what will come next, making the steady 45fps look like a steady 90fps at half the effort
    Thanks,

    How do I know if I have it enabled or not?

    I havent been updating my OSVR client .. I think its still at v1.6, so maybe I don't have it?
  • mbze430mbze430 Posts: 567
    Trinity
    For now to enable ASW you have to edit the registry in Windows 10.  So if you had to ask that, then you are not using ASW.
    i7-6900k @ 4.4ghz | Kingston Hyper 64GB DDR4 @ 3000mhz | SLI Nvidia Titan Xp | ASUS Strix Gaming X99 | Samsung 950 Pro 512GB PCIe/NVMe | 3x Samsung Pro 850 512GB RAID0 | 2x Samsung Pro 850 1TB RAID1 | Corsair AX1500i | Custom Water Cooling | Thermaltake Core X5
Sign In or Register to comment.