New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Oculus setup tool can't connect to server

AlanLiuAlanLiu Posts: 6
NerveGear
It displays "Looks like we can't reach the Oculus server. Please check your connection.". I'm in China. Does Oculus limit the countries/regions which can connect to server.
«1

Comments

  • RS_3RS_3 Posts: 1
    NerveGear
    edited April 2016
    it's definitely not a regional problem: had  the same issue here in NYC.
    Turning off Windows firewall solved the problem for me. Running windows 10.
  • AlanLiuAlanLiu Posts: 6
    NerveGear
    Thank you for replying. My case is due to DNS cache pollution. I modified "hosts" file to solve the problem.
  • imoonnerimoonner Posts: 1
    Can u tell me How ?! 
  • AlanLiuAlanLiu Posts: 6
    NerveGear
    Add "31.13.95.61       graph.oculus.com" to the end of "hosts" file.

  • the same problem, and i don't know how to fix that
  • arwenlwcarwenlwc Posts: 4
    NerveGear
    I am having the same problem. still can't reach the oculus server after I cleaned the dns, modified the hosts file, turned off the firewall....
  • frenchcommanderfrenchcommander Posts: 1
    NerveGear
    oculus tech support sucks . $599 for a device that you can't even call someone on the phone
  • luke73tntluke73tnt Posts: 1
    NerveGear
    Been having the problem and don't know how to fix it
  • SpencerVRSpencerVR Posts: 1
    NerveGear
    Just had this issue today. For me the problem was that i didnt have enough space free on my c drive, but it still gives the "cant connect" error. You need ~5G free
    YOU ARE MY HERO
  • DSFLDSFL Posts: 1
    NerveGear
    Worked for me also. Same Error Message. Had less than 5GB of disk space on C:\. Once I had 5,6GB free the installation worked
  • mrmclaughlinmrmclaughlin Posts: 1
    NerveGear
    yep .. same solution worked... need more then 5 gigs free... 
  • CaptainCodexCaptainCodex Posts: 1
    NerveGear
    Be carfull oculus setup can't work if your C: partition is on DYNAMIC mode . i use EaseUS partition master (pro version) for change my partition mode ( Basic MBR ) .
  • AdomicAdomic Posts: 1
    NerveGear
    edited January 2017
    Same thing here, I just reinstalled WIndows and it won't connect to the server to install.  I've cleared the dns, made sure it had plenty of permissions, turned off anti-virus and firewall, run as administrator, added the address to the dns host file, tried on other computers on my home network..  but the fact the graph address has an error mentioning an "Access Token" makes me think we need those reissued from Oculus or something.

       "error": {
          "message": "Invalid OAuth 2.0 Access Token",
          "type": "OCApiException",
          "code": 190,
          "fbtrace_id": "FAzR7xy1fYq"
       }
    }
    I went back to Win7 from 10 after attempting to install PS3 blutooh drivers and they became very much corrupted .. not sure if it was the Xbox blutooth interfering but anyway, I'm hoping someone will chime in about the tokens

    UPdate,
      It was the .Net drivers, just updated to 4.6.2 and now it's downloading
  • Timothy3.14Timothy3.14 Posts: 1
    NerveGear
    For me it was the same. I had to update .Net drivers to version 4.6.2. As Rift Software Troubleshooting says U have to install .NET Framework 4.5 if U use Windows 7.
    https://product-guides.oculus.com/en-us/documentation/rift/latest/concepts/rgsg-3-ts-setup-troubleshooting/

  • sany5dsany5d Posts: 1
    NerveGear
    solved with .net update
  • Eric0wns916Eric0wns916 Posts: 1
    NerveGear
    Be carfull oculus setup can't work if your C: partition is on DYNAMIC mode . i use EaseUS partition master (pro version) for change my partition mode ( Basic MBR ) .
    This was exactly my issue. EaseUS worked like a charm. Soon as I switched it to a Basic disk it installed right away. I never would have thought of this if not for you. Thanks!!!
  • cygnusx7cygnusx7 Posts: 1
    NerveGear
    edited March 2017
    I had this cannot connect to server issue first time setting up a rift on win7 64bit. Proceeding with Timothy3.14's fix worked for me.
    This thread comes up first in a google search so I felt like I should share what fixed the issue on my system.

    Please note: this is what was required for my win7 64bit system.
    By updating to KB2858728 the Oculus setup software indicated my system needed KB2670838
    and KB3033929 to proceed with setup.

    Every system is in a different state of updates. I know I am guilty of falling behind on mine.

    Oculus Rift is an incredible experience in Assetto Corsa.

  • przecinekprzecinek Posts: 596
    Nexus 6
    edited May 2017
    Case of 5gb of free space needed. It's been over a year since (topic created in March 2016) and I see that the incorrect message still hasn't been fixed ... good job Oculus. 
  • birito76birito76 Posts: 1
    NerveGear
    I have tried all of the above except for chaging my disk from dynamic to basic.  I would have to reinstall my OS. right? 
  • jilay.pandyajilay.pandya Posts: 1
    NerveGear
    Worked for me finally as well after uninstalling all the previous oculus related software items and having 5.5GB of free space on C:\ drive

  • goldrush76goldrush76 Posts: 45
    Brain Burst
    I tried the host file edit first and then saw the free space issue mentioned. Freeing up enough space on C:\ resolved the problem.
  • RemyJesseRemyJesse Posts: 1
    NerveGear
    I tried EVERYTHING on this list. In the end I kept feeling that it was the disk space issue even though I had over 6 GB's of free space on my my C:\ drive. This because I felt the installer didnt't even try to connect with anything. It went straight to no connection every time. So I decided to free up some more space and when I had 7.5 Gb's... It worked! So keep in mind that the 5GB's might not be enough for everybody, or maybe the data to be downloaded is bigger nowadays. Go for 10 GB if you want to be sure!
  • MainFraggerMainFragger Posts: 15
    NerveGear
    If its strictly a space issue, I have close to 16 gigs, and I am still getting the error.  I am going to try to do updates on Win10 right now to see if that helps.  Because otherwise, none of this makes sense to me...
  • MainFraggerMainFragger Posts: 15
    NerveGear
    OK..so, I have 16 Gbytes of space, I turned off all firewalls and virus protection, and it still doesn't work.  I can tell its never even getting to a point where it is installing software.  After I agree to the terms of service, it immediately gives me the error.  I checked, and nothing new actually installs on my system.
  • HTCVIVEISBETTER03HTCVIVEISBETTER03 Posts: 1
    NerveGear
    1. I wanted to download this for revive to play lone echo, but I am having the same issue as MainFragger. This is starting to make me hate oculus even more. This is just so fucking un user friendly and just annoying. Can anyone please tell me if I am doing something wrong because I see most people and they download it just fine. 
  • Ed3manEd3man Posts: 5
    NerveGear
    added the install program to the firewall safe list and it worked fine
Sign In or Register to comment.