Oculus Update November 11th, Oculusvr.exe now using 25% CPU while wearing headset?!?! — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Oculus Update November 11th, Oculusvr.exe now using 25% CPU while wearing headset?!?!

StreetPreacherStreetPreacher Posts: 224
Nexus 6
I never checked what percentage of CPU it used before today's update, but now my games are running much worse than they were yesterday!!!!!!!?!?!?!??

Is there ANY WAY to revert back to the previous build?!

So much for my plan to do some VR gaming tonight.. 

Comments

  • StreetPreacherStreetPreacher Posts: 224
    Nexus 6
    edited November 2016
    with Oculus Home running and the hmd off, it's at 0% CPU.  As soon as you put the hmd on CPU usage jumps to between 21-23%...  This can't be how much CPU power it was using before can it?

    And it's Oculus App Version 1.10.0.308075 (1.10.0.306913) 

    Yesterday Dirt Rally was running wonderfully locked in at ultra settings and hitting a steady 45fps.  Now I'm getting constant drops to below 40fps, which causes stutters and gives me a headache.... 

    Thanks guys!!!!  :(
  • djwqvedjwqve Posts: 12
    NerveGear
    I got that since 1.9, before that all runs perfect....
    With senzza pesso opera experience, elite dangerous etc...from oculus library are unplayable, stutters, lag...
    I tested that games and experiences from steam and runs perfect, all in high or ultra....WTF!!!!!!

    Oculus is pushing people to update hardware? i suspect yes
  • JeepyBJeepyB Posts: 19
    NerveGear
    I have the same issue. Can't play DCS anymore. My CPU usage jumps to 30% as soon as the rift is running !
  • JD-UKJD-UK Posts: 2,289 Valuable Player
    Mine is fine in DCS. i5 SB and GTX970




  • Sax-a-boomSax-a-boom Posts: 731 Poster of the Week
    Unless you're maxing out your CPU, I'm not understanding why 25-30% usage is a problem. I've played traditional 2D that has hammered my CPU a lot more than that.
  • nAV2016nAV2016 Posts: 516
    Trinity
    Oculus support will say upgrade yur pc..its funny with all this new technolgy asw thingy mob, I thought we were supposed to run more with less? ..not knocking it thou at least my DK2 is working again
  • MradrMradr Posts: 3,348 Valuable Player
    How many cores are we talking here ? 20% of the core or the total cpu?
  • JeepyBJeepyB Posts: 19
    NerveGear
    30% of the total cpu for me. Doesn't get loaded much more than that in game, and the game is still playable, but I get weird graphical tearing when things are moving fast and they give me massive headaches. Wasn't the case before Nov 11 update. Is there a way to revert the update ?
  • Sax-a-boomSax-a-boom Posts: 731 Poster of the Week
    JeepyB said:
    30% of the total cpu for me. Doesn't get loaded much more than that in game, and the game is still playable, but I get weird graphical tearing when things are moving fast and they give me massive headaches. Wasn't the case before Nov 11 update. Is there a way to revert the update ?
    Have you checked if there's an updated driver for you graphics card since the update?
  • nalex66nalex66 Posts: 4,467 Volunteer Moderator
    edited November 2016
    It'll use up some CPU/GPU capacity while the Home environment is running, since it's a 3D rendered environment just like any game, but that load should disappear once you start a game.

    I haven't noticed any drop in VR performance since getting the 1.10 update yesterday.
    i7 5820K @ 4.25 GHz | EVGA GTX 1080 SC | Gigabyte GA-X99-UD4 | Corsair DDR4 3000 32 GB | Corsair HX 750W
    Corsair Hydro H100i | Samsung SSDs: 860 Evo 1 TB, 850 Evo 1 TB, 840 Evo 1 TB | Seagate BarraCuda HDD 3 TB
  • JeepyBJeepyB Posts: 19
    NerveGear
    Storm_Cloud a dit :
    JeepyB said:
    30% of the total cpu for me. Doesn't get loaded much more than that in game, and the game is still playable, but I get weird graphical tearing when things are moving fast and they give me massive headaches. Wasn't the case before Nov 11 update. Is there a way to revert the update ?
    Have you checked if there's an updated driver for you graphics card since the update?
    I have update all my drivers yes. I tested other games since, and I only see problems in DCS. Tried reverting to older versions of the game, but the issue is still there. 
  • whitav8whitav8 Posts: 92
    Hiro Protagonist
    I see a lot of pausing in Oculus Home now with 1.10 that I've never seen before. The hourglass comes up and I can't turn my head without a very significant pause - looks like it is loading something from disk?? This was never a problem with 1.09.  Aerofly FS2, a flight sim, seems basically OK though.
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    So Oculus Home is a 3D application, so some CPU utilization is expected. 30% seems high and abnormal (though it may depend on how powerful your CPU is to begin with). On my machine, with a 5930K, I'm getting around 4% with the Oculus app open, and around 10% while wearing the headset in Oculus Home. Of course, if you load up a game, then the usage will likely be more. But let me ask the team to see if there is some known reasons for this behavior.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    Actually, it looks like the engineering team is aware of the issue and are investigating now.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • Samg381Samg381 Posts: 7
    NerveGear
    It's ASW. I want a way to disable it NOW. What a terrible decision. I cannot play my games without the horrible artifacting.
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    The CPU usage bug actually is unrelated to ASW. We will be fixing it shortly.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • JeepyBJeepyB Posts: 19
    NerveGear
    has it been fixed yet ?
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    We did release a hotfix and AFAIK that fix was in there. Please give it a go.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • JeepyBJeepyB Posts: 19
    NerveGear
    issue still present on my side. Running App 1.10.0.308075 (1.10.0.310947)
  • JeepyBJeepyB Posts: 19
    NerveGear
    oh well I didnt know about the ASW thing. I disabled it and my issue is now gone. DCS runs smooths with no graphical glitch without ASW enabled.
  • whitav8whitav8 Posts: 92
    Hiro Protagonist
    @cybereality,
         Would you please tell us just what version of the runtimes we should check ( 1.10.0.310947 is several days old). And where is there any Oculus-published information on when a hotfix is released?? Also, please, please tell us how to disable ASW without always using CNTRL+1
  • ApplecorpApplecorp Posts: 741
    3Jane
    Was this ever fixed?

    Just checked my CPU usage (i5 4690k) in Home with the headset on and it's at about 35%, surely that is way too high?
  • FlausnFlausn Posts: 187
    Art3mis
    nope
  • reddeath360reddeath360 Posts: 342
    Art3mis
    this is what I was just posting about the other day I'm getting the same problem even did a full wipe of my os to see if that fixed it with no luck
  • markm75markm75 Posts: 68
    Hiro Protagonist
    Same issue here, at least on one of my two rigs.. cpu usage at around 20-25%, seems to cause stuttering in the game as you turn your head too, didnt before.. Any resolution here?
  • GeekyGamiGeekyGami Posts: 105
    Art3mis
    This is still a problem
    Game ran fine at the beginning of the day, and then it started running like complete garbage. I passed from 75% CPU utilisation while running a game (game using 34% CPU) to 90%.

    When I checked OVRServer64.exe, it was using 25%
Sign In or Register to comment.