ASW & Project Cars — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

ASW & Project Cars

teknix1teknix1 Posts: 32
Brain Burst
Hi,

The other night I thought I'd go around the race track a few times in Project Cars. So I put on the HMD and start the game... oddly enough the image didn't quite look the same as it did before. The not so fluid frames per second I had gotten used to was now replaced with constant 90 fps.How could that be? I had spent hours lowering the settings to the minimum and trying other settings on my 1080 with no improvement. The stutter didn't really bother me since I though it worked good enough and it didn't make me sick, it was mostly visible when looking at fast moving objects to side anyways. But this new fluidity was making me feel a little sick. So I thought I'd look into updates and what not only to discover this new tech... Asynchronous Spacewarp. The idea is great and all but it has a negative effect on me. I managed to find the registry key to disable the feature which brought it back the way it was before.

So I have a few questions:

1. I pretty much thought my 1080 didn't have enough power to push 90 fps while playing Project Cars. Is there a way to get 90 fps on that game with a 1080? I mean without ASW.

2. When can I use the CTRL-1 CTRL-2... 3 and 4 hotkeys to configure ASW? They don't seem to do anything for me.

3. Anybody else having trouble getting their XBox One controller to work in Project Cars? I keep having to disconnect and reconnet or restart the game multiple times. My controller has the latest firmware and I am on Windows 10.

4. Anybody else getting sick with ASW?

Thanks in advance
Nic

Comments

  • tonysaruntonysarun Posts: 17
    NerveGear
    Seems like project cars is broke. im onky getting 45fps
  • VRsteveVRsteve Posts: 68
    Hiro Protagonist
    Need to make sure you hit the NUM LOCK key first to be able to turn off ASW using CTRL -1 etc...

    I can confirm it works for me.
  • HackMacHackMac Posts: 9
    NerveGear
    edited December 2016
    teknix1 said
    I managed to find the registry key to disable the feature which brought it back the way it was before.

    I have the same problem. 
    Can you please share how you exactly disabled ASW in the registry?
  • StreetPreacherStreetPreacher Posts: 224
    Nexus 6
    tonysarun said:
    Seems like project cars is broke. im onky getting 45fps
    That sounds like ASW is active.  If your system can't maintain 90fps then ASW will lock you at 45 FPS and artificially generate and add extra frames to bring the actual dispaly fps up to 90.

    It works great for me, project cars looks fairly smooth at the fake 90fps, and in Dirt Rally I was able to turn everything up to epic settings, and that's on a gtx970!
  • Phil007Phil007 Posts: 56
    Hiro Protagonist
    I have a problem with stutter on project cars with a 1080 too. 
    I have noticed, if i start up the game and see a stuttering framerate. I restart my pc, the game runs smooth. If i leave the game and start playing  other games. When i return to Project cars, the stutter is back and i need to restart to make it smooth again.
    I had controller problems too. Pad would connect for 1 second then turn off. I found if i closed the oculus program, and tried again the pad would connect again. Seems that if i allowed the controller to turn off automatically, the problem would arise, needing an oculus program shutdown to fix. 
  • HackMacHackMac Posts: 9
    NerveGear
    teknix1 said:
    Hi,

    The other night I thought I'd go around the race track a few times in Project Cars. So I put on the HMD and start the game... oddly enough the image didn't quite look the same as it did before. The not so fluid frames per second I had gotten used to was now replaced with constant 90 fps.How could that be? I had spent hours lowering the settings to the minimum and trying other settings on my 1080 with no improvement. The stutter didn't really bother me since I though it worked good enough and it didn't make me sick, it was mostly visible when looking at fast moving objects to side anyways. But this new fluidity was making me feel a little sick. So I thought I'd look into updates and what not only to discover this new tech... Asynchronous Spacewarp. The idea is great and all but it has a negative effect on me. I managed to find the registry key to disable the feature which brought it back the way it was before.

    So I have a few questions:

    1. I pretty much thought my 1080 didn't have enough power to push 90 fps while playing Project Cars. Is there a way to get 90 fps on that game with a 1080? I mean without ASW.

    2. When can I use the CTRL-1 CTRL-2... 3 and 4 hotkeys to configure ASW? They don't seem to do anything for me.

    3. Anybody else having trouble getting their XBox One controller to work in Project Cars? I keep having to disconnect and reconnet or restart the game multiple times. My controller has the latest firmware and I am on Windows 10.

    4. Anybody else getting sick with ASW?

    Thanks in advance
    Nic

  • HackMacHackMac Posts: 9
    NerveGear
    Does anyone know the regedit the OP used to permanently disable ASW?
  • teknix1teknix1 Posts: 32
    Brain Burst
    My apologies for not replying sooner, I wasn't getting notified of the new replies.

    Disabling ASW has been hit and miss for me. I didn't know at the time but before the new update, I wasn't getting 90fps, hence the slight stutter which I had gotten accustomed to. Since the update, I was sure of having successfully disabled ASW but I can't seem to do that anymore. Perhaps pressing numlock will make it work. Anyways, here are the instructions I followed at the time: 
    https://m.reddit.com/r/oculus/comments/56af3t/detailed_stepbystep_guide_to_enabling_asw_through/d8hodir?compact=true

    As for the controller not working, I found that clicking outside of the project cars window and clicking back in to give it focus again does the trick.

    Hope this helps.
    Nic 

Sign In or Register to comment.