New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Guardian switch

Warrior-johnWarrior-john Posts: 14
NerveGear
I have set up touch and set the guardian system to stop me walking into my desk but now have the problem that when using a HOTAS or wheel on my desk the guardian grid is always showing.
I can back up a bit to make it invisible but then am to far away to use it, I can also move the guardian system over the desk but then I can walk into the desk. What I need is a keyboard or controller shortcut to disable guardian when sitting at desk, anyone have any ideas?

Comments

  • CharlieHobbesCharlieHobbes Posts: 555
    Neo
    You bring up a very good point, there should be a hot-key to switch between "seated mode" and "guardian mode".

    @cybereality can this please be brought to the attention of the tech wizards.
    I live in the UK and my game room is quite small, I play loads of simulator games with the Rift and this will get annoying.
  • kuabikuabi Posts: 92
    Hiro Protagonist
    You can go into the main menu inside the rift where you can turn it on or off. I have the same as I play driving sims or flight sims sitting down so the guardian isn't needed. I think someone mentioned profiles in another thread but we need the to switch between sitting or standing height.
  • GreymanGreyman Posts: 1,315
    Wintermute
    does it go away if you put the Touch controllers out of sight of the sensors?
  • Warrior-johnWarrior-john Posts: 14
    NerveGear
    No even with the controllers out of view the mesh is still there until turned off, would be far better with a hot key for guardian/seated and would save the menu surfing to turn it on and off repeatedly.
  • GreymanGreyman Posts: 1,315
    Wintermute
    I wonder if it displays just when you get close to the edge and, if your room is as small as mine, that will be most of the time
  • Warrior-johnWarrior-john Posts: 14
    NerveGear
    yea it pops up as you get close to the edge, but as the edge is level with my desk as I sit down to use wheel it hovers just in front of my face, the other option I have found is to set it a couple of feet back from desk so it is behind me when sitting but that loses a good chunk of the 8 feet of play space I have.
  • bonarhyabonarhya Posts: 4
    NerveGear
    kuabi said:
    You can go into the main menu inside the rift where you can turn it on or off. I have the same as I play driving sims or flight sims sitting down so the guardian isn't needed. I think someone mentioned profiles in another thread but we need the to switch between sitting or standing height.
    Hi can you tell me how to do this as I cannot find anywhere to switch it off / on..  I put on the rift and there is no main menu with settings that can be adjusted.  Also without putting the rift on I have looked through the oculus settings on my pc and cannot find anything there either.  It's very annoying and hopefully they will see our rants and give us a hotkey toggle or something.  I am now having to play all the games I bought previously STANDING up in the middle of my living room else the heights wrong and the guardian mesh is in the way....
  • GreymanGreyman Posts: 1,315
    Wintermute
    go to the Oculus, using the remote or the Oculus button on the right hand Touch controller, and the Guardian settings are on an icon that is close to the bottom of the left hand column of icons.

    Press that and you will be able to turn off Guardian altogether or just the wall, leaving just an outline of the play area, on the "floor".

    Don't forget that you have turned it off though, as you might want it back on again, for other games, to avoid demolishing the TV or any other peeps in your house.

  • wanoennogswanoennogs Posts: 166
    Art3mis
    edited December 2016
    kuabi said:
    You can go into the main menu inside the rift where you can turn it on or off. I have the same as I play driving sims or flight sims sitting down so the guardian isn't needed. I think someone mentioned profiles in another thread but we need the to switch between sitting or standing height.
    We need an easy way to swtich between having guardian on and off.  I know you can go into the settings but that is long winded.  A simple F1 for on and F2 for off would do. 
  • Fredd32Fredd32 Posts: 251
    Nexus 6
    It's really easy and quick to do. Click menu botton, click gurdian icon bottom left, click off and done. Less than 10 seconds to accomplish. 
  • ryanhellyerryanhellyer Posts: 1
    NerveGear
    I'd love to do this too, but I can't make any sense of the instructions provided above.

    What is an "Oculus button"? And when in the main Rift menu I don't see anything about Guardian, so I don't have anything to click :/
  • Star-lizardStar-lizard Posts: 344
    Trinity
    When you put on your headset click on the icon bottom left , it looks like a house. The Guardian menu will be on the lower left column icons. I don't have access to rift ATM but it's not hard to find. You will have an option to turn off completely or just turn off the walls leaving the floor outline active. I leave floor outline active all the time 
  • wanoennogswanoennogs Posts: 166
    Art3mis
    I have asked for this before.  The function keys could be assigned to do this.  F1 = gaurdian on and F2 = guardian off 
Sign In or Register to comment.