Cannot update apps on Oculus Home - please help! — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Cannot update apps on Oculus Home - please help!

PayneSculpturesPayneSculptures Posts: 41
Brain Burst

Hello Oculus friends!

I'm having a strange problem where I cannot update my Rift apps that currently have pending upgrades to install. Each one will download and then it just tries to install the update (counts from 1 - 100%) and the I get an error message saying: "Sorry, Oculus home could not installl *name of application*. Try contacting support."

I have home 1.11. The pending upgrades are Medium 1.04, Dead and Buried, Lucky's Tale, Bigscreen Beta.

Other notes: I have tried closing and reopening home, signing out and back into home, restarting the computer...even The beta reset.

Thoughts? Have any of you experienced this?

Comments

  • MadWolf7MadWolf7 Posts: 24
    Brain Burst

    I have the exact same damn problem, reported it to Oculus Support, got the general response, is your computer plugged in, bullshit questions, told them exactly what you said and haven't heard a word back!

    This is total BS especially not letting us know they recognize the problem and are working on it!!

  • will84will84 Posts: 76
    Hiro Protagonist
    edited February 2017
    @PayneSculptures

    Look in the Oculus install folder in Program Files & see if you have the redistributables folder install each one manually if the folder is there (could be the problem, not saying it is)

    I have never seen that error and currently my rift is being RMA'd so can't look, otherwise try a repair install with the OculusSetup.exe.

    edit: glad you have you rift up and running again :-)


  • Percy1983Percy1983 Posts: 1,410
    Wintermute
    Same problem here with Alt Space, Rec Room and Bigscreen.

    I did get a Dead and Buried update through in my case.
    Asrock Z77 Extreme 4 + 16GB RAM 1866mhz + i5-3570K at 4.5Ghz + Coolermaster Nepton 140XL cooler
    Sapphire 8GB RX 580 Nitro+
    256Gb SDD Samsung Evo 850 +3x2TB in raid 0 with 64GB SSD cache
    Thermaltake Level 10 GT Snow Edition + Toughpower 875w
  • MadWolf7MadWolf7 Posts: 24
    Brain Burst
    I did the repair install, didn't do a thing. I will try to see if I have a redistributables file 
  • MadWolf7MadWolf7 Posts: 24
    Brain Burst

    Never had a single problem with the rift before, not one. Worked perfectly

    Where are the Oculus and Gun Slinger tech guys?! on this.

  • will84will84 Posts: 76
    Hiro Protagonist
    Sorry if it did not fix, damn wish oculus would have invested some of that money in it's operating software. It's great that they invested money in apps and games but "cart before the horse" and all that.

    Hope they get this sorted soon :s
  • MadWolf7MadWolf7 Posts: 24
    Brain Burst
    Where is the support, if I knew they acknowledged the problem and were working on it I would be cool, but instead all I hear is Crickets
  • twisteklabstwisteklabs Posts: 416
    Trinity
    I have a similar issue with fresh install of Oculus Home as directed by Oculus support. I already updated my ticket. Hopefully I will get a response back soon. 
    CPU: Intel i5-4690K
    Mobo: ASUS Z97-AR
    Ram: 8GB 1600MHz
    Graphics Card: EVGA GTX 1080 SC
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    edited February 2017
    Also, this is commonly a permissions or security issue. You may want to try disabling anti-virus and (if that doesn't work) reinstall the Oculus app to a better folder with proper permissions (for example, something like E:/Oculus would probably work fine).
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • MadWolf7MadWolf7 Posts: 24
    Brain Burst
    I did both of those and by the way, it has never been a problem before?

  • MadWolf7MadWolf7 Posts: 24
    Brain Burst
    Seems to be related to Dead and Buried and Hulu update, other updates have gone through

  • MadWolf7MadWolf7 Posts: 24
    Brain Burst
    Seems to be related to Dead and Buried and Hulu update, other updates have gone through.

    Here is the old ticket #328092
    I just did another #328609

  • MadWolf7MadWolf7 Posts: 24
    Brain Burst
    thanks for the help
  • Bailey618Bailey618 Posts: 1
    NerveGear
    I have had the same problem and eventually uninstalled oculus BIG mistake as it now wont let me reinstall oculus set up and I have lost the lot. it has told me to contact support which I have.... here s hoping
  • MadWolf7MadWolf7 Posts: 24
    Brain Burst
    Fixed it!!!! Myself,     Disable McAffee antivirus completely, turn off the scanner, not the firewall, and bammm it downloads and loads! And no one could tell us that. Good Luck
  • MadWolf7MadWolf7 Posts: 24
    Brain Burst
    UNBELIEVABLE!!
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    Awesome! Glad to hear it's working now and thanks for following up. However, to be fair, I did suggest earlier today to disable anti-virus, and I see in your ticket that was the first thing support asked as well. 
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • Percy1983Percy1983 Posts: 1,410
    Wintermute
    edited February 2017
    Just tried disabling anti virus (windows defender) no joy.

    Games are installed on D:\Oculus
    Main program C:\Program Files\Oculus

    Asrock Z77 Extreme 4 + 16GB RAM 1866mhz + i5-3570K at 4.5Ghz + Coolermaster Nepton 140XL cooler
    Sapphire 8GB RX 580 Nitro+
    256Gb SDD Samsung Evo 850 +3x2TB in raid 0 with 64GB SSD cache
    Thermaltake Level 10 GT Snow Edition + Toughpower 875w
  • MadWolf7MadWolf7 Posts: 24
    Brain Burst
    i disabled firewall first, my error, apologize,  and thanks again
  • XJSXJS Posts: 2
    NerveGear
    Hi all, exact same problem on the exact same games. Mcafee removed and everything downloaded instantly
  • PayneSculpturesPayneSculptures Posts: 41
    Brain Burst
    Hello All, when I also have been able to reliably fix the issue by disabling both McAfee firewall AND virus scanning. Only doing the firewall does not help but both together fixes it every time and allows updates to download. THANK You for your help on this matter!
  • Tim74UKTim74UK Posts: 1,369
    Nexus 6
    I'm having this problem.
    No apps will update, stuck on Attention required... installing third party etc...

    I have disabled by antivirus and still nothing... I've repaired and still nothing.... I've uninstalled and reinstalled... still the same.

    I'm guessing its a problem with home software.
    My Rig: - Gigabyte Z97 X5 MB / Core i7 4790K @ 4.4Ghz - Water Cooled Coolmaster AIO Loop (Push - Pull Config)/ 16GB Corsair Dominator ram at 2400Mhz / Palit Jetsteam GTX 980 OC edition / 250GB SSD OS / Program Drive + 2 TB hard drive storage / Win 10
  • flexy123flexy123 Posts: 791
    3Jane
    edited February 19
    @cybereality what do you mean with "better folder with proper permissions". My OH system software is always on C:\Program Files\Oculus  (as is default), and I also checked and "OVRLibraryService" has full access to this folder. However, there are problems with automatic update of OH which basically NEVER works. It is also clear in the OVRLibraryService log that there is a problem either doiwnloading the archives from your server, or it may download them but can't access them then locally. (But to me it seems it doesn't even d/l them).
    It references a Download folder within the Oculus folder as well as a tmp folder within the folder, but there is nothing in it. The log file clearly shows it tries to get the *.zip files from these folders but there is nothing there, so the automated update aborts.
    Please advice, eg. in  particular about proper permissions that you refer to.
    (Reinstalling or repair is not an option, this may well work, I want to know why it doesn't work from the software. It's at pending and never ever anything happens because of this).
    Ty!
    *** SNIP ***
    [Debug] [2/19/2019 8:55:52 PM] Starting up OVRLibraryService v1.16.0.0.
    [Debug] [2/19/2019 8:55:52 PM] Starting up.
    [Debug] [2/19/2019 8:55:52 PM] IPC connection opened.
    [Debug] [2/19/2019 8:55:52 PM] IPC thread running; waiting for Oaf to connect.
    [Debug] [2/19/2019 8:55:52 PM] IPC connection established!
    [Debug] [2/19/2019 8:55:52 PM] App libraries for this user: [CORE_DATA]
    [Debug] [2/19/2019 8:55:52 PM] OVRLibraryService starting in service mode.  Arguments: [core-upgrade-chunked-start, C:\Program Files\Oculus\\Downloads\oculus-client\1549890179\oculus-client.zip, C:\Program Files\Oculus\\Downloads\oculus-client\1549890179\oculus-client.sig, C:\Program Files\Oculus\\Downloads\oculus-librarian\1549889881\oculus-librarian.zip, C:\Program Files\Oculus\\Downloads\oculus-librarian\1549889881\oculus-librarian.sig, C:\Program Files\Oculus\\Downloads\oculus-diagnostics\1549890121\oculus-diagnostics.zip, C:\Program Files\Oculus\\Downloads\oculus-diagnostics\1549890121\oculus-diagnostics.sig, C:\Program Files\Oculus\\Downloads\oculus-compat\1549890458\oculus-compat.zip, C:\Program Files\Oculus\\Downloads\oculus-compat\1549890458\oculus-compat.sig, C:\Program Files\Oculus\\Downloads\oculus-dash\1549892553\oculus-dash.zip, C:\Program Files\Oculus\\Downloads\oculus-dash\1549892553\oculus-dash.sig, C:\Program Files\Oculus\\Downloads\oculus-platform-runtime\1549892467\oculus-platform-runtime.zip, C:\Program Files\Oculus\\Downloads\oculus-platform-runtime\1549892467\oculus-platform-runtime.sig, C:\Program Files\Oculus\\Downloads\oculus-redistributable-installer\1549889787\oculus-redistributable-installer.zip, C:\Program Files\Oculus\\Downloads\oculus-redistributable-installer\1549889787\oculus-redistributable-installer.sig, C:\Program Files\Oculus\\Downloads\oculus-runtime\1549892511\oculus-runtime.zip, C:\Program Files\Oculus\\Downloads\oculus-runtime\1549892511\oculus-runtime.sig, C:\Program Files\Oculus\\Downloads\oculus-worlds\1549902402\oculus-worlds.zip, C:\Program Files\Oculus\\Downloads\oculus-worlds\1549902402\oculus-worlds.sig]
    [Debug] [2/19/2019 8:55:52 PM] Creating NTFS transaction.
    [Debug] [2/19/2019 8:55:52 PM] Creating NTFS transaction.
    [Debug] [2/19/2019 8:55:52 PM] Operation failed.  Rolling back changes.
    [Error] [2/19/2019 8:55:52 PM] Error starting chunked core update!
    Daybreak.OVRLibraryService.Libraries.LibrarianException: Error acquiring package. ---> Daybreak.Core.Io+IoException: Error installing 'C:\Program Files\Oculus\tmp\afeb271c-8741-4e03-825a-be1e8f791821\package.zip. ---> System.ComponentModel.Win32Exception: The system cannot find the path specified
       --- End of inner exception stack trace ---
       at Daybreak.Core.Io.CopyFile(Nullable`1 transaction, String source, String dest)
       at Daybreak.OVRLibraryService.Libraries.LibrarianOperation.ExtractPackages[T](IntPtr transaction, IEnumerable`1 zips, String tempDir)
       --- End of inner exception stack trace ---
       at Daybreak.OVRLibraryService.Libraries.LibrarianOperation.ExtractPackages[T](IntPtr transaction, IEnumerable`1 zips, String tempDir)
       at Daybreak.OVRLibraryService.Libraries.LibraryController.<>c__DisplayClass13_0.<CoreUpgradeChunkedStart>b__0(IntPtr transaction)
       at Daybreak.Core.TxF.PerformBlockInTransaction[T](Func`2 block, Nullable`1 existingTransaction)
       at Daybreak.OVRLibraryService.Libraries.LibraryController.CoreUpgradeChunkedStart(List`1 zips, ChunkedProgressUpdater updater, OafCancellationHandler oafCancellationHandler, IChunkDownloader chunkDownloader)
    [Debug] [2/19/2019 8:55:52 PM] Operation failed.  Rolling back changes.
    [Error] [2/19/2019 8:55:52 PM] Exception in PerformBlockInTransaction():
    System.Exception: Block returned ErrorAcquiringPackage.
       at Daybreak.OVRLibraryService.Libraries.LibraryController.<>c__DisplayClass19_0.<PerformBlockInTransactionDeprecated>b__0(IntPtr transaction)
       at Daybreak.Core.TxF.PerformBlockInTransaction[T](Func`2 block, Nullable`1 existingTransaction)
       at Daybreak.OVRLibraryService.Libraries.LibraryController.PerformBlockInTransactionDeprecated(Func`2 block)
    [Warning] [2/19/2019 8:55:52 PM] Oaf IPC connection lost!
    [Debug] [2/19/2019 8:55:52 PM] IPC connection destroyed.
    [Debug] [2/19/2019 8:55:52 PM] Exiting with code 7 (ErrorAcquiringPackage).
    ****

  • LZoltowskiLZoltowski Posts: 6,774 Volunteer Moderator
    flexy123 said:
    @cybereality what do you mean with "better folder with proper permissions". My OH system software is always on C:\Program Files\Oculus  (as is default), and I also checked and "OVRLibraryService" has full access to this folder. However, there are problems with automatic update of OH which basically NEVER works. It is also clear in the OVRLibraryService log that there is a problem either doiwnloading the archives from your server, or it may download them but can't access them then locally. (But to me it seems it doesn't even d/l them).
    It references a Download folder within the Oculus folder as well as a tmp folder within the folder, but there is nothing in it. The log file clearly shows it tries to get the *.zip files from these folders but there is nothing there, so the automated update aborts.
    Please advice, eg. in  particular about proper permissions that you refer to.
    (Reinstalling or repair is not an option, this may well work, I want to know why it doesn't work from the software. It's at pending and never ever anything happens because of this).
    Ty!
    *** SNIP ***
    [Debug] [2/19/2019 8:55:52 PM] Starting up OVRLibraryService v1.16.0.0.
    [Debug] [2/19/2019 8:55:52 PM] Starting up.
    [Debug] [2/19/2019 8:55:52 PM] IPC connection opened.
    [Debug] [2/19/2019 8:55:52 PM] IPC thread running; waiting for Oaf to connect.
    [Debug] [2/19/2019 8:55:52 PM] IPC connection established!
    [Debug] [2/19/2019 8:55:52 PM] App libraries for this user: [CORE_DATA]
    [Debug] [2/19/2019 8:55:52 PM] OVRLibraryService starting in service mode.  Arguments: [core-upgrade-chunked-start, C:\Program Files\Oculus\\Downloads\oculus-client\1549890179\oculus-client.zip, C:\Program Files\Oculus\\Downloads\oculus-client\1549890179\oculus-client.sig, C:\Program Files\Oculus\\Downloads\oculus-librarian\1549889881\oculus-librarian.zip, C:\Program Files\Oculus\\Downloads\oculus-librarian\1549889881\oculus-librarian.sig, C:\Program Files\Oculus\\Downloads\oculus-diagnostics\1549890121\oculus-diagnostics.zip, C:\Program Files\Oculus\\Downloads\oculus-diagnostics\1549890121\oculus-diagnostics.sig, C:\Program Files\Oculus\\Downloads\oculus-compat\1549890458\oculus-compat.zip, C:\Program Files\Oculus\\Downloads\oculus-compat\1549890458\oculus-compat.sig, C:\Program Files\Oculus\\Downloads\oculus-dash\1549892553\oculus-dash.zip, C:\Program Files\Oculus\\Downloads\oculus-dash\1549892553\oculus-dash.sig, C:\Program Files\Oculus\\Downloads\oculus-platform-runtime\1549892467\oculus-platform-runtime.zip, C:\Program Files\Oculus\\Downloads\oculus-platform-runtime\1549892467\oculus-platform-runtime.sig, C:\Program Files\Oculus\\Downloads\oculus-redistributable-installer\1549889787\oculus-redistributable-installer.zip, C:\Program Files\Oculus\\Downloads\oculus-redistributable-installer\1549889787\oculus-redistributable-installer.sig, C:\Program Files\Oculus\\Downloads\oculus-runtime\1549892511\oculus-runtime.zip, C:\Program Files\Oculus\\Downloads\oculus-runtime\1549892511\oculus-runtime.sig, C:\Program Files\Oculus\\Downloads\oculus-worlds\1549902402\oculus-worlds.zip, C:\Program Files\Oculus\\Downloads\oculus-worlds\1549902402\oculus-worlds.sig]
    [Debug] [2/19/2019 8:55:52 PM] Creating NTFS transaction.
    [Debug] [2/19/2019 8:55:52 PM] Creating NTFS transaction.
    [Debug] [2/19/2019 8:55:52 PM] Operation failed.  Rolling back changes.
    [Error] [2/19/2019 8:55:52 PM] Error starting chunked core update!
    Daybreak.OVRLibraryService.Libraries.LibrarianException: Error acquiring package. ---> Daybreak.Core.Io+IoException: Error installing 'C:\Program Files\Oculus\tmp\afeb271c-8741-4e03-825a-be1e8f791821\package.zip. ---> System.ComponentModel.Win32Exception: The system cannot find the path specified
       --- End of inner exception stack trace ---
       at Daybreak.Core.Io.CopyFile(Nullable`1 transaction, String source, String dest)
       at Daybreak.OVRLibraryService.Libraries.LibrarianOperation.ExtractPackages[T](IntPtr transaction, IEnumerable`1 zips, String tempDir)
       --- End of inner exception stack trace ---
       at Daybreak.OVRLibraryService.Libraries.LibrarianOperation.ExtractPackages[T](IntPtr transaction, IEnumerable`1 zips, String tempDir)
       at Daybreak.OVRLibraryService.Libraries.LibraryController.<>c__DisplayClass13_0.<CoreUpgradeChunkedStart>b__0(IntPtr transaction)
       at Daybreak.Core.TxF.PerformBlockInTransaction[T](Func`2 block, Nullable`1 existingTransaction)
       at Daybreak.OVRLibraryService.Libraries.LibraryController.CoreUpgradeChunkedStart(List`1 zips, ChunkedProgressUpdater updater, OafCancellationHandler oafCancellationHandler, IChunkDownloader chunkDownloader)
    [Debug] [2/19/2019 8:55:52 PM] Operation failed.  Rolling back changes.
    [Error] [2/19/2019 8:55:52 PM] Exception in PerformBlockInTransaction():
    System.Exception: Block returned ErrorAcquiringPackage.
       at Daybreak.OVRLibraryService.Libraries.LibraryController.<>c__DisplayClass19_0.<PerformBlockInTransactionDeprecated>b__0(IntPtr transaction)
       at Daybreak.Core.TxF.PerformBlockInTransaction[T](Func`2 block, Nullable`1 existingTransaction)
       at Daybreak.OVRLibraryService.Libraries.LibraryController.PerformBlockInTransactionDeprecated(Func`2 block)
    [Warning] [2/19/2019 8:55:52 PM] Oaf IPC connection lost!
    [Debug] [2/19/2019 8:55:52 PM] IPC connection destroyed.
    [Debug] [2/19/2019 8:55:52 PM] Exiting with code 7 (ErrorAcquiringPackage).
    ****


    @cybereality is no longer with Oc@cybereality

    What might be happening is that your antivirus maybe deleting this file as Oculus tries to download it. Are you running any antivirus/antimalware software?
    Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
    ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

    Be kind to one another :)
  • flexy123flexy123 Posts: 791
    3Jane
    NOD32, but I also tested w/ disabling it (as well as disabling defender). (I also added exclusions to any Oculus paths to NOD32, just to be double-safe.)

    I have no idea what is wrong here, but everything points to a permission problem.
Sign In or Register to comment.