New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Oculus Setup: KB2670838 and KB3033929 required, but already installed



  • zzkszzkszzkszzks Posts: 2
    i am really feel regret to buy this now. waste my time to deal these shits.
  • BillVajtasticBillVajtastic Posts: 1
    edited April 2017
    I tried this but now it says it cannot find the server

    *FIXED  I used this guide but had to uninstall all of my antivirus software including Microsoft security essentials.

    It is now working! 
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    Great. Glad I could help.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • Deathstar6864Deathstar6864 Posts: 2
    hey guys the  Cmd in command promp should work ...if you type it in but nothing hapens that means that your typing it wrong look at this and type it the same as here look at the capital ones    OculusSetup.exe /bypassHotfixCheck    .....if you only type the thing in small letters wont work
  • Deathstar6864Deathstar6864 Posts: 2
    hello, I am having same issue, with those Kn hotfix, how to do I use command promt to open oculus .exe?

    click on start then type in the search bar cmd....your downloaded file the (oculussetup.exe) should be in your downloads when u typed in cmd and enter at the search bar the black screen should come on....type in the screen (cd downloads) this shoulddirect it to the place its downloaded...then type this (OculusSetup.exe /bypassHotfixCheck) remember to look at what letter is a capatal and lower

    hope it helped
  • DasvessenDasvessen Posts: 1
    edited May 2017
    im having  the same problem 
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    edited June 2017
    Dasvessen said:
    im having  the same problem 
    If you see this post (earlier in this thread)?
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • geogangeogan Posts: 9
    Brain Burst
    I just tried to install now and got the same two errors on Windows 7 SP1. And after downloading the hotfixes and running them, Windows tells me they are both installed already. This is fucking ridiculous Oculus! Are you actually trying to kill your company stone dead by making it as hard as possible for ANYONE to use your device???
    Coolermaster HAF 932, ASUS Rampage II Extreme, Intel i7 970 @ 3.2GHz, Gigabyte Xtreme Gaming GTX 1070, 12Gb Corsair Dominator GT DDR3, OCZ Vertex 4, 17TB SATA storage, Creative HS-1000 Fatal1ty USB X-Fi Gaming Headset, ASUS Xonar DSX audiocard, Logitech G15 Keyboard, XFX Triple monitor stand, Dell U2715H, Dell 2407WFP x 2, Tagan BZ-ESA Modular 800W, Windows 7 Professional 64bit | 16TB HP Proliant Media Server, Oculus Rift CV1 + Touch
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    Have you done the steps I suggested the the post directly above?
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • JimmyGilibertiJimmyGiliberti Posts: 1
    don't know why it works, but I first did

    OculusSetup.exe /h   which fails but afterwards

    OculusSetup.exe /bypassHotfixCheck  then continues.... magic. but it works.
  • chris.bell.2008chris.bell.2008 Posts: 1
    You guys are awsome, just got my DK2 and would be in the shit without you lot helping each other ;)
  • GenIdeaGenIdea Posts: 12

    This thread has been a godsend.

    Allowed me to get on with downloading the software.

    This is the sort of information that should be in the official troubleshooting, and by now the "/bypassHotfixCheck" should be the default setting for the setup software or at least have a "tickbox "option.

    As a new purchaser, I'm rather disappointed.

  • GenIdeaGenIdea Posts: 12
    hello, I am having same issue, with those Kn hotfix, how to do I use command promt to open oculus .exe?

    best way is from the windows search (it's different depending on version 7, 8, or 10) and just type "cmd" and press enter.

    That will give you command prompt window.

    If you know where you saved the setup App the you use the "CD" command to move to that folder and then type the "OculusSetup.exe /bypassHotfixCheck" and it should work without asking for the Windows updates.

    ... well it did for me.  I'm still downloading (its 1.7 GB)

    Good luck

  • T1-ProxiiT1-Proxii Posts: 1
    hello, I am having same issue, with those Kn hotfix, how to do I use command promt to open oculus .exe?
    Go to the folder where the SetUp.exe is located, click the address bar and type "cmd" then enter the command from there.
  • dayukdayuk Posts: 1
    pyr084 said:
    i had the same problem, rift software says KB3033929 and KB2670838 are not installed.
    i tried everthing in this post, dosent work.

    then i force install the 2 windows updates like this

    1. download KB3033929 and KB2670838 from microsoft
    2. download and install 7zip
    3. unpack KB3033929 and KB2670838 with 7-zip
    4. copy the files to c:\
    5. open console in admin mode
    6. type: dism /online /add-package:C:\
    7. wait until restart
    8. open console in admin mode
    9. type: dism /online /add-package:C:\
    8. wait until restart
    10. install oculus

    have fun. hope it works for someone

    Thanks pyr084. This method worked for me. I couldn't confirm if they were installed so rather doing the bypass I tried your way. Installing software now.

    Surely this means its a windows problem than Oculus ?
  • pyr084pyr084 Posts: 2
    no its a oculus problem, one of these updates is more then 2 years old now, and got packet by an rollup update of windows. it is realy installed but the KB-code is not longer registerd and the oculus software doesnt know this XD .....absolut facebook fail
  • abuzz20abuzz20 Posts: 4
    Who cares about the reasons. Goddam fix it you incompetent fools
  • rupsabbott1rupsabbott1 Posts: 19
    thre is a way to ignore these: on Win + R run the setup and add /bypassCheckFix - i think thats it: this worked for me :) i had one of the 2 KB's already installed - after installing second and then using this switch no issues experienced at all (note: I'm win7Pro64bit)
  • DonkyBoYDonkyBoY Posts: 90
    Hiro Protagonist
    Over a year later with many new Oculus updates yet this issue is still not resolved.
    SHAME ON YOU Oculus.

    Probably should focus your efforts on this as more users have Win7 than anything else your most likely pissing off a lot of people.

    Oculus CV1 room scale with 3 tracker's
    i7 4790K @ 4.4Ghz with delid and Liquid metal ultra +Corsair H110i / MSI GTX1080Ti Sea Hawk / 32GB DDR3 @2400Mhz
    (All rads running EK Furious Vardar F4 / F5 fans)
    Sandisk Extreme for OS and Kingston SSD Now for games
    Steam =
    TS3 server =
  • SirenCrudmakerSirenCrudmaker Posts: 1
    Used No.11_Darky's version of Cybereality's post. It worked, thanks guys!
    C:\OculusSetup.exe /bypassHotfixCheck (see above)
  • kwalker23kwalker23 Posts: 1
    edited September 2017
    Nothing worked. 
    1. bypassHotfixCheck = FAILED
    2. DISM install .cab files = setup = FAILURE! 

    Support is basically re writing what you have all tried thus far hoping they can get someone to successfully install thier equipment.

  • PsychoMuffinPsychoMuffin Posts: 1
    edited November 2017
    It looks like this thread started in April of 2016, and here it is Nov 2017, and I am having this issue too. I'm not a programmer, but I would think that at some point in the last 19 months, one would have updated the software to check for either this 838 and 929 update ***OR*** this April rollout that includes them. If the April '16 roll out is installed, then 838 and 929 is installed. DONE! I'm going to try these fixes now, but I wish I (and many others) were able to start using this hours ago because an actual programmer couldn't get this fixed anytime in the past 19 months. 

    EDIT: Command through command prompt seems to have started the install process, but I shouldn't have had to do it in the first place.

    EDIT 2: I got everything working well. The experience was well worth the problems installing it. It is amazing how much depth there is to those environments. However, the payoff is not justification for the problems. I worry about all those not tech-savvy enough to implement the instructions here, let alone if they even find these forum pages. I still hope this can be fixed for all those in the future trying to install, as those still wanting windows 7 will be using the rollout more and more (I am still quite win 8 and 10 adverse). 
  • Henrik9979Henrik9979 Posts: 2
    Steps I'd performed to get it to work:

    First use command prompt to check if you have the required updates:
    1. Open cmd.exe as administrator.

    2. Type: SYSTEMINFO.exe | findstr KB2670838
               example how it should look like if you have the update:

    3. I could confirm I already had the KB2670838 update, but could not find the KB3033929 update.

    Installation for KB2670838:

    Installation for KB3033929:

    4. I tried installing the KB3033929 update but the installation said it already was installed.

    5. I oppened cmd.exe again but this time NOT as administrator.

    6. My OculusSetup was located on a different drive so I had to type this command:

    cd /d I:\Henrik\Downloads\Oculusriftruntime

    7. Then I just typed the hotfix command:

    OculusSetup.exe /bypassHotfixCheck

  • Peregrine2976Peregrine2976 Posts: 5
    Here we are in January of 2018, with this issue still unresolved. FYI, 'here's a command line work-around' is not 'resolved', which is apparently a memo you idiots need. I can barely believe that a high-tech development company would need such a basic principle explained to them. Where is the actual, real, fix?
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    Well, we know what the issue is. Basically the Oculus setup is working correctly. However in order to check for those hotfixes, we need to use a Microsoft API which *should* exist on all modern Windows operating systems but sometimes does not (for example if your OS install got corrupted, or is really old and not updated, or otherwise not 100% working). Without that API call, we're unable to verify if the hotfixes exist or not and so it fails. We need the check, because if you don't have those hotfixes, the Oculus software won't work and an error message is better than random crashing with no visual indication of what the problem is. So the command-line work around is the solution, for the small number of customers who will encounter this problem. Thanks.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • anthony.fogganthony.fogg Posts: 1

    Thanks for helping people on here. To offer a suggestion to your issue that you described, why not include a check mark and a double check within the setup GUI saying something to the effect of "I have validated I have theses patches installed and understand if I continue without them installed they will cause me further issues with the Rift software should they not be installed correctly" then let the user proceed?
  • Peregrine2976Peregrine2976 Posts: 5

    That's a solution. Something in the interface that allows customers to proceed. I'm not asking for a miracle, I know it's a pain to work with APIs that are out of your control (FYI, I'm on a fully-updated Windows 7 install, hardly an edge case). A command-line workaround for a system that is 100% GUI based is not a solution, period, and I'm beyond baffled that an actual Oculus Staff member would try to make the claim that it is. Has anyone explained User Experience to these people? I think they need some refresher courses.
Sign In or Register to comment.