How to prevent Home from starting when playing Steam games — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

How to prevent Home from starting when playing Steam games

ApollyonVRApollyonVR Posts: 368
Trinity
edited June 2017 in General
Hi all!
Just thought i'd share this nifty trick found by user @droseofc while we where troubleshooting some stuff regarding Oculus Tray Tool. If you set Oculus Home to Run as Administrator, it will not automatically launch in the background when starting Steam VR games. This might save some valuable resources as well as make Steam games launch faster. This will also, however, cause Home to not start automatically when you put the Rift on your head. So there's two sides to this so to say. To set Home to start as Administrator, you right-click the Oculus shortcut -> Properties ->  Compatibility and down at the bottom you check the box "Run this program as an administrator". Done!

You might need to start Oculus Home manually one time and dismiss the Health & Safety warning so you get into the lobby. After this you can close Home and start Steam VR games as usual and it should work fine with no Home starting up in the background.
So this might need to be done every time after you've restarted your PC. As i mentioned this was discovered by @droseofc, i just tested and verified it. Hope someone finds it useful, couldn't find any existing posts about it. =)

Cheers!

Comments

  • droseofcdroseofc Posts: 60
    Hiro Protagonist
         It really does make a huge difference, at least on my pc. Seems SteamVR games start up almost instantly, where before there was a wait while it loaded. I do not have to redo after every reboot, and I do have the health and safety warning disabled as well as unknown sources checked.
         If you press the Oculus menu button while playing a steamvr game the screen will just turn black until you press it again, since the Oculus client is not loaded..  At least I'd assume, with the amount of resources required to run VR, being able to only have one running instead of two is the ideal option. 
  • dburnedburne Posts: 2,520 Valuable Player
    edited June 2017
    This is awesome and works great, many thanks for this tip! I had to install Steam VR begrudgingly
    for playing IL-2 Battle of Stalingrad  as it was the only platform supported, now I can launch the game much faster without Oculus Home starting up as well. Have not had a chance to check any performance comparisons but certainly can not hurt!

    Thanks very much for sharing!
    Don

    EVGA Z390 Dark MB | I9 9900k| EVGA 2080Ti FTW3 Ultra |32 GB G Skill 3200 cl14 ram | Warthog Throttle | VKB Gunfighter Pro/MCG Pro grip | Crosswind Pedals | EVGA DG 87 Case|
  • dburnedburne Posts: 2,520 Valuable Player

    You might need to start Oculus Home manually one time and dismiss the Health & Safety warning so you get into the lobby. After this you can close Home and start Steam VR games as usual and it should work fine with no Home starting up in the background.
    So this might need to be done every time after you've restarted your PC
    Just tested on mine, did not need to set it upon any restart of PC. I had already previously dismissed the Health and Safety Warning though as well.
    Don

    EVGA Z390 Dark MB | I9 9900k| EVGA 2080Ti FTW3 Ultra |32 GB G Skill 3200 cl14 ram | Warthog Throttle | VKB Gunfighter Pro/MCG Pro grip | Crosswind Pedals | EVGA DG 87 Case|
  • Redstone13Redstone13 Posts: 1
    NerveGear
    HI, this solution worked great for me, but not anymore. I had to run the oculus setup again yesterday and now it's back to opening home whenever I open steamvr.  run as administrator is still checked and the headset does not turn on when I put it on so I can't figure out why it's doing this.  I almost never use the oculus store and having it run in the background KILLS my performance as it is an absolute RAM whore.  Can someone help?
  • droseofcdroseofc Posts: 60
    Hiro Protagonist
    HI, this solution worked great for me, but not anymore. I had to run the oculus setup again yesterday and now it's back to opening home whenever I open steamvr.  run as administrator is still checked and the headset does not turn on when I put it on so I can't figure out why it's doing this.  I almost never use the oculus store and having it run in the background KILLS my performance as it is an absolute RAM whore.  Can someone help?
    You may have to re-check the Safety Warning Screen setting, it most likely shows it as being disabled already, but for me, I had to check it (enable it) and then uncheck it (disable) in order for it to go back to how it was before.
  • droseofcdroseofc Posts: 60
    Hiro Protagonist
    Also, there are two options for running as administrator within the shortcut properties. First one is in Compatiblity Tab, and the second is within the bottom option of that tab that says "Change settings for all users". In that option, there is also a run as admin box. Check that one, I am pretty sure it is more permanent than the first one, because when it is checked it grays out the previous option before it. I check both, first the one on compatibility, and then inside the change for all users next. Apply, and then ok.
  • sherpa25sherpa25 Posts: 50
    Hiro Protagonist
    edited August 2017
    You guys know how I can put Oculus Home to startup when I boot Win10? Tried including Oculus Client in startup via shell:startup but it doesnt start with Win10.

    Also, any way to turn off the Health warning? Already have it turned off in OHome, but every start of OHome, it keeps showing up. Tnx.
  • droseofcdroseofc Posts: 60
    Hiro Protagonist
    sherpa25 said:
    You guys know how I can put Oculus Home to startup when I boot Win10? Tried including Oculus Client in startup via shell:startup but it doesnt start with Win10.

    Also, any way to turn off the Health warning? Already have it turned off in OHome, but every start of OHome, it keeps showing up. Tnx.
    You might have to re-enable the health warning and then disable again. If you use the Oculus Tray Tool, there is an option to launch oculus home when windows starts. I am not positive, but it may or may not work if you have the "Run as administrator box" box checked for launching steam without oculus. Not sure though. I only would imagine as it prevents it from running normally, then it might prevent it from launching at start as well. Not positive though, nor am I about the Oculus Tray Tool, as I've never tried the launch at start up option, but it is there.
  • sherpa25sherpa25 Posts: 50
    Hiro Protagonist
    droseofc said:
    sherpa25 said:
    You guys know how I can put Oculus Home to startup when I boot Win10? Tried including Oculus Client in startup via shell:startup but it doesnt start with Win10.

    Also, any way to turn off the Health warning? Already have it turned off in OHome, but every start of OHome, it keeps showing up. Tnx.
    You might have to re-enable the health warning and then disable again. If you use the Oculus Tray Tool, there is an option to launch oculus home when windows starts. I am not positive, but it may or may not work if you have the "Run as administrator box" box checked for launching steam without oculus. Not sure though. I only would imagine as it prevents it from running normally, then it might prevent it from launching at start as well. Not positive though, nor am I about the Oculus Tray Tool, as I've never tried the launch at start up option, but it is there.
    Will try that, re-enabling it and disabling again.

    Yeah, enabled in OTT but it doesnt start up. Weird too that OHome minimize button usually actually closes the OHome client, and I have to run it again... but thats more of an OHome issue.
  • crossmrcrossmr Posts: 21
    Brain Burst
    edited September 2017
    I just did this, clicked on the oculus short cut in my start menu, set it to administrator, then fired up SteamVR but Oculus Home opened anyway.

    I also tried doing this directly on the oculus client file here: C:\Program Files\Oculus\Support\oculus-client and it made no difference, oculus home still launches with SteamVR.


  • droseofcdroseofc Posts: 60
    Hiro Protagonist
    crossmr said:
    I just did this, clicked on the oculus short cut in my start menu, set it to administrator, then fired up SteamVR but Oculus Home opened anyway.

    I also tried doing this directly on the oculus client file here: C:\Program Files\Oculus\Support\oculus-client and it made no difference, oculus home still launches with SteamVR.


    I have noticed, likely after oculus updates, that I need to reset the setting that is for safety warning notification, because it needs to be disabled in order for it to not launch. If that doesnt work, I am able to just exit out of oculus and steam vr will remain displayed. 
  • crossmrcrossmr Posts: 21
    Brain Burst
    I tried to exit oculus and SteamVR instantly closed.

    The health and safety warning is disabled in my oculus home (was already disabled) don't think that's it at all. Is it working for you now? are you on the public test channel?

  • seansedseansed Posts: 9
    NerveGear
    crossmr said:
    I tried to exit oculus and SteamVR instantly closed.

    The health and safety warning is disabled in my oculus home (was already disabled) don't think that's it at all. Is it working for you now? are you on the public test channel?

    I'm having the same issue that you are. The Oculus Home still opens when I load up a SteamVR game as well even with the shortcut set to Admin. I thought Oculus Home was required to start up for you to even use the headset anyways?
  • falken76falken76 Posts: 2,806 Valuable Player
    How much ram does everyone have?  I have 16 gb and never run low on resources.  I do in CAD, but not in VR.  Are others running out of ram when steam runs?  Steam seems to run just fine for me and my system is old as the hills.  In computer years, my machine would be the titanic.  It sounds like Oculus is patching their software in updates so this trick stops working, is that what they're doing?
  • snowdogsnowdog Posts: 6,907 Valuable Player
    Why on earth would you want to do this? By running a SteamVR game without Oculus Home and the OculusSDK you won't have the benefits of ATW and ASW so you'll have poorer performance in games.
    "This you have to understand. There's only one way to hurt a man who's lost everything. Give him back something broken."

    Thomas Covenant, Unbeliever
  • seansedseansed Posts: 9
    NerveGear
    snowdog said:
    Why on earth would you want to do this? By running a SteamVR game without Oculus Home and the OculusSDK you won't have the benefits of ATW and ASW so you'll have poorer performance in games.
    I read that people did see performance increases via the more available RAM which is why I was curious. I have 8gb in my system and between Oculus Home, SteamVR, the game I'm playing, and antivirus/Windows/Plex server running in the background I do max out the 8gb.
  • BeastyBaiterBeastyBaiter Posts: 788
    3Jane
    snowdog said:
    Why on earth would you want to do this? By running a SteamVR game without Oculus Home and the OculusSDK you won't have the benefits of ATW and ASW so you'll have poorer performance in games.
    If it bumps FPS up so that you have 90 fps locked, it's preferable. Also, ASW is incompatible with pretty much any fast paced game (results in unplayable levels of distortion). In every single game I play, 45 fps with ASW off is greatly preferable to 45 fps with ASW on. ASW is a very cool idea and I can see it working exceptionally well in more sedate games (eg Lucky's Tale), but it's far from universally helpful.
  • droseofcdroseofc Posts: 60
    Hiro Protagonist
    edited September 2017

           Well, I am not entirely sure what could possibly be causing Oculus to still launch, unless you have the tray tool settings set up to launch oculus somehow. Heres the simple steps I do and have always done without issue, except the one time after an update maybe,which usually requires RE-enabling the safety warning and THEN disabling. I skip video, and accept.

           For the Oculus shortcut on your desktop or wherever you have it, right click it. Click Properties. Go to the "Compatability" tab. 

     Down at the bottom of that it says "Change settings for all users". Click it.

    Inside that it at the bottom, check the box that says "Run this program as an administrator"

    Apply, click ok, Apply, and OK. Try again.

    I just rechecked to make sure I wasn't also having Oculus launch, and I have it on my head right now with Steam VR up, I'm in space (my environment) and oclulus is not running. No issues. I first launched Oculus, made sure it was on, then launched SteamVR, made sure I was in space, Closed oculus, and I'm still in space. I usually just launch Steam VR without checking Oculus or it launching.

  • droseofcdroseofc Posts: 60
    Hiro Protagonist
    I am on Public Beta 1.18.0.442021
  • droseofcdroseofc Posts: 60
    Hiro Protagonist

          I have, from what I can tell and confidently say, definitely seen a big difference, especially in the speed of launching a SteamVR game vs launching a SteamVR game with Oculus running in the background. And its not a problem I usually have, SSDs, i7, NV 1080, 16GB ram, I mean I don't have a problem launching stuff so when I say it makes a difference I would imagine for a pc with the same or less of my pc there would be a noticable difference too.

          And as for performance, I could not tell any difference, besides negatively, of running with Oculus vs without in terms of graphical and experience, except the bad one of having multiple virtual reality programs running simultaneously.

    Oculus tray tool has an option to set ASW mode, but really it boils down to....

    ATW/ASW on Rift via SteamVR

    I've seen some confusion online regarding this and wanted to set the record straight.

    When running the Rift through SteamVR, the Oculus runtime is still responsible for presenting images to the device's screen. The SteamVR compositor adds chaperone, the dashboard, etc. but then hands off the textures to the Oculus compositor for it to perform its own distortion correction, chromatic aberration correction, etc. This also allows their framerate mitigation techniques (i.e. ATW and/or ASW to kick in), bypassing our own implementations of similar techniques.


  • droseofcdroseofc Posts: 60
    Hiro Protagonist
    I imagine he is talking about the OVRServer_x64.exe and/or the OVRService that does run, constantly I believe.
  • CaTaPulT88CaTaPulT88 Posts: 7
    NerveGear
    The easy way to make it so Oculus Home does NOT start when you want to run SteamVR is to right click the Oculus shortcut on your desktop, choose "properties" then choose the "compatibility" tab, then click the "run this program as an administrator". To run Oculus Home once you have done this, you have to double click the desktop shortcut. :)
  • droseofcdroseofc Posts: 60
    Hiro Protagonist
    The easy way to make it so Oculus Home does NOT start when you want to run SteamVR is to right click the Oculus shortcut on your desktop, choose "properties" then choose the "compatibility" tab, then click the "run this program as an administrator". To run Oculus Home once you have done this, you have to double click the desktop shortcut. :)
    Right, same steps as its been since post 1. 
  • WreckLuse68WreckLuse68 Posts: 250
    Nexus 6
    crossmr said:
    I just did this, clicked on the oculus short cut in my start menu, set it to administrator, then fired up SteamVR but Oculus Home opened anyway.

    I also tried doing this directly on the oculus client file here: C:\Program Files\Oculus\Support\oculus-client and it made no difference, oculus home still launches with SteamVR.


    You may need to set your windows security settings...I have my Home set to 'run as admin' and I get the yes/no option when I run Home direct from a shortcut...this stops it from loading with Steam.
    When Einstein was asked how it felt to be the smartest man on Earth, he replied, “I wouldn’t know. Ask Nikola Tesla”.
Sign In or Register to comment.