Tracking-judder / Strange workaround — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Tracking-judder / Strange workaround

ZebKingstonZebKingston Posts: 20
Brain Burst
Ladies and gentlemen,

I'm trying to find a solution to an issue which has emerged out of the blue, and - despite having invested hours of research - I couldn't find any viable information / remedy for, so far.

Brief introduction:
I started with VR-app-development (hobby only!) like 3 years ago. At the time I was using a W-Series-Notebook manufactured by Lenovo.
While not serving top-notch-VR-performances, it was still able to run Unity / Blender + VR at around 65-70 FPS.
That was until Oculus released their first consumer-software...
The GPU couldn't take it any longer and therefore I switched to a custom built Mini-ITX system.

The Mini-ITX system did it's job quite well, but I always missed the portability / option of working / experimenting 'on-the-go'...
That's why I decided to try my luck with ASUS and it's GL502VM.

I was pretty happy with this notebook and it's capabilities, especially concerning it's rather lightweight build / design - until recently...

So, to cut a long story short:
Since like a week or so, while running any game / application, there would appear some sort of "tracking-judder", like, out of the blue.
It doesn't seem to be an issue of the tracking camera as - when covered - the judder is still there.
It's not an FPS-problem, either - those numbers look just fine.

There's one strange workaround that - in fact - does help - but the remedy would only last for a couple minutes:
If I take-off the headset and put it back on again, the tracking returns to flawless functionality - the judder would then be absent for a couple minutes.

Actions taken so far:

Disabled USB-power-saving-features (via device manager) for the following devices:
- Rift sensor
- USB-controllers

To prevent thermal throttling:
- Undervolted the CPU by -0.110V (Intel XTU)
- Disabled TurboBoost (Registry / Power plan changes)
- Applied custom GPU-profile (MSI Afterburner)

STEAM VR-settings:
- Disabled asynchronous reprojection
- Disabled interleaved reprojection

Clean Windows 10-install (no kidding)

I'm really out of ideas at this moment and I'd be highly grateful for any suggestions.
P.S: I'm not quite sure whether there's a correlation between the judder-issues and the Windows 10-fall-update.

Thank you in advance + best regards

Comments

  • droseofcdroseofc Posts: 60
    Hiro Protagonist
    Is the sensor on the headset firmly against your head the whole time and is it fitted to recommendation fit? Seems like as you move the sensor gets seperated, even slightly from your head and if you take it off and put back on it is fine, likely until movement? By sensor im meaning the one inside the headset that you can put your finger over and it will come on as if on your head
  • JutaeJutae Posts: 1
    NerveGear
    Hi Sam, I had same problem? It took me 2 nights to work out what it was and the answer was the new Nvidia drivers 388.13 so I rolled back to 388.00 and low and behold problem sorted
  • ZebKingstonZebKingston Posts: 20
    Brain Burst
    Hi @droseofc + @Jutae,
    thank you both very much for your input!

    @droseofc
    I applied some duct tape onto the proximity-sensor.
    While this 'mod' would keep the headset on all the time it wouldn't help with the judder issue, unfortunately.

    @Jutae
    I performed a driver-rollback to 388.00 - unfortunately to no avail.
    The judder-issue would still pop-up out of nowhere.

    Thank you again + best regards

  • HedgyHedgy Posts: 62
    Hiro Protagonist
    I'm getting this in Elite Dangerous, I'll try the above and report back.
  • droseofcdroseofc Posts: 60
    Hiro Protagonist
    Mine would judder it seemed there for awhile whenever I had the monitor on full screen. You can test this by either minimizing the window on the monitor or hovering over a differerent minimized window on the taskbar. Disabling DSR(?) I believe in nvidia control panel fixed this. Idk if it was dsr, but its the one that has options within it of x1.00 x1.25 x1.75 etc. Its the option that increases resolution 
  • HedgyHedgy Posts: 62
    Hiro Protagonist
    Rolling back the driver fixed it, back to being smooth, my PC rolled me back to 385.69 :) I used Oculus tray tool to overlay the performance and it didn't seem any different between the old and new driver so it isn't performance just something else in the witchcraft that are GFX drivers.
  • ZebKingstonZebKingston Posts: 20
    Brain Burst
    Hi @Hedgy,

    thank you very much for your input!
    I'm on WIN 10 Build 1709 (Fall Creators Update), I did roll back the NVIDIA-driver to 382.53 - now it's running perfectly fine!



    I've been playing Project Cars for about 2 hours straight - didn't start to judder once!
    Temps and performance-levels were both stable.


    Quick note regarding roll-back-procedure:
    Enabled flight mode, uninstalled the NVIDIA-drivers via appwiz / devmgmt (delete driver).
    Rebooted the client - after a couple seconds WIN 10 would apply the "supplied" NVIDIA-driver (382.53).

    I'd like to thank everybody who's been involved - really appreciate your efforts
    @droseofc @Jutae @Hedgy
  • HedgyHedgy Posts: 62
    Hiro Protagonist
    Glad it's fixed, I just went to 'device manager' right clicked on my graphic card and chose properties, then 'roll back driver on the driver tab. 
Sign In or Register to comment.