Rift Stuttering - Page 2 — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Rift Stuttering

2»

Comments

  • f1iceman07f1iceman07 Posts: 40
    Brain Burst
    Just read up on the nvidia site and its saying the windows creator update has also caused issues with the colour which might not be helping matters, so its saying to eliminate issues there to set display colours to 8..
    Sounds like theres a mess going on from drivers from everyone atm hence everytime im switching on i get somekind of issues atm.
    Solve 1 then another pops up.
    But defo try the colour display setting aswell.
  • f1iceman07f1iceman07 Posts: 40
    Brain Burst
    just an update i have re-installed afterburner and it will crash the oculus home with or without power enabled. afterburner is not happy on my pc now :-( 

  • vds32vds32 Posts: 3
    NerveGear
    Iceman, all I can say with 100% certainty what caused the problem for me was the NVIDIA driver update that added the recording overlay icon to popup before the oculus home. When I completely disabled this feature it 100% cured the problem for me. Its smoother than ever!

    One thing I also did at the same time was remove the POWER % monitor from afterburner as well, so it might have been a combo of the two, but I'm pretty much certain disabling the NVidia CTL-Z overlay fixed it! good luck to all in search of this thread
  • hoppingbunny123hoppingbunny123 Posts: 455
    Nexus 6
    start, run, type msconfig. go to startup, disable "NVIDIA Capture Server Proxy", reboot try again
  • DaftnDirectDaftnDirect Posts: 4,783 Valuable Player
    vds32 said:
    Iceman, all I can say with 100% certainty what caused the problem for me was the NVIDIA driver update that added the recording overlay icon to popup before the oculus home. When I completely disabled this feature it 100% cured the problem for me. Its smoother than ever!

    One thing I also did at the same time was remove the POWER % monitor from afterburner as well, so it might have been a combo of the two, but I'm pretty much certain disabling the NVidia CTL-Z overlay fixed it! good luck to all in search of this thread
    That's interesting, I always untick the NVIDIA Experience option when updating the drivers which the recording function is part of.... think I'll carry on doing that.
    Intel 5820K OC@4Ghz, Titan X (Maxwell), 16GB Corsair Vengeance DDR4, ASRock X99 Taichi, Samsung 500Gb 960 Evo M.2, Corsair H100i v2 Cooler, Inateck KTU3FR-4P USB 3 card, Windows 10 Pro v1903 (18362.239)
  • animal_timeanimal_time Posts: 1
    NerveGear
    edited November 2017
    I suddenly have this problem too. In Oculus Home or any game, when I move my head, the whole environment moves a little bit. It's not consistent, but when it happens it's immersion breaking and slightly nauseating.

    My graphics card Radeon RX 480 with the latest drivers and I'm running Oculus App 1.20.0.474906.

    I didn't have this problem a few weeks ago, so my guess is that it's caused by an update in the Oculus software. It's not limited to Nvidia cards, since mine is AMD and I have the same issue described by several others in the thread. 

    I've tried rebooting and running through the Oculus setup again, the problem still exists. I also disabled the Beta option and it didn't help either. I'd love to hear suggestions of how to fix this. Thanks.
  • heynowbrowncowheynowbrowncow Posts: 127
    Hiro Protagonist
    edited November 2017
    "UPDATE: The answer was surprising and simple: There is some issue with the GTX970 and using DVI out for the monitor. When I switched to a Display Port to HDMI adapter suddenly the computer had no more frame skips! BIZARRE! I still think this is a Nvidia driver issue possibly mixed with an Nvidia hardware issue. Regardless it seems to work now! "



    this is just a guess but set your desktop resolution to 1280 x 720, some games are set to this resolution and if your monitor is set to a different resolution it can cause a issue like the steam game rocket league did when the resolution was 1080p no game but at 720 p it worked, the bug is fixed now but there you go, try 720 p desktop resolution.
  • AymitoAymito Posts: 41
    Brain Burst
    my Oculus rift  finale updated to 1.20 and I can confirm the stuttering is  visible even in simple development projects, the rift performance is down by about 20% I would say and for unknown reason , the hardware and all other drivers are the same  as before, so I guess this update is responsible somehow... :/

  • EliteSPAEliteSPA Posts: 1,560
    Project 2501
    edited November 2017
    Works perfect here.

    I know it sounds stupid but have you change the pixel density in oculus debug tool and forgot to set it back to 1.0?

    Also check your nvidia control panel and be sure is set as "perfomance"
    i7 6700K @ 4.2 GHz | Corsair 16GB DDR4 PC2300 | GTX 1080 Ti | Asus z170-Pro | Corsair RGB Strafe Keyboard | Logitech G27 | Oculus CV1 + Touch + 4 Sensors | Win 10 64 bit | Acer Predator x34 @ 100Hz
  • UBSERDUBSERD Posts: 348
    Nexus 6
    Please all still having these issues, make your voice heard in this post I just put on the forums after you receive the 1.20.01 update. For those having stuttering, and hitching issues, has your performance gotten worse since 1.20.01?
    Thanks!
  • christopher_drumchristopher_drum Posts: 1
    NerveGear
    @vds32 I believe Windows 10 also has the XBox app which has the option to do its own overlay, similar to the Nvidia overlay. Also, doesn't Steam have its own option as well? I think there might even be other apps/services that try do it. I wonder if there is benefit to checking all similar services and disabling every last one of them? I'm going to do your Nvidia trick tonight!
  • Eclipse8301Eclipse8301 Posts: 5
    NerveGear
    This has been driving me crazy for months, my Rift setup worked flawless until like a month or so ago. I have tried moving my sensors about 10 different Nvidia drivers and about a hundred other failed suggestions i found on the net. I don't have afterburner but I do have precision X which I disabled power % on and had completely off while on the Oculus. About the only thing I have not tried is I read in one place that teamviewer server running in the background will affect performance. I  can't kill the process as it will just reappear again.

    Anyone that has stuttering have teamviewer by chance?

    My setup
    3 sensor setup.
    1070 GTX
    I7 7700K
    Win 10 with fall update installed

    Things I have tried off the top of my head
    -Removed mirrors
    -Moved sensors all around
    -7-10 different driver set (clean install)
    -Turned game mode off in windows settings
    -Precision X changes as noted above
    -on screen recording (Geforce experience)
    -Max performance is of course on in Nvidia options and my PC.
    -a ton of other things I can't think of at the moment
  • detroitslayerdetroitslayer Posts: 2
    NerveGear
    My stutter was found in my task manager. Service host processes spiking my performance. 2 of them specifically had my CPU holding around 40-50% usage at idle. When I launched Oculus, Id watch the CPU max and the stutter occur. I killed the processes and got the stutter to go away for good. What Im seeing though is alot of this stutter issue is based on system setup, so my fix could be irrelevant. This stutter showed up after Coco download.

    2 sensors
    I5-7600k
    1080 FTW hybrid

    Side note:
    Prior to finding and killing the processes, I checked my device manager and there was a conflict on the USB 3.0 port the headset was plugged into. Swapped it with a sensor and it resolved. Did notice an improvement in stutter prior to my ultimate resolve.
  • blanesblanes Posts: 1,067
    3Jane
    I have the Oculus 1.20 update and latest nvidia drivers and the stutter is bad plus my performance has dropped hugely.  Picked up battlezone on the Steam sale and can only run at Low settings with pixel density / supersampling at 0.80 otherwise is stutters and lags and makes me sick really quick.  Has anyone found solution ?
  • UBSERDUBSERD Posts: 348
    Nexus 6
     Go to this link at the bottom to bring you to this magical forum post.  Look at the comment from aisepos! His suggestion actually fixed everything. Oculus has never suggested this but now they will. This man is a genius and he actually figured out why I was having my problems... all 6 months of them.  I can’t guarantee it’s a cure all but I hope this helps you too and give him a shout if you see him. He is a God!!!! 

    Thanks to everyone in their suggestions if they are reading this. I really appreciate all the help and working together to figure out these things for the community.

    See you in the Rift!

    https://forums.oculusvr.com/community/discussion/58073/poor-tracking-quality-audio-glitches-lagging-etc-after-half-hour-of-use#latest
  • Sharkster-NVRSharkster-NVR Posts: 74
    Hiro Protagonist
    edited January 2018
    @UBSERD - You really shouldn't jump on every thread dealing with the weird NVidia caused stuttering and claim that it's solved, when you come back the next day saying that it did in fact NOT help you. This makes people think there actually is a solution to this problem, if you write it everywhere.

    Also... it's sad, that the discussion about the NVidia driver f*ck up is spread over dozens of different threads, instead of just dealing with one thread (hint at the mods to merge them).

    A temporary solution to the problem is to roll back to the July/August release of the Nvidia drivers (as described in this thread: https://forums.oculusvr.com/community/discussion/59281/nvidia-drivers-and-oculus-rift-head-tracking-stutter-judder), but unfortunately, the new Oculus Home screen doesn't work with these old drivers (only in "classic" mode). It's all a huge mess, largely ignored by NVidia.
    ERAZER X7849 Notebook - CPU: Intel Core i7 6820HK - GPU: GTX 1070, 8 GB GDDR5 RAM - RAM: 32 GB (4x 8 GB DDR4 HYNIX PC4 17000 DUAL CHANNEL) - MAINBOARD: INTEL HM170
  • UBSERDUBSERD Posts: 348
    Nexus 6
    edited January 2018
    @Sharkster-NVR I can see your point.

    If support was actually able to help with these issues or have actual helpful feedback I wouldn’t of had to post things like I do.

    Instead they tell me it’s my hardware or drivers which were and are fully up to date but in actuality it’s that their software wasn’t designed for every combo of even some of the most elite hardware. Doesn’t make sense man.

    What am I to do then just deal? By the by I also tried what you linked above and also no dice.

    Anything to try as a solution should be welcomed not shunned. I was just trying to help people man.  Any piece of information that could possibly solve one person’s problem makes it worthwhile for me. 
  • Sharkster-NVRSharkster-NVR Posts: 74
    Hiro Protagonist
    You rolled back to 384.94 and it didn't help? Did you check if Windows auto-updated back to the current NVidia drivers after the install? You need to make sure to really fully delete/uninstall the current drivers and also make sure, Windows doesn't just auto-update after you rolled back. DDU uninstaller helps with that task (display driver uninstaller). To me, it got rid of ALL stutters. And I was experimenting a lot with BIOS etc. too, before I came to that solution.
    ERAZER X7849 Notebook - CPU: Intel Core i7 6820HK - GPU: GTX 1070, 8 GB GDDR5 RAM - RAM: 32 GB (4x 8 GB DDR4 HYNIX PC4 17000 DUAL CHANNEL) - MAINBOARD: INTEL HM170
  • UBSERDUBSERD Posts: 348
    Nexus 6
    I usually use DDU to uninstall clean, then installing directly from Nvidias site. I will try it again and report back. I haven’t tried since Rift 2.0 to be honest but I heard going too far back with the drivers after the Rift core 2  breaks a bunch of games. I’m guessing this is not the case for you Sharkster-NVR?
  • Sharkster-NVRSharkster-NVR Posts: 74
    Hiro Protagonist
    Well, the main point when going back with NVidia drivers ist that you cannot use the new Home-Screen, but have to use the "classic" Home-Screen. This option can be chosen from the options menu. Other than that, I didn't encounter any issues. But I don't have a lot of games installed anyway.

    However, being a VR dev, I can tell you that the latest version of Unreal Engine (4.19) not only runs on older NVidia drivers, but performs even better.
    ERAZER X7849 Notebook - CPU: Intel Core i7 6820HK - GPU: GTX 1070, 8 GB GDDR5 RAM - RAM: 32 GB (4x 8 GB DDR4 HYNIX PC4 17000 DUAL CHANNEL) - MAINBOARD: INTEL HM170
  • ThatRacer1000ThatRacer1000 Posts: 0
    NerveGear
    I Have an Arch Angles Cyber Tech gaming computer with a GTX1080ti and it seem that when in iracing i get major frame rate lag or something. not my network because without the oculus it works flawless. tryed all the driver yall have sayed work and nothing and have tryed all settings and nothing helps

  • ThatRacer1000ThatRacer1000 Posts: 0
    NerveGear
    I Have an Arch Angles Cyber Tech gaming computer with a GTX1080ti and it seem that when in iracing i get major frame rate lag or something. not my network because without the oculus it works flawless. 
  • ThatRacer1000ThatRacer1000 Posts: 0
    NerveGear
    I Have an Arch Angles Cyber Tech gaming computer with a GTX1080ti and it seem that when in iracing i get major frame rate lag or something. not my network because without the oculus it works flawless. 
  • iNeoTroniCiNeoTroniC Posts: 7
    NerveGear
    Just solved my stuttering issues! I know this won't work for everyone but I wanted to share this with my VR fellas...
    I just switched from a Z77 Asus Hero VI board with a 4770k to a Z390 Asus Hero XI board with a 9900k. After disabling all power saving stuff on my old Z77 board I had no issues with the Oculus at all, even with all the ASUS stuff up and runnning (AI Suite aso). Build new PC, installed Win10 and updated all drivers, tested VR, stuttering after arround 5min when moving the head... Awesome I thought, Z390 not compatible with Rift...?! Did all "standard" procedures, which means reinstalling Oculus, switched USB ports arround, tested older nVidia drivers, checked temps, nothing worked. After 2 days of a mixture of panic/angry/sad mode I was about to give up... Entered VR, played about 10min, stuttering starts, checking tasks in task manager while in VR using Virtual Desktop: Found a service called LightningService using 2% CPU. Stopped the task and stuttering gone instantly!!! LightningService is part of Asus Aura and manages the color animation effects of these shiny RGB leds, if set to rainbow for example. If I set a static color in Asus Aura or stopped the task before playing in VR all stuttering was gone. On my old system I had Asus Aura up and running all the time, too. But I always set this to a static color, never to a color animation. So constantly changing the color of Asus Aura hardware causes stuttering in VR, at least in my case...
  • FishNChispsFishNChisps Posts: 6
    NerveGear
    I have a solution but I am not very good with explaining stuff and I am afraid of you guys judging my grammars and stuff like that so here's a video that I posted  if you have any questions leave it down in the comments
  • OmegaM4NOmegaM4N Posts: 424
    Trinity
    edited December 2018
    I will give this a look as i am having a minor issues with Dirt Rally, nothing massive though, just some weird issue whereas the screen moves with my head direction somewhat, so if i turn my head left the whole screen will turn left with me somewhat before it stops, and the same with any direction i move my head, but i will figure it out, and it is always worth checking out stuff like this in case you stumble on a fix or answer.   ;)

    And do not worry about your grammer and spelling, mine are both atrocious at times.  :( 

  • FishNChispsFishNChisps Posts: 6
    NerveGear
    I AM SO SORRY IF THE OTHER ONE DIDN'T WORK I made a new tutorial tho, sorry if it's boring

  • PickleSteve666PickleSteve666 Posts: 1
    NerveGear
    There maybe a simple fix for all of yall. It could be asynchronous reprojection. Try holding right ctrl and pressing 1 on the number pad. I have to do this everytime i start up oculus app. :)
Sign In or Register to comment.