New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Not Enough Space - But I do?!

1NeedHelp1NeedHelp Posts: 1
NerveGear
So for the past 2 hours I've been trying to set up my new Oculus Rift that I just got, but its been a hassle. Now whenever I run the software the program says, "Not Enough Space The oculus rift need 6.37 gb of storage." Thing is I have a spare 437 gb drive that I want to us for it and it is in a D:\.
Although I installed the software through my D:\ Drive it keeps downloading the contents to my C:\ Drive and is overall annoying. I am trying to move the files by using the instructions on the support page, https://support.oculus.com/1142129705828091/ ,but nothing happens it just opens the folder and doesn't move it... !?

Can I get some assistance?

Comments

  • SyrellarisSyrellaris Posts: 1,035
    Wintermute
    You can set the download folder for games int he software to the drive of your choice. 
  • falken76falken76 Posts: 2,901 Valuable Player
    I think he's running out of space on his C drive.  Oculus installs the main software on the C drive and you can set the path for game installs during the initial setup.  But C needs enough space for the program install.  The link the OP provided looks like it is using the command line (dos) to set the directory path or tricking the system into think the path has been changed.

    If the C drive is that full, he should backup and do a complete re-install of the OS because no space available on your c: drive will cause problems with everything eventually.
  • RichardNixonRichardNixon Posts: 2
    NerveGear
    edited December 2017
    I had the exact same problem, here is the solution.

    The problem is Oculus has a code line, where it picks and chooses which drive should be used, and the drive has to be "Basic" Type and "NTFS" format. I was on live support with oculus, before I figured out the problem. 

    1. Goto "Disk Management" in windows
    2. Looks at your different drives and see if they are in "NTFS" format and "Basic" type. (Your drive is most likely "Dynamic" and in "NTFS" Format)

    3 If they aren't you are going to want to backup all of your files on your D: drive and put them on your C: drive (If you  have space) or another drive for the time being. (Transferring your files will take a while)

    4. Open Computer Management (Local), to open it press the windows key and R on your keyboard simultaneously and in the run window type compmgmt.msc and then press enter. 

    5. In the console tree, click Computer Management and then click Disk Management.

    6. Right-click each volume on the dynamic disk you want to convert to a basic disk, and then click Delete Volume for each   volume on the disk

    7 When all volumes on the disk have been deleted, right-click the disk, and then click Convert To Basic Disk.

    8  After this, you want to right click the disk again, then hit "Create new volume", go through all of the steps that it says.

    8. After this, transfer all of your files back to your D: drive

    9. Redownload Oculus setup

    10. Ta Da

  • cyberealitycybereality Posts: 26,156 Oculus Staff
    The folder you select is for your games (and needs at least 120GB free). The Oculus app itself still always installs on the C drive, so you need space there too. It used to be 4GB, but having at least 8GB free should be sufficient.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • KevinB63KevinB63 Posts: 1
    NerveGear
    This is bullshit, the fact I just spent all this money on this VR and have to do all this extra shit because you guys fked up the code is ridiculous. 
  • ScaryCherryScaryCherry Posts: 1
    NerveGear
    been sitting here for 12 hours trying to do everything and nothing worked returning the oculus

  • FretcozFretcoz Posts: 3
    NerveGear
    fuck oculus man i have been awake for almost 3 days trying to clear some space on my drive rn i have 82.6GB out of 155GB,but it still wont download

  • jmcguire.devjmcguire.dev Posts: 2
    NerveGear
    If it still doesn't work, open up your file explorer
    Locate where your OculusSetup is
    In the address bar, clear it and type "cmd"
    Then copy and paste this is into the command console "OculusSetup.exe /drive=D "
    The setup should loadup, then Ta da


    This worked for me. Thanks!
  • NunyabinezNunyabinez Posts: 55
    Hiro Protagonist
    edited March 17
    A couple of comments for people who might come across this thread. If you are a serious PC user your instincts will betray you. DON'T try use symbolic links or other fancy tricks to move files. They won't work.

    Use the Oculus app to do it. Go to Settings>General>Library Locations and then add your new location.
    Then go to your INSTALLED GAME in the Oculus app, click on the three dots, select move, select location and let it move it.

    Important point: To install to a specific drive, go to the same location as above and change the default drive. You can't choose which drive when you install an app, but you can choose which drive is the default drive before and it will install it to that drive.

    This is a terrible implementation, but in general Oculus has a strange process for handling installs. My experience is that when there is an update, Oculus downloads the entire game to the staging folder and then moves it to the normal directory when complete. When Asgard's Wrath updated, I had to make room for 120+GB of space just to update it even though it was already installed. 
    i7 8700, 16GB, RTX 2080 TI, Rift CV1 | i5 4690K, 16GB, GTX 1660 TI, Rift CV1 | Quest
  • kruger4451kruger4451 Posts: 1
    NerveGear
    Ok, so i converted my drive to basic format, i had ntfs, and ye it worked, however, i didn't back up my data.. But i don't care much about them.
  • Freddymantyler126Freddymantyler126 Posts: 1
    NerveGear
    If it still doesn't work, open up your file explorer
    Locate where your OculusSetup is
    In the address bar, clear it and type "cmd"
    Then copy and paste this is into the command console "OculusSetup.exe /drive=D "
    The setup should loadup, then Ta da


    HOLY THANKS, YOU ARE A GOD!
Sign In or Register to comment.