New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Fixed stuttering on Dash 2.0

balzionbalzion Posts: 5
Hi all,

Just thought I'd share some experiences that I had in case anyone had the same experience, and how I went about diagnosing it over the course of a month. This was super frustrating, so I hope this helps someone else. I have a GTX 1070 on a Sager laptop. My problem was that any time I played VR for any length of time, and sometimes immediately when launching new games, the headset would start stuttering/jittering all over. I would have a ghosted image as well, but the video on the cloned screen on my laptop would be smooth and fine. Long story short, my graphics card was overheating and was throttling itself. Cleaning my fans fixed the issue. If you have this problem and vacuuming fans doesn't help, you might need new thermal paste or something. Now that it's staying cooler, I can pretty much play anything on Steam or Oculus and can use Dash 2.0 just fine with no jitters. I was convinced this was a software problem, but was completely wrong.

I tried all kinds of things to diagnose the problem, downgrading video card drivers, uninstalling 2.0, changing every setting imaginable in Nvidia Control Panel. Downgrading the drivers actually helped for the most part, and would make games playable for a longer period of time, so there must be something in newer drivers or dash that drives cards harder or decreases performance. However, I'd still have the issue after a while depending on the game, and games like Onward would cause the jittering to happen very quickly. The only thing that seemed to help then was to restart the Oculus service and then relaunching the game and it'd be playable for a bit longer then start stuttering again. This didn't seem like an immediate thing and was very confusing and frustrating. I tried turning ASW off and it would help as well for a while.

The first thing that confused me was that in the Oculus Tray Tool under Performance, my frame rate would be under 90 fps, but my headroom would be -100-200%. I thought it was a glitch in the reporting, but it's because my GPU was operating way under its potential. Once I fixed my issues, framerate sticks around 90fps everywhere and the headroom went back to 30-50% or so. The Oculus Tray Tool Performance tab should be your first place to look. I still don't understand all of the other tabs, but knowing what your FPS is and your headroom, as well as an idea of how many frames are being dropped is important to know what the root issue is.

What really helped to diagnose the problem was a utility called GPU-Z. On the status tab, there's both the GPU temperature and a field called "PerfCap Reason" that shows you the limiting factor for the GPU. For me, it was "Thrm", meaning that the GPU was too hot and it'd drop the Core Clock speed to ~300 MHz from ~1400 MHz. Even if heat isn't your problem, this tool may be able to help you find your problem. Here's an example image of what mine looks while idle and on battery (hence the low numbers):

In the course of trying to figure out the jittering, I've found that a lot of people can solve this in different ways, and different things can cause it. Here's a list of reasons/potential reasons that people had the issue:

1.) Their card is just underpowered. It can't keep up with either the new drivers or dash. This is what I thought my issue was, but a 1070 GTX is able to handle it just fine with plenty of headroom when it's operating correctly.
2.) ASW can seem to magnify the problem, but I don't really think is a root cause. Disabling it for me seemed to get rid of the jitters, but there was still a slight ghosting and eventually didn't help.
3.) Lowering supersampling also reduces the load on the GPU. If your card is throttling itself, no level of supersampling will help. If not, try lowering it to reduce the load on the GPU.
4.) Not running Nvidia in performance mode (Nvidia Control Panel lets you switch it)
5.) Sensors aren't tracking well, could be USB or something else. Having too many things plugged into a USB hub causes this for me. This tends to cause more of a "jumping" effect than a jittering effect.
6.) Driver incompatibilities, downgrading Nvidia drivers or reinstalling them might help
7.) Graphics in games are set too high.
8.) f.lux or screen overlays, such as Nvidia shield, Microsoft gaming recording things, etc.
9.) XMP profile in bios -- see post from aisepos here -- (I didn't have this option)
10.) Power problem. GPU-z would show Power as the main issue.

I hope some of this helps. If it doesn't, I've seen repeatedly that a support ticket with Oculus is the correct route to take. It probably would have helped me if I would have done that sooner. :)


  • FusionproFusionpro Posts: 8

    Somebody with the exact same issue as me with a huge thread about how to troubleshoot. You're a saint mate. I've been trying a bunch of stuff to solve the 'Ghosting' myself recently and will give all this some thought before returning with potential questions. 

    Aces, truly. 
  • Rob_In_PhoenixRob_In_Phoenix Posts: 344
    This is a really good post.  Nice detailed post-mortem on your issue and how you fixed it.  Solid content.
  • FusionproFusionpro Posts: 8
    Agree with Rob. Thanks for all the information mate, very well worded.

    So many possible routes, having trouble narrowing mine down - I've made a checklist from your list too. Reproducibly, some unknown event causes Elite Dangerous to enter 'choppy ghosting mode'. Monitor is smooth as butter, headset is choppy or double image.
    • GPU seems to behave as expected. I've cranked up the fans, and it's Power-capped, which is as I'd like it to be. 
    • These small jitters register as "lost frames' according to the Oculus Debugging Tools. negative 8-80% in the performance headroom once this 'choppy ghosting mode' has started. 
    @balzion, was your experience that this issue was at all times? Or only under certain conditions? I don't know what condition triggers it... but most of the time my performance is lovely enough to get along. My 'best-case' in Elite right now looks like the image below. 

    The only way for me to fix this issue is to have my headset blackout (run-time service restarting?) or restart the program before this happens. I've only had this happen with Elite on Dash I believe. Dash is so nice though, I don't want to give it up!

  • balzionbalzion Posts: 5
    That looks really similar to mine when it was stuttering. For me it took a little while to completely start stuttering, then restarting the service would fix it for a while, but otherwise, yeah, it was pretty much all of the time.

    If it's running at the usual mhz for both memory and the gpu, then it's probably a matter of turning down settings. I experienced this once in home and just had to turn down the settings. I'd start with super sampling...using oculus tray tool, try turning it down incrementally. I think you need to restart the oculus service for it to take effect.

    Otherwise, leave that display open and see what settings make an impact inside of elite. Try to increase your headroom with various settings incrementally until you have enough headroom that it stays at 90 fps, and it should stop the stuttering, particularly if you can get it up to around 30% headroom (in my experience) 
  • FusionproFusionpro Posts: 8
    Performance seems so great whenever it doesn't flip into stutter-mode, which can sometimes take hours! You wouldn't even know there was a problem or any visible frame loss. Anything relatable there? Or was it pretty out of the gate for you?

    I'll try nuking my settings beyond VR-Low and see if headroom around 30% will prevent this flip from ever happening. 

    Could I also ask what version of Nvidia drivers you're on? Did any change happen there? I've been going latest and greatest, and was thinking of regressing to the version they recommended at launch for Dash. 

    Below is the image for when stuttering has flipped on. -40 to -300% all over the board once something has broken internally. It's such a night and day: "Oh, time to restart the application" moment. Performance is so good outside of this switch with is why lowering the visuals makes me sad heh. 

    Appreciate all the help mate, you're aces. 
  • balzionbalzion Posts: 5
    Ouch, yeah, that headroom and all was pretty much exactly like mine when my card was throttling. It depended on the game. I have elite but haven't played it in a while. For some games, like Eleven Table Tennis, it sometimes took hours, but Onward was that way from the opening screen.

    The main thing that showed that my card was throttling though was the mhz drop in GPU-z while the headroom went super negative like your last picture. It sure sounds like yours may be doing something similar since the headroom drops so dramatically. 90C was the throttling temperature for me. Until the card throttled my numbers were normal, but they all changed when the card throttled (when it hit 90 degrees), mhz shot down, thermal becoming the limiting factor, and headroom tanking in the display.

    If none of that happens to you, it may be a different issue. It's weird that you have to restart the game/display though, because that's exactly what I had to do which would give the card a little break, drop the temperature again a few degrees, and let me play for a while again (raising the mhz again in GPU-z). It sounds like yours should be doing the same,

    I'm also on the latest nvidia drivers. I tried about 5 different versions though. None of them actually prevented the issue for me, since it was overheating, but the newer drivers made the card get hot faster, so I thought it was the new drivers causing the problem (and there probably is some performance issue going on with them). Software changes would delay the problem, but not prevent it for me since the card would still be getting hotter with continued play.
  • balzionbalzion Posts: 5
    One thing I failed to mention is that you can pin GPU-z with Dash and watch the numbers when it throttles. Even alt-tabbing to it might cause the numbers to change? Though I doubt it. I did have it pinned while playing Onward to diagnose it.
  • FusionproFusionpro Posts: 8
    Looking in the wrong spot me thinks. 

    My solution, for folks going bonkers like I was, is to set the CPU Priority to Above Normal / High through the Task Manager. The location is different based on your Windows version. v10 below:

    I also deleted all of Elite and did a full reinstall, but I feel like this had the most impactful effect. It really is a light and day difference for me.

    Best of luck. 
Sign In or Register to comment.