Games not launching at all — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Games not launching at all

TaiiwTheNerdTaiiwTheNerd Posts: 2
edited January 2018 in Support
Hi, I got my Oculus Rift for Christmas 2017, Today at around 5:00 PM Central Time Zone, I got in VR and tried launching Steam VR. At the time I had no games open, but it said something about multiple apps being open and that they need to be closed. The only thing I had open was Oculus Home. I exited out of VR and got on the Oculus software. I went into my library and tried opening Steam VR from there. Nothing happened. I click Steam VR and literally nothing happens. Any idea how to fix it besides restarting? (When I restart my PC I have a very painful start up with everything starting at once, so I use restarting my PC as a last resort.)


  • nalex66nalex66 Posts: 4,530 Volunteer Moderator
    edited January 2018
    Have you checked "Enable apps from unknown sources" in the Oculus app (Settings/General section)?

    Also, do apps from the Oculus store work?
    i7 5820K @ 4.25 GHz | EVGA GTX 1080 SC | Gigabyte GA-X99-UD4 | Corsair DDR4 3000 32 GB | Corsair HX 750W
    Corsair Hydro H100i | Samsung SSDs: 860 Evo 1 TB, 850 Evo 1 TB, 840 Evo 1 TB | Seagate BarraCuda HDD 3 TB
Sign In or Register to comment.