45 FPS Problem in some games - Page 2 — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

45 FPS Problem in some games

24

Answers

  • JJcourageJJcourage Posts: 23
    Brain Burst
    Hello RedLeader42, Sharkster-NVR, also Oculus Support/cybereality if this proves useful. I've found your replies above the closest to my experience of micro-stuttering.

    TL;DR -> I agree, it is not a hardware issue (in my case) but a driver upgrade issue, which somehow introduces code into Win 10 that even DDU does not remove. At the exact moment I upgraded Nvidia 385.14 to 388.xx, micro-stutters began (early Dec. 2017). Before was perfect (Dell R3 13, 1060 6Gb, OLED). Going from Oculus Client 1.19 to 1.20+ was not the problem. Downgrading from 388.xx, even to original drivers, does _not_ fix anything (as others have said on the internet). I haven't had the time to do a complete Win 10 reinstall, but after 2 months of reading around, today I have: installed Oculus Client 1.23 Beta 2.0 and latest 390.65 drivers (it still had bad microstutters, but...), then downgraded back to (non-Beta) Oculus Classic Home 1.22 _and_ crucially, switched off Unknown Apps (thus stopping access to SteamVR). I thus only see in my Oculus Library Robo Recall (nothing else installed). For the first time in two months I have had a stutter-free Robo Recall mission. (I was surprised!). My testing continues tonight, but so far, no stutters in Classic Oculus Home or Robo. Another really bad stutterer has been Tomb Raider (worse than Robo, low graphics settings or high/maxed-out graphics, exactly the same level of stuttering), in fact I've never used this in the Rift for more than 10-20 sec ever due to this stuttering), but I will try that after this post - TR is launched via SteamVR (another issue).

    Details -> I'm posting to add something to this amazingly complex issue - I've been trying for 2 months to sort out the micro-stutters myself, but I hope this info will help from my specific perspective:

    Last Black Friday, after reading abou the Rift since its launch - and waiting (hopefully) for the technology to mature - I acquired:
    Dell Alienware R3 13 / 16Gb / 512Gb / GTX1060 6Gb (+Intel HD 630) / OLED model (NB, on the OLED model, the F7 I/D GFX button is intentionally non-functional (no idea, ask Dell, but it is worth mentioning for those that have the LCD models, where it does function - in any case, I believe this is irrelevant here).
    +
    Oculus Rift + Touch + 2 sensor bundle.
    NOTE: I bought this Dell laptop setup _only_ for the Rift (to move between rooms/work/home), and it has never had any other programs installed on it. None. Just an Oculus Client and (after a week, SteamVR, more on that later). Thus, I have never had Corsair/RGB/Power/Afterburner, and such programs, but, of course, all the Dell pre-installed drivers and so on. I de-installed McAfee on first boot.

    1. The whole Rift setup worked _perfectly_ for about 5 days. Dell UK has a page showing how to setup the Rift, and this helped me buy in the first instance. The hardware is more than capable, and I experienced this to be the case, on many Rift programs and games (15), both in Oculus Library and Steam VR.
    Flawless: Robo Recall, max settings, buttery smooth.This was before any Windows updates or Nvidia driver updates, etc. So, in the first week of December 2017, I suffered _no_ Rift micro-sttutering issues. None. It was an excellent experience (but I do not use for very long) and I was very happy and enjoyed showing colleagues/friends (mostly). For other reasons, I usually have time for no more than 20 minutes in each session, so I can't comment on those reports where stutters occur over 30 min+. I hadn't looked at any forums and had no idea what 'micro-stuttering' was or even existed. Now I do of course, for 2 months of trouble-shooting.

    Power management was on Dell's recommended OLED profile (NB changing this between High Performance, makes no difference to micro-stutters AFAIK, for me).

    Start/baseline:
    Dell pre-installed A09 drivers for the laptop GTX 1060 offering (which is, when viewing the Nvidia Control Panel: Nvidia 385.14 (yes, 14, not 41, these are 385.14) drivers. At this stage, I was not bothered with what the Intel HD 630 igfx drivers were (and I also think this is never relevant).
    Oculus Client was 1.19, which on Dec. 5th received an auto update to 1.20.
    Still no problems using _just_ the Oculus Client and software one can use with it (including SteamVR, installed after 2-3 days of first boot).

    Let me choose Robo Recall, as the worst offender for micro-stutter: every second, many times, totally broken. Even Oculus Classic Home or Google Earth VR (perhaps once every 1-2 secs).

    But, when did this happen, exactly at which point, for me? I can tell you:

    At the end of the first week of the Rift, I decided to try Rift 2.0 Beta. This also required an update, at that time, to 388.xx. It installed OK, but immediately I saw the micro-stutter for the first time. Now I realised, at that point in time, I had a problem. Ok, it's a Beta. I calmed down. I rolled back the driver from the Win 10 (64 bit) control panel, back to 385.14. I then had to, of course, go back to Oculus Home 1.20 (at that time). By this method, all seemed fixed. I breathed a sigh of relief. I left some customer feedback to Oculus about this, and did say I was worried that they were forcing an upgrade to 388.xx, which clearly 'broke' the whole Rift experience for me at that point. Still, it's a Beta.

    So, I thought I was fixed, back to Stable channel, 385.14 and Client 1.20. My whole Rift experience was back to perfect, no stutters, just the limitations of a 2 sensor (360) setup (which aren't that bad of a set of limitations actually) - the touch controllers are great, no jump with them, very stable.

    This is when the fun began.
    On the next system boot, Windows forced an Update, for whatever reason, an update to 388.xx (I can't quite recall whether this was 388.13) and... I couldn't roll back the driver in the Device Manager either! Argh! [yes, micro-stutters were back, but now even in Classic Oculus Home 1.20). I discovered the DDU driver deinstall program, ran that, rebooted, and re-installed the Dell A09 original (385.14) package from Dell support. Still microstutters! Oh no. I have since tried pretty much every Nvidia package from 384.xx to 388.xx, even the 382.xx. No change. I removed all graphics drivers, even the Intel HD 630, downloaded both Intel and Nvidia packages afresh and installed them, dumped Oculus Home, together with CCleaner registry cleaning, all that stuff, everything. I even delved into the registry and tidied it up manually AFAIC. The last possibility would be a complete Win 10 reinstall. But I like to go down fighting and (I still) have not done this... read on:

    The last two months have come and gone and all the Win 10 updates, too. No change, still microstutters (I don't _believe_ any new Win updates since early Dec 2017 have added to the problems).

    Finally today, I have made progress (without a full Win 10 reinstall):

    I went all in, one more time and went to the Beta program, Oculus 1.23 and Rift Core 2.0, Nividia 390.65 - all the latest of today. I thought, heck, if it is 'broke' I may as well go bleeding edge and look at the latest offerings, even with the dreadful micro-stutters.

    2. With all the latest Oculus Beta / Nvidia 390 drivers in place, still the stuttering, but I did notice, as others have reported, it was indeed a little better in the Oculus Home/Dash 2.0. But still hopeless. Well, I thought before I put it all back in the box... and wait a month or so, let's go back down to non-Beta...

    Oculus app version 1.22.0.520720 (122.0.5.520733) is reported at the bottom of the Settings page in Oculus Client, and I kept the Nvidia 390.65 drivers in place (NB to keep 'Win 10 Update' happy, as it keeps asking to upgrade them, and I'd rather keep Win Update fully on for other updating/security reasons). Still the stutters persist, but again, perceptibly better. I rebooted and came back to the option "Use Classic Oculus Home (May be available for a limited time)" setting; I switched this on, and entered Rift. Stutters were almost gone, almost nothing, 1 every ten seconds. What!? Robo Recall, ah, still some stuttering, but not as bad.

    3. Then, why, I cannot tell you, I decided to remove (i.e. stop) Unknown Sources and Automatic app updates, these options are under the Settings -> General tab in Classic Oculus Home. I put back on the Rift, no stuttering. None. Wow. I started Robo. In the menu system of Robo, no stuttering. None. Entered a mission, Mission 1. Just a couple of stutters if I turned to look to the rear (I have a two sensor setup) at the beginning of the session, then, none. I completed the mission, no stutters, all graphics maxed out as they were when I first bought the Dell R3 13, and all had been perfect the first week.
    Oculus Home with Classic on, 1.22 / Nvidia 390.65, on proven hardware.
    More tests tonight. It is nowhere close to a solution for probably more than anyone but me (Dell R3 13 OLED), and likely everything may break in the next session, but, that's my story so far.
    Alienware R3 13 OLED notebook | GTX 1060 6 GB (Intel 630 HD igfx) | Core i7-7700HQ | 512 | 16 GB RAM
    Rift worked perfectly (no stutters) until early Dec 2017, then stuttered until May 2018 (gave up using it). Since May '18, what worked = use DDU to force remove all Nvidia GPU drivers, reinstall all Dell official ones, followed by (to present) 411.70. On Oculus Home 1.33. All works fine.
  • JJcourageJJcourage Posts: 23
    Brain Burst
    OK - follow up tests to the post above: I have to write this complexity up asap; it is freakin' bizarre.
    I rebooted, and entered Classic Oculus Home 1.22 immediately (still on 390.65 Nvidia latest). No stutters in the main Home pages. Great. That's a good start. Entered into the Edit Avatar pages (never bothered before) - again, no stutters. Started Robo Recall, no stutters in the menu/office area. Picked Mission 1 again (now, in hindsight - please note, it was Daytime (not Night-time) for this Mission - the default is Random at the Mission start page) - no stutters! Yes! Enjoyed for a minute this revelation after 2 months of unplayability.
    So, to Tomb Raider... I had to accept Unknown Sources to allow Steam VR... ah... now the stutters begin, everywhere... even in Oculus Home Classic... as expected, Tomb Raider starts... to complete stutters, the worst I've experienced. Quit.
    Reboot, start to Oculus (no Steam VR, I uncheck allow Unknown sources), no stutters, Robo Recall... but this time it Random starts in Night-time (Mission 1) and I have what I would call 'medium' stuttering - rubbish. I try again, realising it was not  "Day time" in the game... and it starts in Day time - no stutters! So I repeat, and then I realise I can force the Mission 1 start page to not be Random, but either Day time (no stutters) or Night time (stutters). Now, on one occasion, the Day time starts with stutters. I pause the game, and restart the level. No stutters. Wow, fascinating... I try this on Night time - no dice; even on a "restart level" command, this always has stuttering.
    Before I gave up tonight - I tried Robo Recall with the Steam window (not VR, just the Steam client window) just being open (Big Screen or Steam Home, didn't matter), behind the Oculus Classic Home window (on top), and... then going into the Rift just via Oculus Home Client... ok, ok... there's slight stuttering even in Oculus Home (looking up at my Avatar, you can see the slight stutters sometimes). And Robo Recall _always_ has stuttering in game, doing anything at all... but not in the menus or office (?). Wow. So, there is some kind of deeply embedded code, related to some kind of highly demanding API graphics call (reflections? e.g. night time Robo, or Steam just being open, but clearly when in Tomb Raider's VR level), that once triggered, doesn't clear, and causes micro-stuttering, until a reboot.
    That's all I can manage folks - the logic is too complex; but basically all the best parts are broken for me. It's all going back in the box for a while. The way it is. YMMV!
    Alienware R3 13 OLED notebook | GTX 1060 6 GB (Intel 630 HD igfx) | Core i7-7700HQ | 512 | 16 GB RAM
    Rift worked perfectly (no stutters) until early Dec 2017, then stuttered until May 2018 (gave up using it). Since May '18, what worked = use DDU to force remove all Nvidia GPU drivers, reinstall all Dell official ones, followed by (to present) 411.70. On Oculus Home 1.33. All works fine.
  • RedLeader42RedLeader42 Posts: 44
    NerveGear
    edited January 2018
    JJcourage, one thing I can confirm 100% at this point is that much of the stuttering I am seeing in games is associated with other application windows being open on the computer screen. The Oculus Client software is the worst offender I've found, but they can even be open "behind" the game window, whether the game is full screen or not, and still have a huge negative affect on in-game fps.

    Example: I start up Star Trek Bridge Crew and notice lots of stuttering and poor fps just sitting at the main menu, which usually doesn't happen. I go to the computer and make sure all other applications are minimized - immediately have great results and solid 90 fps performance. 

    I believe a lot of my "mixed" testing results is due to sometimes having other application windows open and not realizing it. My understanding is "whatever is on the computer screen shouldn't have an affect on game performance" but that is NOT proving correct in my case.

    I'm going to go try disabling unknown sources and see if I see a correlation.

    [EDIT]

    I tested switching to Home Classic and disabling unknown Sources, neither seemed to have a direct affect. I confirmed that having the app open "behind" the game window still affected performance and caused lower fps and stuttering, despite classic home being enabled.
    MSI GE63VR-7RF Raider | GTX 1070 8 GB | Core i7-7700HQ 2.80 - 3.80 GHz | 32 GB RAM
  • LZoltowskiLZoltowski Posts: 6,720 Volunteer Moderator
    JJcourage, one thing I can confirm 100% at this point is that much of the stuttering I am seeing in games is associated with other application windows being open on the computer screen. The Oculus Client software is the worst offender I've found, but they can even be open "behind" the game window, whether the game is full screen or not, and still have a huge negative affect on in-game fps.

    Example: I start up Star Trek Bridge Crew and notice lots of stuttering and poor fps just sitting at the main menu, which usually doesn't happen. I go to the computer and make sure all other applications are minimized - immediately have great results and solid 90 fps performance. 

    I believe a lot of my "mixed" testing results is due to sometimes having other application windows open and not realizing it. My understanding is "whatever is on the computer screen shouldn't have an affect on game performance" but that is NOT proving correct in my case.

    I'm going to go try disabling unknown sources and see if I see a correlation.
    Hey do your setting match these? (obviously, your monitor can be different res)




    Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
    ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

    Be kind to one another :)
  • LZoltowskiLZoltowski Posts: 6,720 Volunteer Moderator
    Also, two quick questions is Your XBOX DVR feature on, AND how are you installing Nvidia drivers? By just installing over them or actually doing a complete removal using DDU? https://www.wagnardsoft.com/
    Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
    ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

    Be kind to one another :)
  • RedLeader42RedLeader42 Posts: 44
    NerveGear
    edited January 2018
    LZoltowski, maybe this is something? I don't have the Display, Mobile, or Video options available in my GeForce control panel. It seems at some point the rift being detected as a second "monitor" was removed (maybe with the manual uninstall and reinstall support asked me to do?) and now neither Windows nor the control panel are detecting it. I only have a "Built-in Display" now. The system has an Intel HD 630 display adapter and I've confirmed those drivers are up to date, so I do see a "maintain aspect ratio" option under the Intel control panel, which I selected, but it made no noticeable difference in performance. If I need to have the Rift detected as a second monitor I'm not sure how to go about that.

    To answer your other question, every single time I switch drivers am rebooting into Safe Mode, running DDU, rebooting, and reinstalling the GeForce drivers.

    [EDIT] 
    Oh and I don't have Xbox anything installed on this system, so no to that. 
    MSI GE63VR-7RF Raider | GTX 1070 8 GB | Core i7-7700HQ 2.80 - 3.80 GHz | 32 GB RAM
  • LZoltowskiLZoltowski Posts: 6,720 Volunteer Moderator
    LZoltowski, maybe this is something? I don't have the Display, Mobile, or Video options available in my GeForce control panel. It seems at some point the rift being detected as a second "monitor" was removed (maybe with the manual uninstall and reinstall support asked me to do?) and now neither Windows nor the control panel are detecting it. I only have a "Built-in Display" now. The system has an Intel HD 630 display adapter and I've confirmed those drivers are up to date, so I do see a "maintain aspect ratio" option under the Intel control panel, which I selected, but it made no noticeable difference in performance. If I need to have the Rift detected as a second monitor I'm not sure how to go about that.

    To answer your other question, every single time I switch drivers am rebooting into Safe Mode, running DDU, rebooting, and reinstalling the GeForce drivers.

    [EDIT] 
    Oh and I don't have Xbox anything installed on this system, so no to that. 
    In windows 10 search bar, type in settings, when the window pops up, select gaming, click on game bar .. and disable the first option. In Game DVR, make sure its set to off too.


    Can you send me the screenshot of your Nvidia Panel like above? While your Rift is plugged in via HDMI .. and actually use the latest 390 drivers this time (I know but work with me here lol) ..



    Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
    ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

    Be kind to one another :)
  • RedLeader42RedLeader42 Posts: 44
    NerveGear
    In windows 10 search bar, type in settings, when the window pops up, select gaming, click on game bar .. and disable the first option. In Game DVR, make sure its set to off too.

    GOT IT. Okay, I did find that and disable those settings.

    Can you send me the screenshot of your Nvidia Panel like above? While your Rift is plugged in via HDMI .. and actually use the latest 390 drivers this time (I know but work with me here lol) ..
    I can and will do that, but first for something different. I started thinking about the Intel adapter and my HDMI connection and noticed I have a mini-display port as well. (New laptop as of a few weeks ago bought just for VR; I haven't explored it much.) Because why not at this point, I hooked up a external monitor and found out this port is also on the GTX 1070! So I made this my primary monitor and disabled my laptop monitor completely. I can clearly see in Windows Task Manager that now every process is now forced to use GPU 1 (the GTX 1070) and I've effectively bypassed the onboard Intel. Previously, system processes like Desktop Window Manager and the like were using GPU 0, the Intel HD 630. 

    Any guesses on Robo Recall performance?? BETTER THAN ANYTHING YET! Smoking fast, smooth, almost no hiccups except once in a while drops to about 87 fps, and my performance headroom is improved yet still close to the floor.

    I'm gonna go out on a limb and say some software isn't optimized to use the differing GPUs properly or at least separate them so one isn't holding the other back. I'll grab some screen shots of these different configurations I've just discovered. Will also try the 390 driver now that I feel like I've got a handle on the root cause.
    MSI GE63VR-7RF Raider | GTX 1070 8 GB | Core i7-7700HQ 2.80 - 3.80 GHz | 32 GB RAM
  • LZoltowskiLZoltowski Posts: 6,720 Volunteer Moderator
    edited January 2018
    Excellent news! That pesky Intel!

    I think I read like a bazillion articles trying to help you solve this.
    Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
    ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

    Be kind to one another :)
  • RedLeader42RedLeader42 Posts: 44
    NerveGear
    Okay here's the report: Updated to 390.65 drivers and so far as I can tell they're still smoking fast. The Rift as a second monitor did not re-appear and is still AWOL. As long as I run everything on the GTX 1070 outputs the experience is as excellent as one would expect regardless of what apps are running on the desktop or behind the game window. Here are some screen shots:
    Legend
    • GPU 0 = Intel HD 630
    • GPU 1 = NVIDIA GTX 1070 (notebook)
    • (Please ignore util %, as I was not in game)
    Process running while using laptop display


    GeForce Control panel while running on laptop display



    Processes while running on external monitor, laptop display disabled


    GeForce Control Panel while running on external monitor
    Note there is no NVIDIA display for the Rift.


    I am going to report back to support on my comments here and see what they think about the fact if I use a monitor that utilizes the on-board Intel that the Oculus Rift performance goes to #*&$^.
    MSI GE63VR-7RF Raider | GTX 1070 8 GB | Core i7-7700HQ 2.80 - 3.80 GHz | 32 GB RAM
  • LZoltowskiLZoltowski Posts: 6,720 Volunteer Moderator
    So it boils down not to drivers .. but the Intel / Nvidia chipset implementation .. something Oculus and Nvidia needs to keep in mind in a future build. Perhaps disabling Intel chipset when the HMD is being put on and only going via Nvidia at this point ...  man what journey!.
    Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
    ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

    Be kind to one another :)
  • JJcourageJJcourage Posts: 23
    Brain Burst
    edited January 2018
    Wow! This surely is music to my ears (or VR smoothness for the eyes, ha! :D ). Thank you (all) here. It makes a lot of sense. Sorry I can't test today as I don't think I have a mini-DP->HDMI adaptor, but ordering one, if I can't find one in my "serpentine bin of cabling".
    1. I also have just that one '3D settings' tab in the Nvidia Control panel (and never seen any other tabs, so never knew they could exist).
    2. I have always plugged my Rift's HDMI into the rear HDMI port on the Alienware R3 13 laptop (and, as said, doing this on the laptop's original installation (385.14 drivers) this did work buttery smooth, for the one week early last Dec.).
    Next to that port, there is a mini-DP female out which I will now give a try to.
    3. FWIW, I've always used DDU between Nvidia driver installs (and I've done so many I've lost count :/ ).

    LZoltowski, your latest post is most likely the best summary. In a quick reply to that - if true, it is even more crazy that when you are in the Nvidia control panel 3D settings (the only tab I have, like Rleader42, as said), and you are forcing all the relevant programs to use _just_ the GTX 1060, that it wouldn't completely cut out the Intel HD 630. Yes, really hope Nvidia can liaise with Oculus and pinpoint the problem.

    My experience of 385.14 (Dell A09 version) -> 388.xx+ bringing into play the stutters i.e. is this introducing some funny code (if that's the case), again, it is maddening that post-DDU cleaning, when even reinstalling those 385.14 drivers, hasn't solved the stutters. (Is there some Intel HD 630 <-> GTX 1060 GPU driver code that _isn't_ removed by DDU?).

    Indeed, this is a journey - I'll get back to this thread and let you know how I get on (but it may be some days, but I will report). Thanks again - right now there is hope.

    EDIT:
    a) In my Settings -> Gaming. I had Record clips/Game Bar set to ON. This I have now turned off. I'll try the effects of this first. I'd never even been into this setting, ever. I have also switched OFF everything that was in any way set to on, in all the tabs available in the Settings -> Gaming section. This was various audio options, and so on.
    b) Sorry... I am a little confused at this stage, as I don't want to lose the use of the Laptop's panel and portability, i.e.  start to carry around an external display monitor - this would totally remove the point for me and using the Rift for demonstration purposes (to others) while keeping it all portable (in one large backpack).
    Mmm. Just for testing purposes, how can I even disable the onboard OLED panel? And then enable it again, without possible serious confusion arising (if I didn't have any external monitor to spare). The R3 13's F7 I/D GFX button is disabled by Dell (the message pops up "Not supported with OLED LCD panel" when you attempt to use F7 - heck, even that message is total rubbish; OLED LCD panel is nonsense of course).
    As I thought initially, can the Rift headset now get plugged into the mini-DP port, instead of the HDMI? And would that change anything at all. Can the OLED panel be driven by the GTX 1060 alone? etc. It still sounds like I'm heading towards a world of pain at the mo.
    Alienware R3 13 OLED notebook | GTX 1060 6 GB (Intel 630 HD igfx) | Core i7-7700HQ | 512 | 16 GB RAM
    Rift worked perfectly (no stutters) until early Dec 2017, then stuttered until May 2018 (gave up using it). Since May '18, what worked = use DDU to force remove all Nvidia GPU drivers, reinstall all Dell official ones, followed by (to present) 411.70. On Oculus Home 1.33. All works fine.
  • RedLeader42RedLeader42 Posts: 44
    NerveGear
    I just learned something else. While swapping out external monitors the Rift popped back in as a second monitor in Windows. I didn't do any testing with that because then the external monitor couldn't be detected. :disappointed:
    It's probably a hardware limitation that the HDMI and mini displayport can't be detected at the same time - only one can used by Windows. I had to:
    1. Disconnect both the Rift HDMI and mini displayport
    2. Connect the external monitor via mini displayport so it was detected in Windows and turned on
    3. Reconnect the Rift HDMI
    4. Restart Oculus Services from the Oculus Client Beta menu
    Everything came back up and ran excellently again, but Oculus is not a third monitor detected by Windows. I'm completely fine with that so long as I get this kind of performance.
    MSI GE63VR-7RF Raider | GTX 1070 8 GB | Core i7-7700HQ 2.80 - 3.80 GHz | 32 GB RAM
  • RedLeader42RedLeader42 Posts: 44
    NerveGear
    edited January 2018
    JJcourage said:
    b) Sorry... I am a little confused at this stage, as I don't want to lose the use of the Laptop's panel and portability, i.e.  start to carry around an external display monitor - this would totally remove the point for me and using the Rift for demonstration purposes (to others) while keeping it all portable (in one large backpack).
    Mmm. Just for testing purposes, how can I even disable the onboard OLED panel? And then enable it again, without possible serious confusion arising (if I didn't have any external monitor to spare). The R3 13's F7 I/D GFX button is disabled by Dell (the message pops up "Not supported with OLED LCD panel" when you attempt to use F7 - heck, even that message is total rubbish; OLED LCD panel is nonsense of course).
    As I thought initially, can the Rift headset now get plugged into the mini-DP port, instead of the HDMI? And would that change anything at all. Can the OLED panel be driven by the GTX 1060 alone? etc. It still sounds like I'm heading towards a world of pain at the mo.
    JJcourage, I only needed to disable the laptop screen in Windows 10. You can do this by searching for Change Display Settings, then under Multiple Displays choose Show only on 2 (assuming 2 is your external monitor and you laptop is 1; you can use Identify at the top of this dialog to identify them.)


    As soon as you disconnect the external monitor your laptop screen will pop back on, so you could then take it and play it anywhere - but I can't speak to the game performance you'll get. My laptop is so far dedicated to the Rift, so it would be interesting to hear how your mobile gaming performs.

    In regard to plugging the Rift into the mini displayport - probobly not, but it would be an interesting experiment. My guess is the HDMI is still best suited to VR. The problem I've apparently discovered has more to do with Intel / NVIDIA not playing together nicely. Complete speculation on my part, but it could be because a recent Intel driver now supports the Windows Mixed Reality headset.
    MSI GE63VR-7RF Raider | GTX 1070 8 GB | Core i7-7700HQ 2.80 - 3.80 GHz | 32 GB RAM
  • JJcourageJJcourage Posts: 23
    Brain Burst
    “FIXED”! Or, rather, a workaround! I can confirm the above works for me too. GREAT! First time in 2 months all OK no stutters, and first time Tomb Raider is perfect. All looks good in first 10 min of tests.
     :) 
    RedLeader42, Thanks a lot for the above 2 posts, made life easy. I followed all, and they are a match for me.
    I found a mini-Display Port to full-size Display Port dongle in my ‘collection’ of adapters and connected to an external monitor, “disabling the OLED laptop panel/Intel igfx” was the fix.
    I’m calling it a workaround as clearly I don’t want to carry around a monitor to get flawless Rift performance. Hopefully Nvidia will spot this with Oculus - I will report this to them.
    Thanks to all here! Time for a beer...
    Alienware R3 13 OLED notebook | GTX 1060 6 GB (Intel 630 HD igfx) | Core i7-7700HQ | 512 | 16 GB RAM
    Rift worked perfectly (no stutters) until early Dec 2017, then stuttered until May 2018 (gave up using it). Since May '18, what worked = use DDU to force remove all Nvidia GPU drivers, reinstall all Dell official ones, followed by (to present) 411.70. On Oculus Home 1.33. All works fine.
  • RedLeader42RedLeader42 Posts: 44
    NerveGear
    JJcourage, woohoo! Glad to hear it worked! If this is a problem for many people, hopefully they find this and start reporting it as well. Hopefully we'll see this fixed in the near future.
    MSI GE63VR-7RF Raider | GTX 1070 8 GB | Core i7-7700HQ 2.80 - 3.80 GHz | 32 GB RAM
  • JJcourageJJcourage Posts: 23
    Brain Burst
    RedLeader42, B)

    Confirming: Tomb Raider, maxed out graphics settings, also Robo Recall, max settings, GTX 1060, it’s all smooth as a peach! There are just 1 or 2 momentary stutters on entering the gameplay, but these I feel are ‘standard’ as the Rift is handshaking with the GTX hardware [somehow the onboard Intel HD 630 must keep interrupting this handshake when some form of Advanced Graphics (e.g. reflections(?)) is being requested. Who knows.]

    I have seen on other internet searches that there are reports of people “fixing stutters” using a DP dongle, who have the older GTX 970 cards, but given what I had assumed, like you, that we have a relative “lack of ports” on a laptop, I hadn’t made the connection that the miniDP port we have would be a GTX-only output “fix” - why would we?

    Yes, hope Nvidia <-> Oculus can get together and figure out what is causing this onboard (CPU) igfx <-> GTX mismatch. I can’t do any more tests for a day or so, but I’ll drop another comment here if some other bizarre glitches appear.

    Now I am going to buy a miniDP to DP cable which is thin at the plugging-in point, and probably a miniDP to HDMI cable as well (the wedge-like miniDP->DP dongle I have found is putting too much off centre vertical pressure on its port as it is too thick for the R3’s chassis, typical, so I am propping up the back of the laptop with a small book at the moment, oops) so at least I can use the Rift until a driver update, and not forced to have an external monitor hooked up to get smooth performance.
    Alienware R3 13 OLED notebook | GTX 1060 6 GB (Intel 630 HD igfx) | Core i7-7700HQ | 512 | 16 GB RAM
    Rift worked perfectly (no stutters) until early Dec 2017, then stuttered until May 2018 (gave up using it). Since May '18, what worked = use DDU to force remove all Nvidia GPU drivers, reinstall all Dell official ones, followed by (to present) 411.70. On Oculus Home 1.33. All works fine.
  • RedLeader42RedLeader42 Posts: 44
    NerveGear
    That made me think to mention that I am this mini displayport to DVI dongle, but I would think any converter should work as they are all passive converters.
    MSI GE63VR-7RF Raider | GTX 1070 8 GB | Core i7-7700HQ 2.80 - 3.80 GHz | 32 GB RAM
  • LZoltowskiLZoltowski Posts: 6,720 Volunteer Moderator
    JJcourage said:
    RedLeader42, B)

    Confirming: Tomb Raider, maxed out graphics settings, also Robo Recall, max settings, GTX 1060, it’s all smooth as a peach! There are just 1 or 2 momentary stutters on entering the gameplay, but these I feel are ‘standard’ as the Rift is handshaking with the GTX hardware [somehow the onboard Intel HD 630 must keep interrupting this handshake when some form of Advanced Graphics (e.g. reflections(?)) is being requested. Who knows.]

    I have seen on other internet searches that there are reports of people “fixing stutters” using a DP dongle, who have the older GTX 970 cards, but given what I had assumed, like you, that we have a relative “lack of ports” on a laptop, I hadn’t made the connection that the miniDP port we have would be a GTX-only output “fix” - why would we?

    Yes, hope Nvidia <-> Oculus can get together and figure out what is causing this onboard (CPU) igfx <-> GTX mismatch. I can’t do any more tests for a day or so, but I’ll drop another comment here if some other bizarre glitches appear.

    Now I am going to buy a miniDP to DP cable which is thin at the plugging-in point, and probably a miniDP to HDMI cable as well (the wedge-like miniDP->DP dongle I have found is putting too much off centre vertical pressure on its port as it is too thick for the R3’s chassis, typical, so I am propping up the back of the laptop with a small book at the moment, oops) so at least I can use the Rift until a driver update, and not forced to have an external monitor hooked up to get smooth performance.
    A small stutter/glitch at the start of the game happens all the time, that's because the game is loading assets into memory and taxing the system, it's completely natural.
    Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
    ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

    Be kind to one another :)
  • RedLeader42RedLeader42 Posts: 44
    NerveGear
    edited January 2018
    Not amazing response from support. I asked them if they could reproduce it and if it was something that could be researched. Their answer, paraphrasing:
    Your laptop model is not certified as oculus ready. You're probably doing the right thing bypassing the Intel. We appreciate your thorough testing.

    Wow. :'(
    MSI GE63VR-7RF Raider | GTX 1070 8 GB | Core i7-7700HQ 2.80 - 3.80 GHz | 32 GB RAM
  • Sharkster-NVRSharkster-NVR Posts: 74
    Hiro Protagonist
    edited January 2018
    Is that just a standard reply or is your notebook in fact not "Oculus ready", when you run the testing stuff? Your hardware sounds well capable of handling the job (and beyond)?

    However, if there's one thing we found out in this thread, it's all of us running the Rift on high-end gaming notebooks with hybrid GPUs (Intel and Nvidia). Is that correct? Because if so, that's definitely a step forward!

    As for the machines in our company, we got rid of the micro stutters by rolling back to 384.94. I just want to write down the exact process, so you can reproduce it, if you want to try.

    A - Remove NVidia GPU display driver via device manager.

    B - Uninstall all unnecessary NVIDA stuff (Geforce Experience, 3D Vision, Audio bla bla...)

    C - Set Windows game bar, Windows DVR etc. stuff to DISABLED

    D - Clean everything up with DDU (uninstall remaining driver and Geforce Experience elements)

    E - Restart Windows - Your machine should be 100% Nvidia free now.

    F - Download 384.94 driver package from here:
    http://www.nvidia.com/Download/Find.aspx?lang=en-uk

    G - Extract the directory "Disply.Driver" from the WHQL using e.g. Bandizip and copy it to your desktop

    H - Install the driver from that directory via Windows device manager as the "new" driver for your Nvidia GPU (Ignore all the other NVida services, extra apps and bla).

    I - Reboot machine

    J - You should now have a super clean 384.94 driver installed for your Nvidia GPU. Fire up Oculus services, set it to Home Classic and launch the game of your choice. Microstuttering are now gone (at least on our machines).


    Note: When launching SteamVR, the micro stuttering is still persistent, even with 394.94. So, for testing purposes, you may also want to uninstall SteamVR when getting rid of all the NVidia stuff in step B.
    ERAZER X7849 Notebook - CPU: Intel Core i7 6820HK - GPU: GTX 1070, 8 GB GDDR5 RAM - RAM: 32 GB (4x 8 GB DDR4 HYNIX PC4 17000 DUAL CHANNEL) - MAINBOARD: INTEL HM170
  • LZoltowskiLZoltowski Posts: 6,720 Volunteer Moderator
    Not amazing response from support. I asked them if they could reproduce it and if it was something that could be researched. Their answer, paraphrasing:
    Your laptop model is not certified as oculus ready. You're probably doing the right thing bypassing the Intel. We appreciate your thorough testing.

    Wow. :'(
    That's annoying. Hey .. is there no way to disable the intel graphics all together in bios?
    Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
    ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

    Be kind to one another :)
  • RedLeader42RedLeader42 Posts: 44
    NerveGear
    Is that just a standard reply or is your notebook in fact not "Oculus ready", when you run the testing stuff? Your hardware sounds well capable of handling the job (and beyond)?
    Performance-wise the laptop is very Oculus ready, and it passes oculus and steam performance tests with flying colors. They are saying my system isn't on this list as "certified." 

    Sharkster-NVR said:
    However, if there's one thing we found out in this thread, it's all of us running the Rift on high-end gaming notebooks with hybrid GPUs (Intel and Nvidia). Is that correct? Because if so, that's definitely a step forward!

    If that ends up being the case, definitely a step forward. I didn't own my Rift or laptop before Jan 2018, but it appears there is a group of folks who saw the Rift take a performance nosedive in the Nov - Dec 2017 time frame. If the hybrid Intel / NVIDIA is the underlying cause, it would take those folks reporting this to support, and pushing the issue that this is not an unfixable hardware compatibility problem. Now that I've seen how the Rift can perform over the past couple of days, I am not certain it ever ran this well. Memory is fickle.

    A bit of background
    I bought this system after playing a friends Rift. Played it like 20 minutes and went, "Yeah, well, I have to own one of these." :smile: He owns an MSI laptop just a bit older than mine with an Intel / GTX 1060 hybrid, and runs the 382.05 drivers. It seems I can't run the 382.05 drivers, because the installer says it can't detect a compatible system. I can only install as far back as 384.x. On his MSI laptop with 382.x and a GTX 1060, Robo Recall ran near flawlessly at 90 fps. He's been a help to me working through this and we've communicated back and forth about this. So far it appears he doesn't have the problem I do, but he's not run all the software updates that I have. I'm encouraging him to try an external monitor like I have and see if it improves further. It would be interesting to hear from more folks, but JJCourage
    on this thread confirmed that using an external monitor is a very effective workaround.

    Sharkster-NVR said:
    Note: When launching SteamVR, the micro stuttering is still persistent, even with 394.94. So, for testing purposes, you may also want to uninstall SteamVR when getting rid of all the NVidia stuff in step B.

    In my situation I can't describe anything I've seen as "micro-stuttering" it was either "wow-this-is-horrid" or "wow-this-is-nearly-flawless" (angles playing trumpets). I do still have a hiccup now and then, like the first time I pull apart a Robot and it explodes in parts and sparks, but I attribute this to natural loading of resources or whatnot, like LZoltowski suggested above, as it doesn't happen every time. I have tried drivers from 384.x to 390.x and can't discern a difference I could point a finger at. Oculus Client and Steam VR both played equal well or equally bad so far as I could discern.

    MSI GE63VR-7RF Raider | GTX 1070 8 GB | Core i7-7700HQ 2.80 - 3.80 GHz | 32 GB RAM
  • RedLeader42RedLeader42 Posts: 44
    NerveGear
    That's annoying. Hey .. is there no way to disable the intel graphics all together in bios?

    Thats an interesting idea I’ll have to experiment with. That would also be better for JJCorage than hauling around a monitor. :smile: My wife’s not a huge fan of the monitor I have sitting on our living room coffee table right now, so better for me too! :D

    MSI GE63VR-7RF Raider | GTX 1070 8 GB | Core i7-7700HQ 2.80 - 3.80 GHz | 32 GB RAM
  • Sharkster-NVRSharkster-NVR Posts: 74
    Hiro Protagonist
    In my BIOS there is a "MSHybrid" or "DISCRETE" toggle. I believe that allows to switch off the hybrid GPU stuff altogether, but I haven't played around with it yet.
    ERAZER X7849 Notebook - CPU: Intel Core i7 6820HK - GPU: GTX 1070, 8 GB GDDR5 RAM - RAM: 32 GB (4x 8 GB DDR4 HYNIX PC4 17000 DUAL CHANNEL) - MAINBOARD: INTEL HM170
  • Sharkster-NVRSharkster-NVR Posts: 74
    Hiro Protagonist
    edited January 2018
    Not amazing response from support. I asked them if they could reproduce it and if it was something that could be researched. Their answer, paraphrasing:
    Your laptop model is not certified as oculus ready. You're probably doing the right thing bypassing the Intel. We appreciate your thorough testing.



    To my understanding, there's no such thing as an "Oculus Ready Certificate". I guess they simply believe that your notebook didn't pass the "Ready for Rift" compatibility test:
    https://www.roadtovr.com/oculus-rift-compatibility-check-tool-checks-pc-ready-rift/

    ...which is obviously plain wrong. To me it sounds like: "Hey, your hardware doesn't work with Oculus! But that's not our fault!" - which is BS of course, because the question of who's to blame is not as interesting as the solution to the problem. I mean... what is "not certified as Oculus ready" even supposed to mean... or how is it supposed to help?

    Statements like that from support staff always make me kinda angry, as they're just so NOT helpful. Instead of digging the depths of the internet for weeks to get our (which is in fact THEIR!) VR hardware to work, we should just return it, take a refund. Buy a Vive... and say: "K, maybe it's HTC ready certified shiznit?".

    :/
    ERAZER X7849 Notebook - CPU: Intel Core i7 6820HK - GPU: GTX 1070, 8 GB GDDR5 RAM - RAM: 32 GB (4x 8 GB DDR4 HYNIX PC4 17000 DUAL CHANNEL) - MAINBOARD: INTEL HM170
  • nalex66nalex66 Posts: 4,365 Valuable Player
    To my understanding, there's no such thing as an "Oculus Ready Certificate". I guess they simply believe that your notebook didn't pass the "Ready for Rift" compatibility test ... which is obviously plain wrong. To me it sounds like: "Hey, your hardware doesn't work with Oculus! But that's not our fault!" - which is BS of course, because the question of who's to blame is not as interesting as the solution to the problem. I mean... what is "not certified as Oculus ready" even supposed to mean... or how is it supposed to help?

    Statements like that from support staff always make me kinda angry, as they're just so NOT helpful. Instead of digging the depths of the internet for weeks to get our (which is in fact THEIR!) VR hardware to work, we should just return it, take a refund. Buy a Vive... and say: "K, maybe it's HTC ready certified shiznit?".
    The "Oculus-Ready" list linked above is simply a list of systems that have been tested by Oculus and confirmed to work. By saying that the system is not on the list, they're not saying that it definitely won't work, just that they don't know whether it will work, or what hoops you might have to jump through to get there.

    Laptops are generally problematic for VR, due to the issues you guys are experiencing, which are outside of Oculus's control. The hardware problems are in how the laptops are wired up, not in the VR hardware. Oculus has provided a list of laptops that are known to work. Beyond that, you're free to try, but you're somewhat on your own--you might find a way to make it work, or you might be SOL.
    i7 5820K @ 4.25 GHz | EVGA GTX 1080 SC | Gigabyte GA-X99-UD4 | Corsair DDR4 3000 32 GB | Corsair HX 750W
    Corsair Hydro H100i | Samsung SSDs: 860 Evo 1 TB, 850 Evo 1 TB, 840 Evo 1 TB | Seagate BarraCuda HDD 3 TB
  • LZoltowskiLZoltowski Posts: 6,720 Volunteer Moderator
    I would Highly recommend disabling HYBRID in bios and going with DISCRETE all together, this will bypass the intel chipset and might solve the issue you are having. I have seen tonnes of reports that this fixes a lot of switching issues for people where games and applications forget to use discreet or Intel butts in and messes things up.

    This will affect battery life tho.
    Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
    ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

    Be kind to one another :)
  • Sharkster-NVRSharkster-NVR Posts: 74
    Hiro Protagonist
    edited January 2018
    @nalex66 - What's the point of releasing a "Is my hardware ready for Oculus"-tool then? Oculus released that tool, so you can self-check if your system works or not. That's it. If the answer is: "Who knows?", then there's no need for that tool. 

    I'm well aware that there's probably not one single culprit, but a combination of complex issues. We're developers ourselves and had to deal with the whackiness of gaming notebooks and especially NVidia's poor implementation of their so called "Optimus" before.

    However, we HAVE TO use notebooks, as we develop and sell semi-mobile out-of-the-box VR systems (software & hardware). Our only concern is to get the expensive base hardware to work... which sometimes can get frustrating. And we hope that NVidia AND Oculus will finally come up with a ready-to-use solution that doesn't require us to fiddle around with their stuff for ages, as we don't get paid for that (i.e. it steals time from our actual development work).

    Anyway, let's not be focused on who's to blame, but on how to solve this. We already have a running interims solution with the July released NVidia drivers, but we'll test out the MShybrid vs. Discreete BIOS modes later today. We will report back, when we have some news.
    ERAZER X7849 Notebook - CPU: Intel Core i7 6820HK - GPU: GTX 1070, 8 GB GDDR5 RAM - RAM: 32 GB (4x 8 GB DDR4 HYNIX PC4 17000 DUAL CHANNEL) - MAINBOARD: INTEL HM170
  • nalex66nalex66 Posts: 4,365 Valuable Player
    @nalex66 - What's the point of releasing a "Is my hardware ready for Oculus"-tool then? Oculus released that tool, so you can self-check if your system works or not. That's it. If the answer is: "Who knows?", then there's no need for that tool.
    The tool is primarily meant for desktop systems, where these issues don't present themselves. It can only look at the specs of the hardware components and say, "Yes, these components should meet the performance level required for VR".

    Unfortunately, there is no way for the tool to test your GPU/port connection without actually plugging something into the port. This is where the "Oculus Ready" list comes in--they can at least tell you which systems they've tested and confirmed to work. If you must use laptops, your choices are to either choose something from the Oculus-tested list, or go through the troubleshooting you've been doing to find hardware that can work.

    Things have at least gotten a bit better on the laptop front--a couple years ago, most laptops were almost guaranteed not to work. Nvidia has pushed for better connectivity in new machines, and laptop manufacturers have made some progress in producing better VR-ready computers.
    i7 5820K @ 4.25 GHz | EVGA GTX 1080 SC | Gigabyte GA-X99-UD4 | Corsair DDR4 3000 32 GB | Corsair HX 750W
    Corsair Hydro H100i | Samsung SSDs: 860 Evo 1 TB, 850 Evo 1 TB, 840 Evo 1 TB | Seagate BarraCuda HDD 3 TB
Sign In or Register to comment.