New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

[Possible Fix] for HDMI/Sensor issues after PC wakes from Sleep or HMD goes black after idling

LZoltowskiLZoltowski Posts: 6,536 Volunteer Moderator
edited February 2018 in General
I did some digging and Windows 10 Fall Creators Update is causing issues for users of laptop and desktops where USB and HDMI are affected by Sleep Wake.

Turning fast startup to off has fixed an issue for me where the HDMI light would go Orange, or sensor tracking would be unusable and glitchy.

After PC wakes up my Rift would have an orange light and required a reboot to get it to work again, disabling it solved the issue:

Edit: This fix also seems to fix the HMD being unusable after a few hours of not being used.
Edit2: I have pinned this thread for a bit as I have had more reports of this working for others.
Edit3: If you are experiencing instant HMD blackout after taking it off for the first time and the below fix does not work, people have reported that temporarily disabling the Guardian System, for now, fixes the issue.

After disabling it Do not reboot, perform a shutdown, wait a few secs and start up again.

power options

available options

fast startup


Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

Be kind to one another :)
«13

Comments

  • LZoltowskiLZoltowski Posts: 6,536 Volunteer Moderator
    Bumping this up as 4 people confirmed to me this has fixed it for them.
    Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
    ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

    Be kind to one another :)
  • RedRizlaRedRizla Posts: 5,179 Valuable Player
    edited February 2018
    Strange thing is that option was not ticked on my computer, but I don't remember unicking it. Is there a similar thing in the bios that allows you to do a fast startup? 
  • LZoltowskiLZoltowski Posts: 6,536 Volunteer Moderator
    RedRizla said:
    Strange thing is that option was not ticked on my computer, but I don't remember unicking it. Is there a similar thing in the bios that allows that allows you to do a fast startup? 
    It's a very odd feature, so when you shut down (and this thing is on) it's a HYBRID hibernation/sleep mode and not a shutdown.  Windows writes the last state to disk and when you boot up it loads this. It causes a lot of issues for people as I found out there during my research, unrelated to the Rift but I noticed it had the same symptoms, of USB disconnects and HDMI issues.

    It also seems to fix the HDMI/USB timeout over time .. not sure how, but I think it;s to do with device enumeration etc..
    Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
    ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

    Be kind to one another :)
  • RedRizlaRedRizla Posts: 5,179 Valuable Player
    I was having usb disconnects that stopped sometime ago, it now makes me wonder if it's this been unticked that solved the problem, but I just cannot remember ever unticking it.
  • LZoltowskiLZoltowski Posts: 6,536 Volunteer Moderator
    The more people say it fixed a lot of issues for them the more I'm' researching it. This "fix" I found was not related to the Rift at all, but some obscure Microsoft forum with complaints of display and USB issues after the Falls Creators update.
    Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
    ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

    Be kind to one another :)
  • nalex66nalex66 Posts: 4,143 Valuable Player
    edited February 2018
    I’ve been using the latest Nvidia driver (390.77), which has been working fine except for the occasional black screen with audio (restarting the Oculus service always resolves it). I’ve disabled this Fast Startup setting now, so we’ll see if this helps with black screens on the new driver. *Edit: nope still getting the odd black screen with 390.77.

    Funny thing, the BIOS setting for Fast Boot was causing my random shutdowns that I was experiencing last month. Since disabling that, everything has been perfectly stable again. I don’t even notice boot-up taking any longer. 
    i7 5820K @ 4.25 GHz | EVGA GTX 1080 SC | Gigabyte GA-X99-UD4 | Corsair DDR4 3000 32 GB | Corsair HX 750W
    Corsair Hydro H100i | Samsung SSDs: 860 Evo 1 TB, 850 Evo 1 TB, 840 Evo 1 TB | Seagate BarraCuda HDD 3 TB
    My Oculus Medium sketchbook thread, and my Oculus Medium Gallery
  • LZoltowskiLZoltowski Posts: 6,536 Volunteer Moderator
    nalex66 said:
    I’ve been using the latest Nvidia driver (390.77), which has been working fine except for the occasional black screen with audio (restarting the Oculus service always resolves it). I’ve disabled this Fast Startup setting now, so we’ll see if this helps with black screens on the new driver. 

    Funny thing, the BIOS setting for Fast Boot was causing my random shutdowns that I was experiencing last month. Since disabling that, everything has been perfectly stable again. I don’t even notice boot-up taking any longer. 
    Yeah the whole thing is glitchy. This Fast Start thing was also causing my HMD going to sleep after a few hours and not coming back until a reset. It lasted a whole day yesterday without issues.

    Fast Start causes a HYBRID shutdown. So when you turn your PC off, it actually hibernates and then loads windows from that state .. because of that it causes strange bugs with USB and HDMI. Now I have a feeling that Fast Start is hooked up to some sort of power management layer within windows, disabling that, disables the power management bit too which fixes 2 issues at the same time.
    Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
    ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

    Be kind to one another :)
  • Duren_BlakeDuren_Blake Posts: 8
    NerveGear
    Hi there,

    i have the same issue. My HMD goes black and stays black as soon as i take it of.
    I reverted to the older 388.59 NVIDIA Driver and disabled fast boot.
    Unfortunatly both does not seem to help.
    I can not take the HMD off, neither in Home2 nor in any game, the display always stays black.
    Only a full reboot, or a restart of the OVRService brings the display back to life.
    My last idea would be to put a sticker on the sensor whenever i want to play something so i can take of the Device if i need to.

    Oh and for good measure:
    Win10 x64, 16GB
    i7-4790K
    GTX 960
    Asus Z87-Plus

    Maybe interesting to mention:
    When i got the Rift i already had an later version of the NVIDIA Driver installed. No Problems at all.
    The problem appeared when i disconnected my Rift (including the sensors) on the 06.02 and reconnected it 2 days later. The PC got briefly used in the time the Rift was away.
  • LZoltowskiLZoltowski Posts: 6,536 Volunteer Moderator
    edited February 2018
    Hi there,

    i have the same issue. My HMD goes black and stays black as soon as i take it of.
    I reverted to the older 388.59 NVIDIA Driver and disabled fast boot.
    Unfortunatly both does not seem to help.
    I can not take the HMD off, neither in Home2 nor in any game, the display always stays black.
    Only a full reboot, or a restart of the OVRService brings the display back to life.
    My last idea would be to put a sticker on the sensor whenever i want to play something so i can take of the Device if i need to.

    Oh and for good measure:
    Win10 x64, 16GB
    i7-4790K
    GTX 960
    Asus Z87-Plus

    Maybe interesting to mention:
    When i got the Rift i already had an later version of the NVIDIA Driver installed. No Problems at all.
    The problem appeared when i disconnected my Rift (including the sensors) on the 06.02 and reconnected it 2 days later. The PC got briefly used in the time the Rift was away.

     Have you tried disabling Fast Start as mentioned in the original post?
    Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
    ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

    Be kind to one another :)
  • Duren_BlakeDuren_Blake Posts: 8
    NerveGear
    Hi there,

    i have the same issue. My HMD goes black and stays black as soon as i take it of.
    I reverted to the older 388.59 NVIDIA Driver and disabled fast boot.
    Unfortunatly both does not seem to help.
    I can not take the HMD off, neither in Home2 nor in any game, the display always stays black.
    Only a full reboot, or a restart of the OVRService brings the display back to life.
    My last idea would be to put a sticker on the sensor whenever i want to play something so i can take of the Device if i need to.

    Oh and for good measure:
    Win10 x64, 16GB
    i7-4790K
    GTX 960
    Asus Z87-Plus

    Maybe interesting to mention:
    When i got the Rift i already had an later version of the NVIDIA Driver installed. No Problems at all.
    The problem appeared when i disconnected my Rift (including the sensors) on the 06.02 and reconnected it 2 days later. The PC got briefly used in the time the Rift was away.

     Have you tried disabling Fast Start as mentioned in the original post?
    Sorry, with fast boot i actually ment Fast Start :)
    So jeah i disabled it.
  • LZoltowskiLZoltowski Posts: 6,536 Volunteer Moderator
    Hi there,

    i have the same issue. My HMD goes black and stays black as soon as i take it of.
    I reverted to the older 388.59 NVIDIA Driver and disabled fast boot.
    Unfortunatly both does not seem to help.
    I can not take the HMD off, neither in Home2 nor in any game, the display always stays black.
    Only a full reboot, or a restart of the OVRService brings the display back to life.
    My last idea would be to put a sticker on the sensor whenever i want to play something so i can take of the Device if i need to.

    Oh and for good measure:
    Win10 x64, 16GB
    i7-4790K
    GTX 960
    Asus Z87-Plus

    Maybe interesting to mention:
    When i got the Rift i already had an later version of the NVIDIA Driver installed. No Problems at all.
    The problem appeared when i disconnected my Rift (including the sensors) on the 06.02 and reconnected it 2 days later. The PC got briefly used in the time the Rift was away.

     Have you tried disabling Fast Start as mentioned in the original post?
    Sorry, with fast boot i actually ment Fast Start :)
    So jeah i disabled it.
    When you did that, did you Shut the PC down, waited a few secs and turned it back on?, not just a restart? If so you might be experiencing a completely different issue. Can you post your log here so I can have a look?
    Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
    ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

    Be kind to one another :)
  • Duren_BlakeDuren_Blake Posts: 8
    NerveGear
    Jeah i did a shutdown not a reboot as you described.
    There are a couple log files .... i guess you mean Oculus_Dash.log ?
    Or the log files in Local/Oculus called Service_(current date and time).txt?

    Anyway, i attached both :)



  • LZoltowskiLZoltowski Posts: 6,536 Volunteer Moderator
    Collect ALL logs, using the OculusLogGather tool in your Oculus\Support\oculus-diagnostics directory it hsould give you a zip file, if you could attach that.

    In the meantime, have you disabled power management on all of these?








    Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
    ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

    Be kind to one another :)
  • Duren_BlakeDuren_Blake Posts: 8
    NerveGear
    edited February 2018
    Ok, i disabled the Power Management in all USB-Devices and
    disabled USB selective suspend setting in my current Power Plan.

    I did a full shutdown, waited and unfortunatly no change.
    As soon as i take the HMD off, the display stays dark.

    After the test i collected ALL logs with the tool you mentioned, so all changes should be visible in the logs if at all.
    I hope it helps.
  • LZoltowskiLZoltowski Posts: 6,536 Volunteer Moderator
    Thanks, Ill have a look, did you disable Fast Start and Rolled back the driver at the same time?
    Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
    ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

    Be kind to one another :)
  • Duren_BlakeDuren_Blake Posts: 8
    NerveGear
    I rolled back the driver and ticked the "clean install" option.
    I testet without a reboot.
    then i disabled Fast Start and did a shutdown.
    So i testet in between but did no reboot after the rollback of the driver.
  • LZoltowskiLZoltowski Posts: 6,536 Volunteer Moderator
    edited February 2018
    I rolled back the driver and ticked the "clean install" option.
    I testet without a reboot.
    then i disabled Fast Start and did a shutdown.
    So i testet in between but did no reboot after the rollback of the driver.
    I cant see much from the log, not seeing any Headset not connected issues.

    I know this is exhausting, and frustrating im sure! Have you tried using DDU? https://www.wagnardsoft.com/

    Remove your display graphics with that, then install the latest Nvidia Drivers, and run Setup from here again:




    I have seen someone report that disabling the Guardian system is a temporary fix for some also.


    Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
    ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

    Be kind to one another :)
  • Duren_BlakeDuren_Blake Posts: 8
    NerveGear
    This is frustrating yes BUT its much more a pain to not beeing able to take of the Rift.
    Therefore, as long as you have any idea of what i could try i will try it.

    Gonna try the Guardian disable first and then the DDU.
  • Duren_BlakeDuren_Blake Posts: 8
    NerveGear
    OMG it works !
    (at least ot the moment)

    I disabled the Guardian in the VR Menu and currently ..... it works perfectly.
    How peculiar .... why would that of all the possible things to break be the one thing.

    I am curious now.
    I will keep testing, reboot, install the newest driver, reenable Fast Start and do tests in beetwen.
    At the end if all still works, i will reenable the Guardian and i hope/guess it will break it again.

  • LZoltowskiLZoltowski Posts: 6,536 Volunteer Moderator
    OMG it works !
    (at least ot the moment)

    I disabled the Guardian in the VR Menu and currently ..... it works perfectly.
    How peculiar .... why would that of all the possible things to break be the one thing.

    I am curious now.
    I will keep testing, reboot, install the newest driver, reenable Fast Start and do tests in beetwen.
    At the end if all still works, i will reenable the Guardian and i hope/guess it will break it again.

    Yes, it's super strange. Glad it worked and are willing to experiment a bit, at least you have a backup plan if it still doesn't work.
    Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
    ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

    Be kind to one another :)
  • Duren_BlakeDuren_Blake Posts: 8
    NerveGear
    Alright, results are in.

    I don´t know about other systems, but
    Fast Start is ON
    newest NVIDIA Driver is installed
    Guardian is OFF

    and it works like a charm.
    As soon as i try to setup the Guardian, the Rift will go and stay dark.

    The Fast Start issue probably is still a thing on other system tho !

    And i can make a faint guess what might or might not could possibly break the Guardian.
    But first, it did work perfectly fine prior the 06.02 with the sensor setup i will now describe.
    What MIGHT break the Guardian now, is something i got remembered as i tryied to setup the Guardian just now.
    My sensors are not next to my display. Instead they are high up wall mounted, more than 2m apart and at an angle of 90° to each other. Unfortunatly this is the only way for me to get a decent coverage in my room.
    While setting up the sensors for the Guardian i get a reminder that they are to far apart.

    Again, the tracking works perfectly. Also the Guardian worked with this setup prior the 06.02.
    But just maybe, something, i can not put my finger on, changed and my sensor setup now breaks the Guardian.
    Its a wild guess sure but maybe i can test this theory some other day, when i can figure out some positions which might work in my room.

    Anyway, after typing this for a very long time, my idle Rift still turns on !
    So thank you VERY much LZoltowski for all your time and effort to get this fixed !!!
  • LZoltowskiLZoltowski Posts: 6,536 Volunteer Moderator
    Alright, results are in.

    I don´t know about other systems, but
    Fast Start is ON
    newest NVIDIA Driver is installed
    Guardian is OFF

    and it works like a charm.
    As soon as i try to setup the Guardian, the Rift will go and stay dark.

    The Fast Start issue probably is still a thing on other system tho !

    And i can make a faint guess what might or might not could possibly break the Guardian.
    But first, it did work perfectly fine prior the 06.02 with the sensor setup i will now describe.
    What MIGHT break the Guardian now, is something i got remembered as i tryied to setup the Guardian just now.
    My sensors are not next to my display. Instead they are high up wall mounted, more than 2m apart and at an angle of 90° to each other. Unfortunatly this is the only way for me to get a decent coverage in my room.
    While setting up the sensors for the Guardian i get a reminder that they are to far apart.

    Again, the tracking works perfectly. Also the Guardian worked with this setup prior the 06.02.
    But just maybe, something, i can not put my finger on, changed and my sensor setup now breaks the Guardian.
    Its a wild guess sure but maybe i can test this theory some other day, when i can figure out some positions which might work in my room.

    Anyway, after typing this for a very long time, my idle Rift still turns on !
    So thank you VERY much LZoltowski for all your time and effort to get this fixed !!!

     Thanks for checking back in, I added this to the original post as a note for others. It might be an Oculus software bug for certain sensor positions, Guardian cannot properly initialise and fails, as it tries to perform a check when you put the headset back on.
    Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
    ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

    Be kind to one another :)
  • dburnedburne Posts: 1,694 Valuable Player
    Where do you disable Guardian in the Oculus?
    For some reason I can not seem to find it, only where to set it up.
    Running Rift Core on the PTC.
    Don

    EVGA Z390 Dark MB | I9 9900k| EVGA 2080Ti FTW3 Ultra |32 GB G Skill 3200 cl14 ram | Warthog Throttle | VKB Gunfighter Pro/MCG Pro grip | Crosswind Pedals | EVGA DG 87 Case|
  • LZoltowskiLZoltowski Posts: 6,536 Volunteer Moderator
    edited February 2018
    dburne said:
    Where do you disable Guardian in the Oculus?
    For some reason I can not seem to find it, only where to set it up.
    Running Rift Core on the PTC.
    Here you go, go to guardian setup and skip it:



    You can also disable it when you are in VR and in Dash, click on the Settings Icon and I think its the sensors sub menu
    Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
    ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

    Be kind to one another :)
  • dburnedburne Posts: 1,694 Valuable Player
    Ok thanks, my guardian was already set up and I already did the skip thing to get out of it - so maybe it is gone now have not checked yet.
    Will also have a look at the settings menu in Dash. I thought I had already looked in there but will double check.

    Thanks,
    Don

    EVGA Z390 Dark MB | I9 9900k| EVGA 2080Ti FTW3 Ultra |32 GB G Skill 3200 cl14 ram | Warthog Throttle | VKB Gunfighter Pro/MCG Pro grip | Crosswind Pedals | EVGA DG 87 Case|
  • Digikid1Digikid1 Posts: 1,565 Valuable Player
    I have never seen this black screen issue with my Rift or any Rift I have set up for others.  However it may have to do with something that I do when I build a VR Computer for others that has any type of SSD as it's primary drive.

    Open up an admin command prompt in Windows
    type powercfg -h off and press enter
    exit out of command prompt and reboot

    This turns off Hibernation permanently and frees up space on the SSD.

    If you need to turn it back on....just change the off to on.


  • PIXELATEDPIXELATED Posts: 236
    Nexus 6
    Ok, i disabled the Power Management in all USB-Devices and
    disabled USB selective suspend setting in my current Power Plan.

    I did a full shutdown, waited and unfortunatly no change.
    As soon as i take the HMD off, the display stays dark.

    After the test i collected ALL logs with the tool you mentioned, so all changes should be visible in the logs if at all.
    I hope it helps.
    this^
    Manually 'disable power management 'on all usb devices did the trick for me.

    Always power off PC (reset anything you can, ram etc) and start as normal after adjusting USB power management.

    Hopefully new drivers and management either by Oculus or Windoz will sort it out soon without having to resort to earlier Nvidia or ASmedia incarnations (-;
    Win 10 Pro, GTX 1080, Asus Z170 Deluxe, Nvidia 391.35
  • dburnedburne Posts: 1,694 Valuable Player
    There is a known issue with the later Nvidia drivers where the headset does not "release" at times when closing Oculus home after using it. This results in the next time put headset on the screen will remain black in the HMD. Takes a restart of the PC or restart of the Oculus Service to get it back.  It is even listed in the latest Nvidia Driver release notes as known issue.

    There may be different issues being discussed in this thread...

    Don

    EVGA Z390 Dark MB | I9 9900k| EVGA 2080Ti FTW3 Ultra |32 GB G Skill 3200 cl14 ram | Warthog Throttle | VKB Gunfighter Pro/MCG Pro grip | Crosswind Pedals | EVGA DG 87 Case|
  • LZoltowskiLZoltowski Posts: 6,536 Volunteer Moderator
    dburne said:
    There is a known issue with the later Nvidia drivers where the headset does not "release" at times when closing Oculus home after using it. This results in the next time put headset on the screen will remain black in the HMD. Takes a restart of the PC or restart of the Oculus Service to get it back.  It is even listed in the latest Nvidia Driver release notes as known issue.

    There may be different issues being discussed in this thread...

    That's what was happening to me too, disabling Fast Start fixed it.
    Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
    ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

    Be kind to one another :)
  • dburnedburne Posts: 1,694 Valuable Player
    dburne said:
    There is a known issue with the later Nvidia drivers where the headset does not "release" at times when closing Oculus home after using it. This results in the next time put headset on the screen will remain black in the HMD. Takes a restart of the PC or restart of the Oculus Service to get it back.  It is even listed in the latest Nvidia Driver release notes as known issue.

    There may be different issues being discussed in this thread...

    That's what was happening to me too, disabling Fast Start fixed it.

    I have had Fast Start disabled for some time now. 
    Don

    EVGA Z390 Dark MB | I9 9900k| EVGA 2080Ti FTW3 Ultra |32 GB G Skill 3200 cl14 ram | Warthog Throttle | VKB Gunfighter Pro/MCG Pro grip | Crosswind Pedals | EVGA DG 87 Case|
«13
Sign In or Register to comment.