New To The Forum? Click Here To Read The How To Guide. -- Developers Click Here.

Can't Copy Files From PC

owenwpowenwp Posts: 657
Art3mis
I have tried two different PCs and my android phone, and nothing is able to access my Go as a disk drive. It shows up under the "safely disconnect" menu in my tray, and I can see an ADB device in my device manager, but nothing shows up in the My Computer screen. There are no prompts for file access inside the headset, or any other signs of activity. I tried rebooting the device, switching to USB 2 ports, updating to the developer ADB driver, turning dev mode on and off, nothing.
Sanzaru - Programmer

Comments

  • cyberealitycybereality Posts: 25,400 Oculus Staff
    We're aware of this issue, due to having developer drivers installed for Go. See these steps to get it working:

    1) Right Click on This PC(My Computer) from desktop or start menu

    2) Select Manage then Device Manager (NOTE: Some PC's can go directly to Device Manager from here skipping manage)

    3) Directly after Network adapters on the list, it should display Oculus Devices (might be Portable Devices) and if expanded it should display Oculus Composite ADB interface. Right click on Composite ADB interface and select Update Driver (NOTE: Might just be Composite ADB interface or Composite device, VR-Headset etc. but this is the one that needs to be changed to MTP following the steps below)

    4) Select the Browser my computer option

    5) Select the Let me pick from a list option

    6) Select MTP USB Device and Next

    7) After the driver updates to a MTP device it should be displayed as a VR-Headset under This PC/My Computer under Devices and drives
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • rubinventurerubinventure Posts: 19
    NerveGear
    edited May 7
    I am sure you already did this...but...when you connect the oculus go to the data cable. the oculus go will ask you to allow sharing files in the headset itself [edit] forgot to mention trying different cables as I came across a usb mini cable that I thought could be for data and it was only for charging...I threw it away
  • studlygooritestudlygoorite Posts: 33
    Brain Burst
    I am sure you already did this...but...when you connect the oculus go to the data cable. the oculus go will ask you to allow sharing files in the headset itself [edit] forgot to mention trying different cables as I came across a usb mini cable that I thought could be for data and it was only for charging...I threw it away
    Thanks for this, I did not see the go ask to allow sharing, fixed it.
  • owenwpowenwp Posts: 657
    Art3mis
    edited May 7
    Thanks for the quick response. Following these instructions, after selecting "Let me pick from a list" there is no option for MTP USB Device.

    The only available choices are:
    ADB Device
    Oculus ADB Interface
    Oculus Composite ADB Interface

    I see some others if I uncheck "show compatible devices" but none that sound anything like it.

    I am on Windows 10 Pro version 1709 build 16299.371 which is the latest on the semi-annual update channel.
    Sanzaru - Programmer
  • cyberealitycybereality Posts: 25,400 Oculus Staff
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • bigcat1969bigcat1969 Posts: 35
    Brain Burst
    This might be dumb but I realized I was using a different cord when it worked for me. I switched back to the other cord and it worked again. With the wrong chord I wasn't getting anything on the computer when I plugged it in, but it was charging.
  • owenwpowenwp Posts: 657
    Art3mis
    Installed driver 2.0 (which had to be forced, windows said that the best driver was already installed until I used the "have disk" option), no change.
    Sanzaru - Programmer
  • castellani.jeanluccastellani.jeanluc Posts: 10
    NerveGear
    It is the same for me !
    And how use DLNA ?
    Jean-Luc : Oculus Go in Paris
  • FieldOfVisionFieldOfVision Posts: 199 Oculus Start Member
    I had this issue for ages, then I turned developer mode off and on again and did a reboot from the HMD while plugged in. It works now for some reason, and I haven't even installed the 2.0 drivers.

    Check out our latest VR exclusive games from www.FieldOf.Vision
  • CraicDesignCraicDesign Posts: 2
    NerveGear
    I had this issue for ages, then I turned developer mode off and on again and did a reboot from the HMD while plugged in. It works now for some reason, and I haven't even installed the 2.0 drivers.
    Yes! This fixed it for me. Switching to another computer seemed to break it, and toggling off and on developer mode from my phone got it working again. 
  • phil.warner.360phil.warner.360 Posts: 1
    NerveGear
    Turning off Developer mode with my phone fixed it for me. Inside the Go it wouldn't turn off and connect to my computer.
  • owenwpowenwp Posts: 657
    Art3mis
    edited May 26
    I finally got it to work, here were the steps that finally did it:

    - Repeatedly uninstall the drivers and replug the device.
    - Reinstall ADB driver 2.0.
    - Switch developer mode off while the Go is plugged into my PC.
    - Put it on while still plugged in, saw the file access prompt for the first time ever. However it still did not mount as a drive.
    - Reboot the Go while leaving it plugged in.
    - Go back to the device manager and do another "choose from list" driver installation, this time for the first time the MTP driver shows up in the list. 
    - And at last I can copy files to it.

    No other combination seemed to do it. If I had to guess I would say that windows did not see the 2.0 driver as the newest, so it would choose a different one every time you plugged it in again. This is a pretty crap user experience frankly for what should be dead simple functionality. Also it doesn't say anywhere in the docs that you have to turn off dev mode.
    Sanzaru - Programmer
  • cyberealitycybereality Posts: 25,400 Oculus Staff
    I actually spent about 2 hours on Friday trying to get this to work and was not able to see the accept prompt while in developer mode. With dev mode off it worked, but I was trying to use dev mode to test a build. Will try again next week, maybe I'll have better luck.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • castellani.jeanluccastellani.jeanluc Posts: 10
    NerveGear
    edited May 28
    owenwp said:

    - Switch developer mode off while the Go is plugged into my PC.
    How switch ?
    but not working on my pc
    Jean-Luc : Oculus Go in Paris
  • owenwpowenwp Posts: 657
    Art3mis
    The switch is in the mobile app, under More Settings.
    Sanzaru - Programmer
  • michaeljreyesmichaeljreyes Posts: 7
    NerveGear
    @cybereality

    I found the fix!  We need to be using ADB version 1.0.39.  Most people will install 1.0.32 and that will not work.  Once I installed ADB 1.0.39, it showed up via adb devices!  I'm so happy!

    Now, I need my Go to cool off from redownloading all the apps that were deleted when I did a factory reset...
  • edhelledhell Posts: 1
    NerveGear
    I started having this problem after turning on Developer mode the first time....the strange thing is that it seems different depending on versions of Windows in my situation...I have 3 different ones in the house (7 home premium-garbage, 8.something (not sure), and 10 with current updates afaik).....the windows 10 computer seemed to access it with no problem in either mode, but the win7 has to have dev. mode turned off through Oculus phone app first to access the file system, but can then be turned back on at least for that session.  TRY TURNING OFF dev mode first, THEN plug in to USB cable and see if it auto detects the VR unit....if it works then you can turn dev mode back ON after transferring your files instead of a factory reset....
Sign In or Register to comment.