New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Can't Update Oculus Home

ButterzroxxButterzroxx Posts: 5
For some reason I can not update Oculus Home or even access any of my games anymore. I get the banner at the top of the app saying new drivers are required. I click to install them, Home closes and re-opens and re-displays the update message. I tried to uninstall and reinstall and it does not fix the issue. If I try to ignore it and play a game it says the update is required to continue. Tried using the driver installer located in the Oculus folder on my HDD and it does nothing.

My PC:

Windows 10 64-bit
AMD Ryzen 5 1600
16gb DDR4
X370 Gaming Plus Mobo
Three 250gb SSD


  • cyberealitycybereality Posts: 26,156 Oculus Staff
    Can you try disabling anti-virus and then running the setup installer and choosing Repair?
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
Sign In or Register to comment.