New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Twitchy shadowmaps.

P3nT4gR4mP3nT4gR4m Posts: 1,715 Valuable Player
I've noticed if you have shadowmap enabled for a lamp then you add another it kills the first lamp's shadowmap (not sure if the new one grabs it or not) but leaves the button turned on in the first light's properties. Need to turn it off then back on again to get it back.
Tagged:

Comments

  • DeadlyJoeDeadlyJoe Posts: 776
    3Jane
    edited July 2018
    I believe in the v2 notes or manual somewhere it says that the engine currently only supports one shadow map, but up to eight light sources. The toggle button staying on is definitely a bug, but switching the shadow map to the most recently added light source is just a software design choice.
  • nosferalatunosferalatu Posts: 33
    Brain Burst
    Yes what @DeadlyJoe says is true. Medium supports one shadow map at a time. There can be up to eight sources, but only one with a shadow map. It sounds like you've found a legitimate bug, though, if the first light's button is still set to enabled.

    FWIW, the problem with multiple shadow maps is one of performance: for the GPU, one shadow map is nearly as expensive to render as a single lit pass. While we could enable multiple shadow mapped lights, it would quickly become prohibitive for any GPU to render multiple shadow maps at VR framerates.

  • jessicazetajessicazeta Posts: 244 Oculus Staff
    Great find though @P3nT4gR4m, we missed that one. Bugging now.
  • P3nT4gR4mP3nT4gR4m Posts: 1,715 Valuable Player
    @jessicazeta This is also an issue across save/reload. Like the shadowmap is turned off on reload but the switch is set on on the property panel. It's almost identical to that hide ref mesh bug in the last release.

  • Sterling77Sterling77 Posts: 514
    Neo
    Also Point Light flicker when you scale the light down small - say to create a small glowing center ie Ironmans Chest. 
Sign In or Register to comment.