New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Gear VR won't launch for me anymore

wingshotwingshot Posts: 3
edited March 2018 in Samsung Gear VR
Ok, So I have the gear VR along with Samsung s8+ for a mount now.
I was so happy, and then out of nowhere even the last hour I was using, it. This happened three or four days ago, just won't launch normally.
I try it directly to launch apps from Oculus, then promotes me to put the phone into the gear, nothing happens, remains at same promote please insert the phone into VR... I try almost everything I even factory reset my phone, followed with many different problems lost all my contacts, etc.. I would be happy if damn think were fixed, but the same problem, then I saw that I can activate Developer mode.
Then I realize most of the stuff are not working tracking and etc..
Can somebody tell me what the hell is going on? cuz I left with no nerfs, and I am gonna sell the shit and buy cardboard and be done with it :(
I just decided to see if u nice people can help me.
Thank you and sorry for the romance
I am so angry.


  • FunKingFunKing Posts: 43
    Brain Burst
    From what you said, it looks like a hardware problem. 

    Did you check the USB connector in the Gear VR? I'd remove and reinsert it just to be sure. Also be sure that your phone's USB port is clean (and dry!).

    If you can't get it working again, I'd recommend to try your phone on another Gear VR headset, perhaps at a Samsung Store or repair center. Bring your headset to try it on another phone as well.

    At least it seems like your phone and Gear VR are still under warranty, so it should be easy to get a replacement. 
  • wingshotwingshot Posts: 3
    It seems I don't have other options I just can't explain to my self since I was using them just fine 1 Hour before this happened, how can any of them break since the gear was on a table next to me and I leave the phone to charge :(
  • tonygordon008tonygordon008 Posts: 1
    Same bullshit problem this stuff is NOT...READY for distribution...worked once....
  • erik.zimmerman.5209erik.zimmerman.5209 Posts: 4
    Having the same issue, worked a couple of times now won't hook up no matter what.
Sign In or Register to comment.