New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Charging but no light? Edit: is it even charging?

furtinfurtin Posts: 104
Hiro Protagonist
edited June 2018 in Oculus Go
edit: At this point I dont even know if its charging?! I get no feedback from the device whatsoever...

So my GO went black while I was installing some Apps. It doesnt react to anything. Yes, I tried the Volume - and Powerbutton combo: didnt work.

Maybe the batterie is just low. But how do I know if its charging, if the small led doesnt light up? Any other suggestions how I get it back to normal? 
"The sky above the port was the color of television, tuned to a dead channel."

Comments

  • paridionblueparidionblue Posts: 3
    NerveGear
    My Oculas go will not charge or turn on, orange light blinks sometimes....
    The battery was dead, so the device shut down, now it won't boot up, or even charge. I know others are having the same issue, but it seems as though no solution was given, what's happening? can you help me?
  • geebee666geebee666 Posts: 224
    Nexus 6
    If prolonged charging doesn't help try holding the On button for 20~30 seconds it may get it to restart.
  • CrashFuCrashFu Posts: 1,756 Valuable Player
    If it's working correctly, there SHOULD be a light (color-coded to charge level, red orange or green, or white when in use) regardless of whether the device is on or off.

    If no light is appearing, then something isn't working correctly.

    If you open up the oculus app in your phone, and go to the settings tab (with your phone's bluetooth and location functions enabled)  can you connect to the Go at all?
    It's hard being the voice of reason when you're surrounded by unreasonable people.
  • ciurea.daniel.77ciurea.daniel.77 Posts: 2
    NerveGear
    I'm having the same problem with my device. It worked for about 10 minutes then I received a low power warning, after it charged for about 30 mins it didn't started again - and the led is not on while connected to a charger, although when I connected it the first time was on.
    After another 3-4 hours of charging still nothing - I tried volume - and power button combo & power button for 20-30 seconds without success.
    I tried to connect it to my pc but I do not have any option to reset it.
     
  • vmatrixvmatrix Posts: 10
    NerveGear
    https://www.droidsavvy.com/unbrick-qualcomm-mobiles/ 
    Has full details on how to recover a device that shows up as Qualcomm HS USB QDloader.
    Only of Oculus can provide us needfull files, it should be easy to recover the device.
Sign In or Register to comment.