New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Booting Directly into Virtual Desktop

kevilaykevilay Posts: 5
NerveGear
I have recently downloaded the virtual desktop app and it is great. I am limited for space in my house so I no longer have a computer desk. So I love using this feature while sitting on the couch. My pc is always hooked up to my tv, but I would get like to get of the difficulty of starting up my computer using the TV. Most of the time my kids or gf are watching it. Right now when I turn on my pc I get to the login screen, then I need to turn my tv on to log on. Then boot the oculus rift software, put the headset on and select virtual desktop. What I am trying to accomplish is turning my computer on from the front and never needing to turn on the TV. This is mostly a windows question, but I am curious if anyone else has done this.

Thanks,
Kevin

Comments

  • DaftnDirectDaftnDirect Posts: 5,279 Volunteer Moderator

    I guess the simplest way is to just put a shortcut of the virtual desktop app in your startup folder.

    In Windows 10, the folder isn't as readily accessible as it used to be (because of the pointless metro style start menu) but it should still be there.... C:\ProgramData\Microsoft\Windows\Start Menu\Programs\StartUp

    Find your app's exe in the Oculus\Software folder and create a shortcut of it, then paste that shortcut into the StartUp folder.

    If you don't have admin privileges set up, Windows 10 may complain about you copying it there but there are a number of sites out there to explain about changing your admin rights.

    From memory I think I used a small regedit to take ownership of all of my folders a while back so I don't have the problem.

    Anyway, I just tested this with Google Earth and it started up fine without me having to do anything. If you have your Windows set to require a logon, then you'll still have to do that. The only way to avoid that is to delete your password in Settings>Account>Sign-in options.

    Intel 5820K [email protected], Titan X (Maxwell), 16GB Corsair Vengeance DDR4, ASRock X99 Taichi, Samsung 500Gb 960 Evo M.2, Corsair H100i v2 Cooler, Inateck KTU3FR-4P USB 3 card, Windows 10 Pro v1903 (18363.476)
  • MAC_MAN86MAC_MAN86 Posts: 2,262
    Wintermute
    When my Rift worked last month, by using a VRcover the sensor always opened it and is perhaps why the VRserver never closed down and after each boot it always started HOME regardless of picking up the Rift. Oddly other times in the past the updates solved it and then it started again like this.
    Surely all you need is a VR account that has no password to negate your TV. For the all too important stuff keep your password on your main account. Then simply putting on your Rift puts you into HOME to then open DesktopVR. Although for this it really is best to use a MOUSE which requires a DESKTOP so you bloody lost me LOL!
  • Protocol7Protocol7 Posts: 317
    Trinity
    There's a tick box for "Start when Windows starts" in the Virtual Desktop settings under Windows Integration
  • DaftnDirectDaftnDirect Posts: 5,279 Volunteer Moderator
    Protocol7 said:
    There's a tick box for "Start when Windows starts" in the Virtual Desktop settings under Windows Integration
    Thanks for that Protocol, as you may have guessed, I don't have Virtual Desktop, so that's quite a bit simpler than my solution!
    Intel 5820K [email protected], Titan X (Maxwell), 16GB Corsair Vengeance DDR4, ASRock X99 Taichi, Samsung 500Gb 960 Evo M.2, Corsair H100i v2 Cooler, Inateck KTU3FR-4P USB 3 card, Windows 10 Pro v1903 (18363.476)
Sign In or Register to comment.