New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

(solved) My oculus software wouldn't boot up so I tried repairing the program and things went wrong

jpryder5jpryder5 Posts: 4
edited December 2018 in Support
Yesterday I had defraged my computer, once that was over with I proceeded to launch oculus so I could redo our setup since one of the sensors had been moved. Upon trying to launch it told me to try again oculus may be updating, and I hadn't launched it at all that day, so I figured it shouldn't be updating especially if I had defraged, so I tried again thinking it just goofed up, the same message popped up. I was puzzled by this and than tried to repair it via the installer, this too failed and deleted the exe from my computer. Since the repair failed I restarted my computer and tried again, but this time it didn't give the option to repair but rather install, and so I installed it, but that also proceeded to fail. Than I attempted to find a program that may be clashing with it, the most recent thing I downloaded was Halo 2 Project Cartogripher so I uninstalled that and tried installing, didn't work.Than I proceeded to try and delete the files related to oculus thinking that one could be corrupted, I stumbled across a log that contained this:
[Debug] [12/8/2018 3:24:38 PM] Starting up OVRLibraryService v1.16.0.0.
[Debug] [12/8/2018 3:24:38 PM] Starting up.
[Warning] [12/8/2018 3:24:38 PM] IPC connection attempt failed!
[Debug] [12/8/2018 3:24:38 PM] IPC thread running; waiting for Oaf to connect.
[Debug] [12/8/2018 3:24:38 PM] App libraries for this user: [CORE_DATA]
[Debug] [12/8/2018 3:24:38 PM] OVRLibraryService starting in service mode.  Arguments: [install-package, C:\OculusSetup-DownloadCache\, C:\OculusSetup-DownloadCache\]
[Debug] [12/8/2018 3:24:38 PM] Creating NTFS transaction.
[Error] [12/8/2018 3:24:38 PM] Invalid command 'install-package'! Args: 2
[Debug] [12/8/2018 3:24:38 PM] Operation failed.  Rolling back changes.
[Error] [12/8/2018 3:24:38 PM] Exception in PerformBlockInTransaction():
System.Exception: Block returned ErrorInvalidCommand.
   at Daybreak.OVRLibraryService.Libraries.LibraryController.<>c__DisplayClass19_0.<PerformBlockInTransactionDeprecated>b__0(IntPtr transaction)
   at Daybreak.Core.TxF.PerformBlockInTransaction[T](Func`2 block, Nullable`1 existingTransaction)
   at Daybreak.OVRLibraryService.Libraries.LibraryController.PerformBlockInTransactionDeprecated(Func`2 block)
[Debug] [12/8/2018 3:24:38 PM] Exiting with code 18 (ErrorInvalidCommand).
This had occurred about the time I first launched oculus. Once I had removed this files I restarted my computer and tried to install again, I made it further than before yet it still failed.
The previous log entries date is 12/1/2018 4:06:23 PM, that is how long its been since I launched oculus
Windows 10, 1803
Gtx  1070 ti
Intel Core i7-8700 CPU, 6 cores
I have no idea what to do, and are freaking out a tad, please help.


  • jpryder5jpryder5 Posts: 4
    Update: I'm currently going to use a restore point automatically created by the computer before I launched oculus.
  • jpryder5jpryder5 Posts: 4
    Update: The restore failed.
  • jpryder5jpryder5 Posts: 4
    edited December 2018
    Solution bellow
    Last update: after deleting the files and redownloading the installer I was able to get it to work, it also launches now.
Sign In or Register to comment.