New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

update fixed

ogmiusogmius Posts: 3
NerveGear
I used the installation app to do a repair and it worked. took about 20 minutes to reinstall but it worked I have VR again.  
«1

Comments

  • doghous3doghous3 Posts: 58 Oculus Start Member
    edited December 2018
    I just updated this morning (10mins ago) and it had borked the SDK (as noted in Unity), but Oculus ran another firmware update and that seemed to have returned things to normal.

    Just a FYI.

    Pricsoner 518 Oculus [soon]

  • V01d_GamingV01d_Gaming Posts: 10
    NerveGear
    so its fixed?
  • ReetavirpReetavirp Posts: 8
    NerveGear
    Nope
  • doghous3doghous3 Posts: 58 Oculus Start Member
    They just posted this on Twitter:



    Pricsoner 518 Oculus [soon]

  • V01d_GamingV01d_Gaming Posts: 10
    NerveGear
    doghous3 said:
    They just posted this on Twitter:


    What if we uninstalled Oculus and now it wont install?
  • AeroXpertAeroXpert Posts: 3
    NerveGear
    Still didn't work for me.  I just tried again.  Deleted the old setup files, including the OculusSetup-DownloadCache, downloaded the OculusSetup app around 30 minutes ago, re-downloaded the 5 GB, just got the "Restart Computer, sorry we encountered an error" message.
  • GeronNerdGeronNerd Posts: 2
    NerveGear
    I have the same issue
  • jayvillaflorjayvillaflor Posts: 1
    NerveGear
    same here. i got the "Restart Computer, sorry we encountered an error" message when trying to re-install the software.
  • jmill98xxjmill98xx Posts: 1
    NerveGear
    same thing here what a first impression of the rift first time setting it up should have got a vive
  • rh_galaxyrh_galaxy Posts: 114 Oculus Start Member
    edited December 2018
    Don't think you would be any happier with a vive... there are much trouble with the steamvr software at the moment, and you'd be left out to that... This probably will be resolved within hours, while steamvr issues goes on and on for weeks...

    Where is the description of the issue you are having?
    Is it related to my issue: https://forums.oculusvr.com/community/discussion/72000/updated-to-1-20-then-got-a-fw-update-then-1-33-queued-now
  • ogmiusogmius Posts: 3
    NerveGear
    all I did was to use the repair function 
  • jackburton09jackburton09 Posts: 5
    NerveGear
    back to normal i didn't do anything i just upadate again through home and now back to normal
  • IamJonDIamJonD Posts: 1
    NerveGear
    Same here, update broke the Oculus app (vr service error). Tried repair which downloaded 5GB but failing to install "Restart Computer, sorry we encountered an error".

    Anyone got a fix for this yet?
  • LuDia001LuDia001 Posts: 5
    NerveGear
    Pretty sure the latest version of this one is the bad one. --> OVRServer_x64.exe 501061-public 
    I see this one right after reboot connecting with the internet like 8 times or so and each time it gets killed automatically.(crashing)
    Manually killing all related Oculus processes and manually starting in command prompt OVRServiceLauncher.exe -start
     does exactly the same. I noticed this executable and other core dll's changed this morning on my machine. There must have been compiling errors as I notice a lot of cpp errors when trying to do it manually. I simply can't believe this has passed any form of QA at all. No notes on the main website either and this is not helping in shaping the integrity and believe on a company like Oculus. Their entire customer base is not able to use their product at all !! this is simply not acceptable in the world we are living today by keeping all of us in the dark.

  • PapaCharlie85PapaCharlie85 Posts: 2
    NerveGear
    Same Issue here…
    I received a new PC today.
    Downloaded latest installer Version.
    Downloaded the 5GB (meanwhile 4 times)
    After downloading it says that an error occured and that i have to reboot the PC.

    What I tried without success: 

    Disable Firewall/AntiVirus
    Adding exclusions to Firewall/AntiVirus
    Run as admin
    Several "fixes" from the web including Regedit to check the permissions
    Trying to install on another drive

    Nothing works and it is frustrating! 

    Here is the log text:

    [Debug] [15.12.2018 14:28:35] Starting up OVRLibraryService v1.16.0.0.
    [Debug] [15.12.2018 14:28:35] Starting up.
    [Warning] [15.12.2018 14:28:35] IPC connection attempt failed!
    [Debug] [15.12.2018 14:28:35] IPC thread running; waiting for Oaf to connect.
    [Debug] [15.12.2018 14:28:35] App libraries for this user: [CORE_DATA]
    [Debug] [15.12.2018 14:28:35] OVRLibraryService starting in service mode.  Arguments: [install-package, C:\OculusSetup-DownloadCache\oculus-runtime.zip, C:\OculusSetup-DownloadCache\oculus-runtime.zip.sig]
    [Debug] [15.12.2018 14:28:35] Creating NTFS transaction.
    [Error] [15.12.2018 14:28:35] Invalid command 'install-package'! Args: 2
    [Debug] [15.12.2018 14:28:35] Operation failed.  Rolling back changes.
    [Error] [15.12.2018 14:28:35] Exception in PerformBlockInTransaction():
    System.Exception: Block returned ErrorInvalidCommand.
       bei Daybreak.OVRLibraryService.Libraries.LibraryController.<>c__DisplayClass19_0.<PerformBlockInTransactionDeprecated>b__0(IntPtr transaction)
       bei Daybreak.Core.TxF.PerformBlockInTransaction[T](Func`2 block, Nullable`1 existingTransaction)
       bei Daybreak.OVRLibraryService.Libraries.LibraryController.PerformBlockInTransactionDeprecated(Func`2 block)
    [Debug] [15.12.2018 14:28:35] Exiting with code 18 (ErrorInvalidCommand).

    Maybe someone has an idea

    Rgds, PC
  • SeafitSeafit Posts: 4
    NerveGear
    edited December 2018
    Repair function failed for me and it uninstalled the existing Oculus install. Trying to reinstall now, failed twice now trying a 3rd time after disabling Windows Defender. I'm not hopeful. 
    Also, having to download 5GB for each installation attempt is not insignificant on my connection, it takes hours. 

    EDIT: Forgot to mention I am seeing the same log entry as PapaCharlie85
  • errore404errore404 Posts: 2
    NerveGear
    AeroXpert said:
    Still didn't work for me.  I just tried again.  Deleted the old setup files, including the OculusSetup-DownloadCache, downloaded the OculusSetup app around 30 minutes ago, re-downloaded the 5 GB, just got the "Restart Computer, sorry we encountered an error" message.

    Same here... and I tried deleting also everything Oculus-related in AppData/Local and AppData/Roaming folders but it's the same: "Restart Computer, sorry we encountered an error"...

    :disappointed:
  • SeafitSeafit Posts: 4
    NerveGear
    Just tried to install again and another failure

    I did find an error in 
    <USERNAME>\AppData>Local>Oculus\OculusSetup.log
     
    ============================================================================
    [Error] [15/12/2018 16:47:36] Error setting up Oculus directories: Daybreak.Core.Io+IoException: Error creating directory 'C:\Program Files\Oculus\'. ---> System.ComponentModel.Win32Exception: Access is denied
       --- End of inner exception stack trace ---
       at Daybreak.Core.Io.CreateDirectory(Nullable`1 transaction, String path)
       at Dawn.Setup.CreateOculusDirectoriesStep.CreateDirectories(Nullable`1 transaction, Boolean movedSoftware)
       at Dawn.Setup.CreateOculusDirectoriesStep.InstallImpl()
    [Debug] [15/12/2018 16:47:36] Install 'Dawn.Setup.CreateOculusDirectoriesStep' failed.
    [Warning] [15/12/2018 16:47:36] Rolling back installation.
    [Debug] [15/12/2018 16:47:36] Partial uninstall: True
    [Debug] [15/12/2018 16:47:36] Uninstall 'Dawn.Setup.CreateOculusDirectoriesStep' succeeded.
    [Debug] [15/12/2018 16:47:36] Uninstall 'Dawn.Setup.CreateLibraryServiceStep' succeeded.
    [Debug] [15/12/2018 16:47:36] Uninstall 'Dawn.Setup.InstallRedistributablesStep' succeeded.
    =======================================================================================
    Those are the last entries in that file. Anyone else seeing this?
  • SeafitSeafit Posts: 4
    NerveGear
    edited December 2018
    Fixed for me:
    Right, so after seeing that 'Access is denied' message I ran the setup as Administrator (right click on file choose Run as Admin option) and that has worked for me, I have it working again.
    I hope that helps someone out there, good luck guys

    EDIT: I had Windows Defender disabled when I did this, not sure if relevant but adding in case
  • errore404errore404 Posts: 2
    NerveGear
    SOLVED FOR ME: 
    I followed and merged the info from this 2 guides and it worked:

    https://forums.oculusvr.com/community/discussion/69494/having-oculus-rift-setup-issues-the-ultimate-guide#latest

    https://forums.oculusvr.com/community/discussion/69245/oculus-software-sorry-we-encountered-an-error-during-installation-solution-found

    So basically, for me, it was:
    uninstall oculus
    delete everything (also things from AppData)
    clean the registry with regscanner
    disable avg free (the antivirus)
    install
    setup
    enable avg free
  • ReetavirpReetavirp Posts: 8
    NerveGear
    Still not fixed. Same error " Restart Computer ". Can they not just roll back to a previous version that worked and then fix this new broken one offline?
  • FreshDeadMeatFreshDeadMeat Posts: 10
    NerveGear
    Reetavirp, Your talking about FACEBOOK!  I think your expectations are a little too high here
  • AeroXpertAeroXpert Posts: 3
    NerveGear
    AeroXpert said:
    Still didn't work for me.  I just tried again.  Deleted the old setup files, including the OculusSetup-DownloadCache, downloaded the OculusSetup app around 30 minutes ago, re-downloaded the 5 GB, just got the "Restart Computer, sorry we encountered an error" message.
    And now it worked.  Install finished, no problems.  Not sure what changed.  Only thing I had done to my system was show hidden and system files and folders from File Explorer...  Anyway, glad it was able to install.
  • FreshDeadMeatFreshDeadMeat Posts: 10
    NerveGear
    Still down, tried about 15 different installs, removed suggested folders, set to admin, tried windows 8 compatibility mode and Nada
  • ReetavirpReetavirp Posts: 8
    NerveGear
    I have just got mine back. I deleted all oculus cache from C drive, then did a fresh install from the oculus website. After the usual 5gb download it installed fine and is running now. Just re-installing robo recall etc at the moment.
  • MattGahan77MattGahan77 Posts: 7
    NerveGear
    Success. On the 7th try. I had to remove all remnants of Oculus software, from "Program Files" and the APPDATA directory, also the download cache. Additionally, I disabled antivirus and ran the setup with admin rights. I didn't touch the registry.
  • LuDia001LuDia001 Posts: 5
    NerveGear
    I got it running on the first try of fixing all the BS.

    I checked my download folder of Windows 10 and there was the initial setup file that I downloaded when I got my Rift.
    This is the OculusSetup.exe with file version 1.26.0.0.

    I did not de-install, cleared cache, no registry cleansing, no services stopping or anything like that at all. The only thing I did was running this setup as administrator (I did it this way to be sure but do not know if it is mandetory). Then from the menu picked the option to 'repair'. I starts downloading the 5+GB of data and starts installing.
    Et Voila…. it's back without issues.
    I haven't been using the rift throughout the week but when I tried to yesterday all the S$$$ started. Now that it is running again I check de history log and noticed the update was done in the background 4 days ago already and that I find interesting. Regardless the Oculus Home is running again and in the changelog I found version 1.33.....
    EDIT: By the way the broken process running in the background is now working with version OVRServer_x64.exe 750915-public. The one that kept on crashing in the background processes yesterday was OVRServer_x64.exe 501061-public 


    Oculus‑software, versie 1.33.0
    Dash:
    • We've added a new system keyboard to Dash. You can access it by clicking on the keyboard icon at the bottom right of any virtual desktop window.
    • We've updated Dash's background environment with new textures and lighting.


    Home:
    • You can now report offensive behavior and content within Home. Use the context menu or social panel to initiate a report.
    • We've added a new collection of festive items to celebrate the holidays! *
    • Assets include:
    • Decorations
    • Lodge Sofa
    • Lodge Armchair
    • Antique Sled Table
    • Lodge Rug
    • Rustic Dining Stool
    •  
    •  
    •  etc etc

    Anyway, I did it in this way and it seems none of the apps I'm missing. There are coming in new updates for some of them even.

    When that is done I'm going to do a reboot, hook everything up and see if it is all good now.
    In case it is not I report back



  • StechmueckeStechmuecke Posts: 42
    Brain Burst
    Is the new install fixed???
    Will the devs inform when this isa fixed???
    Will it be happened before chrismas-holidays????
    If not: Where can i refound oculus and all fgames i bought!
  • bigmike20vtbigmike20vt Posts: 4,105 Valuable Player
    edited December 2018
    Hi.
    I have deliberately kept my pc off in the hope it will automatically update to a working install not a broken one when fixed. Is it safe to log in yet?
    Am hearing conflicting messages elsewhere

    Thanks
    Fiat Coupe, gone. 350Z gone. Dirty nappies, no sleep & practical transport incoming. Thank goodness for VR :)
  • LuDia001LuDia001 Posts: 5
    NerveGear
    I was having an issue yesterday with my AlienWare laptop like you can read in my previous posts. That is solved for me now. Upstairs I got an AlienWare Aurora with my second Rift and that one I didn't touch the past week. I fired it up this morning as well and it got updating immediately and all worked fine there from the moment go. So you should be able to fire it up without any issue.... at least for me it did
Sign In or Register to comment.