New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Constant Oculus Rift Issues/ USB Disconnects and Poor Tracking Quality

MetaPlayMetaPlay Posts: 2
Hello everyone!

This is my first post in any support forum ever so bare with me if I have trouble explaining my issues on here but I do hope that someone is able to help me.

So I have my Rift for roughly a year now and when it works it works well, but 50% of the time I use it I have issues like USB disconnects and tracking issues.
There is so much to write here in order to explain the particular issues I am facing and the things I have already tried and even bought in order to fix everything... but it just doesn't seem to work and it is making me furious everytime I want to use my Rift.

Here is what I own and what my PC Specs are:

- Oculus Rift + Touch Bundle
- An additional Sensor for full 360° tracking
- An Inateck KTU3FR-4P USB 3.0 PCI Express Card for all of my sensors to avoid USB bandwith issues on the motherboard
- Two USB 3.0 Extension Cables (Active)
- a USB 2.0 Extension Cable included with my third Sensor

- OS: Win 10
- Motherboard: MSI X370 Gaming Plus (VR Ready)
- CPU: AMD Ryzen 5 1600X
- GPU: Nvidia GTX 1070
- RAM: 16 GB

In general the issues I am facing appear usually when setting up my rift for another play session, that inlcudes connecting all 3 of my sensors and connecting the Rift itself.
What happens usually is that my sensors aren't being picked up by the software, appear to have poor tracking quality or they show up with device issues in the Device Overview of the Oculus Software. Even when they are shown as completely fine and working - when I put on my Rift, the headset has no positional tracking or is jumping all over the place as if there are no sensors connected to my system. Sometimes the sensors even disconnect from the PC eventhough they are still physically connected. In some cases the setup seems to work fine but after a few hours the sensor disconnect mid gaming and cause the Oculus Software to freeze or show an error message telling me that there is a hardware problem occuring. Trying a fresh Sensor Setup in the Oculus Software also doesn't always work as stuff disconnects or the Touch Controllers aren't being tracked by the sensors properly.

That being said, the strange thing about all of this that sometimes (the other 50% of use) the setup works like a charm and there are no issues at all. The tracking works perfectly and there are no USB disconnects whatsoever.

But when I get my Rift out the next day and connect it to the same USB ports on my PC (including my PCI USB 3.0 Express Card) with the same room setup - it magically stops working and gives me the exact same issues I just explained.

The things I tried to fix as much as I can consist of:

- Buying an extra PCI USB 3.0 Express Card
- Buying extra USB 3.0 Extension Cables (Active)
- Changing the Energy/Power Saving Modes on Win 10 to "Max Performance", including manually disabling USB sleep mode tom prevent Sensor Disconnects
- Disabling Energy/Power Saving for all USB Ports in the Windows 10 Device Manager
- Trying different USB Port Configurations (Some day it works some day it doesn't)
- Using the Sensors with and without USB extension cables
- Updating all the Drivers for every PC Component
- Updating my OS
- Using the Oculus Tray Tool

So as you guys can see, to my knowledge, I tried basically everything I could to fix my disconnects and tracking issues regarding my Rift.
It is pure pain to troubleshoot my setup every damn time I wanna use my Rift.
It feels like one of these computer issues that no one can understand because there are no more things to do in order to fix it.

However, and that is very important, like I said I can sometimes use my Rift with no issues (as of writing this post my Rift is connected and is working perfectly, I did face the exact same issues when setting it up earlier).
My only idea left is that maybe my power supply is a bit too weak to maintain the power and data flow of the Rift and said Sensors but that surely can't be the case since it offers 500W and that should be more than enough.

I really hope to get some ideas and help here...
Thanks in advance!


  • ksnksn Posts: 38
    Brain Burst
    edited January 2019
    1. What power supply unit do u have?
    2. Try to plug all sensors into USB 2.0 PC onboard ports
    3. Try to use only onboard USB 3.0 and 2.0 ports
    If nothing helps try to replace all USB cables (you no need active really and be sure cables are not longer 2 meters)
  • MetaPlayMetaPlay Posts: 2
    ksn said:
    1. What power supply unit do u have?
    2. Try to plug all sensors into USB 2.0 PC onboard ports
    3. Try to use only onboard USB 3.0 and 2.0 ports
    If nothing helps try to replace all USB cables (you no need active really and be sure cables are not longer 2 meters)
    Hey thank you for your help!

    1. I have the Pure Power 10 500W CM Power Supply by "be quiet!"
    2. I only have one USB 2.0 Port on my Motherboard
    3. Tried that before same results, cables are 5 meters long that are suppose to work with the Rift - Amazon reviews even say so

    I got it to work more often by reinstalling the fresco usb card drivers and using the Tray Tool again, but as of typing this all sensors disconnected mid game yet again... It has to be an issue with the USB PCI Card since right now it is showing me a yellow triangle in my Device Manager.
    I will try it with my onboard USB ports again but I can already tell you that it won't last long...

  • shredittttttttttshreditttttttttt Posts: 1
    Hope you got it figured out by now. If not, try uninstalling the fresco driver and let windows detect the usb card and use its native driver. Works like a charm.
Sign In or Register to comment.