New to the forums? Click here to read the How To guide. -- Developers click here.

Will Oculus announce "WE BLOCKED OLD CPUs SO BUY NEW!"

Ticket opened to Support on this for a definite verdict. They either BLOCKED non SSE4.2 entirely now in their update within the Librarian Server OR it just could be a permissions issue. We run Personal Computers not a Mac which lets us decide our setup and performance relations. I was happy with my Xeon Quad Duo 3GHz for 3yrs in VR but since the update 1.32 in November they broke all ways to reinstall it!

I want the truth. No need to be shy on the matter. They had already tried blocking it via the official install but the cpu hack proved that it did still indeed work extremely well. It surely is highly mafia-like to discriminate in this manner especially when only LONE ECHO uses those SSE4.2 commands but also has it's very own cpu check albeit after the installation yet still allows us to enter the game menu! Most likely even that would have worked in not selected the extra gpu detail. When ASW2 comes out it will run even better PLUS 1.33 is running so much more memory efficient and VR is all about the available RAM footprint with a decent gpu.

IF I get a response I'll post back as the community should be told. Remember, it says "Recommended Specs" on the box NOT an absolute requirement. They added the Warning Sign in Home to remind us that our cpu may be lower than possible (in very few cases e.g. FOS). By having that sign they expect users to have cpu that ARE NOT in their recommended spec. Verdict = Guilty!

Comments

  • MAC_MAN86MAC_MAN86 Posts: 1,102
    Neo
    edited January 9
    As expected my first response does not confirm the Block:

    Edzel (Oculus Support)

    Jan 8, 9:35 PM PST

    Hello,

    Thank you for contacting Oculus Support about your concerns regarding the software.

    As Morty previously point out before update 1.32, your Xeon processor doesn't meet our minimum specifications.

    The reason this has been added as a requirement is due to the fact that many games make use of SSE 4.2 due to the new instruction sets compared to SSE 4.1.

    In addition to this, your processor is 11 years old, and has been discontinued for 8 years. You may be able to ask the community for assistance in this matter. The only provided resolution to my knowledge is to upgrade your processor to one with SSE 4.2 compatibility.

    If you have another computer that has the available instruction set to run the Rift, then I'd be more than happy to assist you where possible. In addition to this, if you do purchase any other Oculus devices in the future, we're still more than happy to assist there as well.

    As for an older runtime, we don't have any older version of the software and as such we're unable to provide you with such.

    Let me know if there's anything else that I may address for you.

    Edzel
    Oculus Support

    It evades the wording "Recommended Minimum Spec" and the fact that even though we used a hack it showed us a Warning of not meeting that R.M.S. and we may experience lower performance. Well perhaps it was lower but it worked very well. Now that Warning obviously will never be seen if they have Blocked non-SSE4.2 CPU.

    Yes tech moves on and they cease to make older models but a Xeon is designed to run a lifetime and 24/7 and it did work in VR very well.
    I know of just LONE ECHO which uses SSE4.2 but they claim many games use it. I have requested a list of such.
  • stanimir.dimitrowstanimir.dimitrow Posts: 12
    NerveGear
    @MAC_MAN86 ; Thanks for great effort you've put into this issue! i'm fully supporting you, and wish You  happy hours in VR with your new machine! Unfortunately i don't have such opportunity at the moment, so my newly obtained Rift is rendering useless now! Will stick around for awhile to see  ,if any miracle happens .Then i'll get rid of this thing, and probably the VR itself.
    Good Luck and stay safe!
  • MAC_MAN86MAC_MAN86 Posts: 1,102
    Neo
    I'm rather thinking it is just a problem with the last 2 updates due to other i7 Users had problems with. I'm still upgrading regardless but still would like to know if old PCs are now blocked to prevent me fighting on with installing it for my girlfriend to use at some point.
  • Techy111Techy111 Posts: 5,082 Volunteer Moderator
    A PC with lots of gadgets inside and a thing to see in 3D that you put on your head.
    And FlyInside Forum Admin.
    Flyinside Flight Simulator RELEASED.
  • LZoltowskiLZoltowski Posts: 6,506 Volunteer Moderator
    Guys please don't bate :)
    Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
    ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

    Be kind to one another :)
  • snowdogsnowdog Posts: 5,512 Power Poster
    Guys please don't bate :)

    Sorry LZ, but this entire thread is ridiculous. His CPU isn't anywhere near the Minimum Spec Requirement for the Rift. It's at least 8 years old. VR is currently aimed at the enthusiast market and won't be mainstream for YEARS, and in that time the Minimum Spec Requirement will most likely be EVEN HIGHER THAN IT IS NOW lol :o :D

    This is as bad as that other bloke complaining about the Rift having issues with Windows 7, an Operating System that is 10 years old this year.
    "This you have to understand. There's only one way to hurt a man who's lost everything. Give him back something broken."

    Thomas Covenant, Unbeliever
  • stanimir.dimitrowstanimir.dimitrow Posts: 12
    NerveGear
    This doesn't change the fact, that same old machines were able to run  Rift  just fine and most games also, before some updates.  What is different now, other then Lone Echo?
    Using same device on the same Games -  its a simple and logical request.
    Also if this thread is ridiculous , there much more interesting things to read elsewhere.

  • MAC_MAN86MAC_MAN86 Posts: 1,102
    Neo
    edited January 9
    "Recommended" is the wording they use in SALES but twist this in Support Ticket. Fellas I seriously don't see why this bothers you. They NEVER have yet announced any Block for SSE4.2 and know we only used a hack for installation. i.e. the Runtimes ran ok until 1.32 but as others had issues installing this does not announce any BLOCK and they always had continued to use a Warning Sign in Dash for such CPU. An answer is expected to paying customers of the Rift and Games even though I have no quarms in buying an up to date i7 8700 (even though that is already old generation!)

    @snowdog, I have played in VR for 3 yrs already with little effect to performance. Only 1 (ONE) game uses SSE4.2 I can not play: LONE ECHO.
  • iJudgementiJudgement Posts: 177
    Art3mis
    edited January 9
    MAC_MAN86 said:
    "Recommended" is the wording they use in SALES but twist this in Support Ticket. Fellas I seriously don't see why this bothers you. They NEVER have yet announced any Block for SSE4.2 and know we only used a hack for installation. i.e. the Runtimes ran ok until 1.32 but as others had issues installing this does not announce any BLOCK and they always had continued to use a Warning Sign in Dash for such CPU. An answer is expected to paying customers of the Rift and Games even though I have no quarms in buying an up to date i7 8700 (even though that is already old generation!)

    @snowdog, I have played in VR for 3 yrs already with little effect to performance. Only 1 (ONE) game uses SSE4.2 I can not play: LONE ECHO.
    They have a "recommended" and a "minimum" i dont see a recommended minimum anywhere.

    Minimum means you need at least this to run without issues. Notice, they're all newer CPUs that have SSE 4.2? 

    Notice when you try to install the software without SSE 4.2 it stops you from installing and says you need it? 

    Notice you had to use a workaround to get the software to work when it was working? Workaround not provided by Oculus. 

    Workarounds break. Upgrade your hardware.
  • ohgrantohgrant Posts: 102
    Art3mis
      Tough break bro, but it sounds like the support tech confirmed to you that it is blocked because  SSE 4  is now a requirement. 8 years old, socket 1155? If you never did a CPU upgrade, not much to it after you figure out the fan mounting screws. Pretty much plug and play if you mobo supports upgrading to these.
    I believe the fastest for 1155 is the i7 3770k https://www.ebay.com/itm/Intel-Core-i7-3770K-Quad-Core-3-5GHz-8MB-LGA1155-CPU-Processor-SR0PL-Delided/233081849534?epid=115945079&hash=item3644c2c6be:g:l1UAAOSwpFtcMK25:rk:10:pf:0

    I'm running an E3 1280 and having no issues with anything including Lone eco.  You can get one of those for under $100 now. https://www.ebay.com/itm/Intel-Xeon-E3-1280-SR00R-3-5GHz-Quad-Core-LGA-1155-CPU-Processor-km/173731404442?epid=1501171449&hash=item287332da9a:g:zocAAOSwJdBbFZBh:rk:2:pf:1&frcectupt=true

     Both options should get you running but still on an unsupported processor.  


  • MAC_MAN86MAC_MAN86 Posts: 1,102
    Neo
    edited January 9
    Don't worry fellas I am upgrading but want to know officially my old PC which worked until November is now Blocked or it was just a problem with the installation from Updates 1.32 as was for many users of even new PCs. I already know what I bought did not have a "Minimum Spec" but a "Recommended" as it said on the BOX!
    They gradually added measures along the way to prevent installation of non-SSE4.2 CPU. If the installation problems are now fixed then there is a chance it may still install once again as it did before. I take onboard by using a hack they won't support any issues relating to working properly BUT it did so for 3yrs!
    Sure they can change the software as in T&C but to totally Block a PC which works is discrimination and has totally no requirement to do so. It simply proves corruption within the ethos of Facebook Oculus to force new tech sales.

    I'm not upgrading the m/b nor the CPU as I'm getting another PC. Just tell us Oculus did you BLOCK them?



  • MorgrumMorgrum Posts: 1,379 Poster of the Week
    Man I remember my dual Xeon computer.
    It ran planetside, Morrowind, and Dark age of Camelot without a hitch...... but that was back in 2005-2007!
    WAAAGH!
This discussion has been closed.