New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Audio stops suddenly, randomly

SonicAnatidaeSonicAnatidae Posts: 5
Rift owner since 12-10-18. while I'm new to the Rift, I'm very technical. 

The first week, everything seemed to generally work as expected. Then Oculus did an update. While I cannot confirm the update is the issue, since that time, my Rift headset has suddenly started crashing the audio driver, seemingly. The headset works in every other way, when this happens. I can look around and click any buttons. 

I'll use BeatSaber as an example, but this seems to happen in any game, Oculus or SteamVR. 
In Beat Saber, the song I'm playing just stops, as if the game detected that audio crashed and just pauses the song. I have uninstalled Steam VR and Reinstalled. I have updated all drivers, per Oculus support. I have uninstalled Oculus setup and reinstalled it. I have removed any/all mods from Beat Saber. I have sacrificed a chicken, under the light of a New Moon. 

GTX 1060 - 6 GB
16 GB of ram
MSI Z270 SLI Plus mainboard (not running SLI, that's next year)
Windows 10 64-bit Enterprise

So whats the trick?

Best Answer

  • Templar01Templar01 Posts: 1
    Accepted Answer

    I guess this is just one more example of a company that won't allow their customers access to support and expect us to help each other. I hate it when companies hide behind technology to avoid their responsibilities to their customers. This same discussion is all over the Internet and is apparently not an isolated incident. It would appear that Oculus does follow what's being said on Reddit or other forums so I am posting this here. If they remove this, I'll simply post this again on every other board and also let folks know that this post was censored on the Oculus "support" forum. 

    My issue is the same as posted above. However, I can add some details from numerous hours of testing. According to the logs, I have over 20 hours invested in debugging their product and I'm sharing what I found. Hopefully this post will save someone a similar fate until the Oligarchs at Oculus decide to stand behind their product.

    Clearly the problem is software/firmware related. Why can I say that? Read on. 

    Here's one method that reset audio settings and did get the audio to work again through the rift earphones but did not provide lasting results. This only happens with applications launched within the Oculus app. Steam Launched apps appear to be unaffected.
    • Testing using the Oculus environment always resulted in a loss of audio anywhere between 30 seconds to 3 minutes of use. This is reproducible in ALL apps I've tested and launched from within Oculus.
    • Dropping down to the Windows 10 Audio properties and toggling the "disable all enhancements" on and off did reset the audio. One must click "apply" for this to work. However, as I said, this solution only provided a remedy for 30 seconds to 3 minutes until the audio drivers crashed again. 

    Here's what I did that is a work-around despite being a really unacceptable answer given that I paid for a product that does not function as represented. 

    Solution #1 - Use Steam VR environment.
    Whenever possible, do not purchase or use apps that are hosted within the Oculus environment. Instead, see if the app is available on Steam and purchase it through them and launch it from within their VR environment. Steam does not have this bug. I've only tested "Virtual Desktop", "Universe Sandbox" and "DeoVR Video Player" so far. None of these apps had any audio problems when launched from Steam VR and all of them are available through the Oculus store and Steam. I also tested Elite Dangerous which is only available through Steam and I've never experienced any audio issues ever. 

    Solution #2 - If You Must Use Oculus Launched Apps, Abandon Rift Audio Altogether.
    Disable and remove the Oculus audio headset pieces and go back to plan B which is an alternate Audio output device. This is what I was forced to do and audio works reliably after that but only using Windows 10 resources. 

    If you haven't already noticed, you got a little black piece of plastic with the Oculus that is packaged with the lens cloth. That's actually a screw driver. Take the screw driver and remove the audio ear pieces and set them aside. They are useless anyway until Oculus 1) Acknowledges and owns up to the fact that this is their problem and 2) Decides to do something about it.

    Then go into Windows 10 Device Manager and disable anything that contains the words "Rift" or "Oculus"(if you're unsure how to do this Google: Disable Windows Devices). This will effectively disallow the Oculus software from randomly trying to switch back to the Rift headset, which I found it does if you don't disable that within the OS. If you try to tell the Oculus app to use another Audio output, it will eventually revert back to the defective Rift headset solution and of course crash on you and that's why one must disable to device within Windows Device Manager. It can't use what it can't see.

    Then go back into Oculus app and click on settings and make sure that the only Audio choices are Windows Based hardware. This will verify that you disabled all but Windows devices. You may have to go into "Open Sound Settings" either in Control Panel or your system tray and change the default output to the device you are using in place of Oculus. In my case, I use the Audio from my Monitor or separate headphones connected to my PC if I want to use headphones. With the Rift ear pieces removed, any standard headphone actually fits quite nicely over the VR headset except that you now have to deal with a second set of wires unless you're connected via Bluetooth. 

    I realize this is a Kluge of a solution but it did get me past the problem. Of course, if it were another company's product, I wouldn't have posted here, instead I would have opened a ticket. But then again, Oculus won't actually engage with customers directly, will they? 

    BTW: I also tested the inverse of this solution - that being to disable all non Rift Audio to see if that worked and it had no affect. The audio driver simply crashed as before.

    For the record. I've tested this on two gaming machines. One with an AMD VR capable graphics card and also with my main rig which is an NVIDEA GTX 1050 TI. Both systems are running Windows 10. Both have 16GB of memory, one is an i5 CPU and the other an i7. Both passed the Oculus compatibility test suite and were declared VR ready. The NVIDEA gaming rig was also one that I rebuilt from the ground up, after the initial Oculus audio failures. With a wiped disk and pristine install of Windows 10, this eliminated any potential of incompatible drivers or other software. So if the developers want to point fingers, fat chance, my reference system is as vanilla as a gaming rig can get out of the box. I think the real smoking gun here is that these issues do not show up under Steam but only within the Oculus launched apps.  


  • ZeDoctorZeDoctor Posts: 13
    I have posted the same thing along with 2 other guys and all of us havent gotten answers from anybody. Hopefully someone will know the fix
  • SonicAnatidaeSonicAnatidae Posts: 5
    edited December 2018
    I was able to get it working again, but I don't know the specific fix.
    I was troubleshooting it the correct way (changing 1 thing at a time), but getting no where, so I decided to tear it all out, update drivers and reinstall it all.  Whats odd is it worked fine for the first week, then the issue. 

    Steps taken:
    Uninstall SteamVR and Oculus (delete the folders after uninstall)
    Update audio, USB and Nvidia drivers
    Uninstall all of the extra garbage Nvidia installs (left, the graphics driver and Nvidia HDMI audio driver)
    Moved headset USB to 2.0, left Sensors in USB 3.0 slots. 
    Reinstall Oculus Setup
    Setup Oculus again
    Reinstall STEAMVR
    Reinstall Beat Saber (my testing app)

    After these steps, it seems to have settled. Audio issue *seems* to be addressed. 

    I did purchase the Inatek 4-port USB card, but since everything seems to be working, I never installed it. 

Sign In or Register to comment.