New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Medium Crash on Start... Suggestions?

2»

Answers

  • cybercyrus90cybercyrus90 Posts: 107
    Art3mis
    edited August 2017
    Also Im a bit curious(and might be probably asking in the wrong place), but why Isnt there a change game directory setting inside the oculus runtime? Just seems a bit weird having to reinstall the entire thing... 
  • JuliusBOSSJuliusBOSS Posts: 6
    NerveGear
    @cybercyrus90 I feel your pain. :neutral:
  • ObbyBulletObbyBullet Posts: 1
    NerveGear
    edited August 2017
    [SOLVED: see bottom] 

    I have the same problem. I bought a new computer a month ago to start with VR (an Alienware Aurora). Rift came in 2 days ago. First Medium didn't install because it was blocked by firewall (looking to disable Windows Defender completely because that's all I had at the time). After install, it crashes along with Bigscreen Beta, Quill, Discovery VR, Google Earth VR and others.

    I didn't look very far but I only looked for the Medium and Quill error logs (attached). Both show it's an OpenGL problem. Anyone have recommendations? I'm not very well versed in these things.

    My PC has only one graphics card (I remember reading that's been an issue in the past). 

    Edit: I have Kaspersky Free running which doesn't handle firewalls so Windows Defender is handling that. As many people know, there isn't a way to turn off WD outside of changing the local registry, and I would prefer to stay out of that. I check my firewall rules and only Bigscreen and Oculus are listed as allowed in inbound (no outbound rules). I also checked with NVIDIA and Dell and NVIDIA had some driver updates so I installed them.

    None of the above has helped. Nothing seems to work and I don't know why. 

    SOLVED:
    Kept trying different things, and I ended up right clicking the desktop and going to NVIDIA controls. It told me that my display wasn't connected to an NVIDIA GPU, which led me to maybe my Intel Driver was corrupted. In the end I switch my display to a different port (display port bunched with the HDMI port, rather than an off-shoot) and it ended up working. Everything about when I purchased the computer showed that I only have 1 graphics card, is that incorrect? Does the fact that using a different set of port make this happen?
  • StickjockStickjock Posts: 14
    NerveGear
    Still unable to get mine to run no matter what... just the "Medium has crashed" error box with nothing else...

    I WILL chalk it up to my inferior CPU... at least that's what I'm telling myself for the time being... new MOBO, Ryzen CPU, DDR4 RAM on the way.  Once all that comes in by next week will get it assembled and everything reinstalled and see what the outcome is...

    p.s. been needing to upgrade for a while now anyhow... CPU has been a major bottleneck in my system for too long, hoping the new cpu coupled with my GTX 1060 gives me more luck with Medium and other VR apps in general.
  • MattHickmanMattHickman Posts: 359 Oculus Staff
    Sorry we couldn't figure it out for you @Stickjock we are reproducing a varient of this here now so hopefully we can root it out and get it fixed in the next update. Thanks for the help tracking it down, good luck with the upgrade! 

  • StickjockStickjock Posts: 14
    NerveGear
    No worries @MattHickman  ..I had to "fudge" my install anyhow seeing as my poor old Athlon II x4 650 doesn't support SSE4.2... so again, I'm going to blame it on that... everything I've ran with the exception of Medium "seems" to run OK... just know they all COULD run much better and at a higher quality...

    Will report back next week once the new build is done... 

    btw... as someone who started with PONG... yeah, this VR is A. Maze. Ing... 
  • NobleMarioNobleMario Posts: 5
    NerveGear
    I've got the same issue. All drivers are updated and I'm on App Version 1.17.0.424527.  I don't have a /Oculus/Medium directory either.  The app crashes before that is created, apparently.
  • MattHickmanMattHickman Posts: 359 Oculus Staff
    Sorry to hear that Darren. We're trying to figure out why this is happening and we're moving logging sooner in the boot sequence to get some more info.

    Are you able to run Quill and other apps normally like the other users? Have you disabled all MSI related add ons? No virus scan, malware or anything like that running? No GPU tuners like Riva tuner going?
  • NobleMarioNobleMario Posts: 5
    NerveGear
    Quill does work.  I have AVAST Pro and disabling it does not correct the issue.  I have not installed any GPU software outside of the nvidia drivers and control panel.
  • NobleMarioNobleMario Posts: 5
    NerveGear
    Here is my Service log captured from when I click on the app.  I see warnings that I believe are due to the USB 3. hub I have.  I'm waiting on a 4 port card to replace the 2 port card I have in the pc now.
  • StickjockStickjock Posts: 14
    NerveGear
    Update:  New system built and up and running... native USB 3.0 (old system had USB 2.0 with an add-in USB 3.0 card) as well as USB 3.1... Oculus "can I run it" reports all items ready to go. Will be installing Oculus and setting up everything after work today... Medium will be the first app tested...

    Crossing my fingers..
  • Sterling77Sterling77 Posts: 491
    Trinity
    It happens to me most of the time - boot up rift and hit medium strait away - and it will crash - task manager and kill the lower oculus client - then start medium again and it will work. 
  • MattHickmanMattHickman Posts: 359 Oculus Staff
    HELP! Used to work fine, and just the other day started giving me this, Ive tried everything from reinstalling and updating drivers, restarting my computer, reinstalling medium, clearing space and nothing seems to work :/

    Can you post a DxDiag so we can see your system specs?
  • StickjockStickjock Posts: 14
    NerveGear
    Well... new system up and running... 

    Ryzen 3 1200 @ 3.2 ghz
    GTX 1060 6gb
    ASUS Strix 350F mobo
    16 gb DDR4 G.Skill Ripjaw ram

    Oculus installed just fine... better this time around actually...

    Medium is still a no go... tho' I've one more test to try.  I still installed the Oculus software to my C:\ and all apps to F:\ for space saving. (c:\ is my 250 gb SSD, f:\ is a 1 TB HDD)...

    Will uninstall everything again and TRY having everything installed to my C:\ this time... 

    As an aside... Robo Recall was the only other app/game I installed to test out with the new system... and OMG... knew my old processor was killing the VR experience but wow... huge difference...

    Will report back if the reinstall works/helps...
  • NobleMarioNobleMario Posts: 5
    NerveGear
    Mine still crashes.
    Where does Medium determine the graphics card?
    This is in my one Oculus_Medium.log file:
    07/28/17 14:48:16 [I]: GeForce GTX 980/PCIe/SSE2 w/ GL 4.5.0 NVIDIA 384.94, GLSL 4.50 NVIDIA

    The System Information screen in Windows 7 shows the correct card:
    Name NVIDIA GeForce GTX 1080 Ti

  • MattHickmanMattHickman Posts: 359 Oculus Staff
    That info gets kicked back to us from OpenGL, we don't generate it. I'd suggest doing a clean uninstall of the drivers and update to 385.41. 

    See if that helps. 
  • NobleMarioNobleMario Posts: 5
    NerveGear
    Reinstalling the drivers has not helped.  This message shows in the oculus Service_datetime.txt file:
    31/08 10:39:51.989 {WARNING} [ApplicationPackage] App oculus-oculus-medium-retail has exited with error: 2147483651

    Does that tell you anything?
  • passghostpassghost Posts: 3
    NerveGear
    2017, losing faith... :( I really had high hopes for this program.
  • jessicazetajessicazeta Posts: 195 Oculus Staff
    Hey @passghost, have you checked out the thread specifically for people who are crashing? https://forums.oculusvr.com/community/discussion/69965/are-you-unable-to-start-medium-are-you-crashing#latest 
2»
Sign In or Register to comment.