New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Oculus Go casting

snoopdillasnoopdilla Posts: 3
Trying to cast to my iphone x. 
I click the cast button on the headset. Click start on headset. It pops up a oculus message on my phone. It says Casting: Start casting which I click on my phone. 
Now it goes to a screen on my phone saying Requesting....Please accept the casting request in my headset. BUT there is no request in my headset. And that all it does. 
Any help is appreciated


  • snoopdillasnoopdilla Posts: 3
    It then times out and say headset not found. But my phone and headset are both in the same wifi. 

  • pelle999pelle999 Posts: 5
    Brain Burst
    Try restarting your phone and then open the Oculus app manually before you select start casting on the GO. 
  • h.r.gargih.r.gargi Posts: 204
    Nexus 6
    Got this on my iPhone too. Tried it next day and it worked again without doing anything about it. 
    German Oculus Quest / Go / Link Facebook Group ... join us
  • david.lawrancedavid.lawrance Posts: 1
    Mine wasn't working. I deleted the Oculus app, redownloaded it, and now casting works.
  • snoopdillasnoopdilla Posts: 3
    Ok, I tried deleting and redownloading the oculus app on my phone. No change. :( Also tried restarting the phone, and going into the app before attempting to cast. No change. :( 
    Why does it even ask to accept cast request? Does anyone see the cast request in the headset? 
    There should be an option in the app as well as to attempt to cast with a connected headset. 
    Any other ideas guys? Thanks for your help. Casting with help me guide my kids through using the headset. 
  • KEEFtheREDKEEFtheRED Posts: 2
    I have the same issue using a Samsung S4
    I can usually get it to start casting to my iphone without any issues but the problem is that if I leave the app and come back to it I can't go back to streaming... there's some mention of clicking an icon in the iphone Oculus app but I can't find any streaming icon in the application.   Once that happens the only way I've found to get it back is restarting the Go and then restarting the streaming. 
  • KEEFtheREDKEEFtheRED Posts: 2
    Ok I got casting working on the S4, however it freezes after a few seconds and then goes off. I tried casting to my Samsung TV also but this is not picked up on the connections, however it can see my son's LG.
  • Dragnmasta71Dragnmasta71 Posts: 1
    I have an iPhone XR, so I did a restart on my phone, reopened the oculus app turned on headset and went to casting. I was able to then cast thru my phone. Another added features for Apple junkies, if you have an apple TV is set your phone for screen mirroring first then open oculus app, then turn on headset to turn on casting. Your experience would then be on a larger screen. (*info to help those who are trying to cast on larger screen). Hope this helps. 
  • nostalgeeknostalgeek Posts: 1
    edited December 2018
    Same here on Pixel 3, clicking Start button from the Cast screen on the headset, App on phone shows "Please accept the request in your headset" but nothing shows up in the headset other then the red dot in the middle of the headset screen. Very frustrating. Wanted to show my Oculus Go to family during the holidays.

    Update: Got it to work by rebooting the phone. No more "Please accept the request in your headset" message, it starts casting right away to my phone. Need to use Android built-in Cast feature to cast to my Chromecast though can't seems to cast directly from the Oculus app.
  • a360vra360vr Posts: 4
    im trying to cast to the Huwawei p20 pro using the Oculus app.  I connect to the headset, click the 'cast' icon on the phone follow the selection process and click the 'Accept' pop up on the Go.  Hey Presto it seems to show the Oculus home screen but only for a few seconds before it all freezes.  Is anyone else getting this and have you found a work around??

  • supportCaritasVRsupportCaritasVR Posts: 2
    edited May 2019
    Same problem: Want to cast from Oculus to:
    - Huawei mediapad T5: freezes after about 3 seconds
    - Trekstor P10: freezes after about 5 seconds
    - Samsung galaxy A5 2017: freezes after different times or doesnt start and keeps black
    - Huawei M10: Freezes after a few seconds

    Oculus Go-App seems to be some sort of trash.
  • aghkoaghko Posts: 4 Oculus Start Member
    I will just join the reports. Huawei Honor5: Freezing after 5 seconds. For Go and Quest.
  • MrPigBallMrPigBall Posts: 2
    Same as above for quest and p20 pro 😔
  • nicolas.voulgarisnicolas.voulgaris Posts: 1
    edited May 2019
    Same problem with my huawei mate 20, it freezes after a few seconds...

    EDIT : Problem with the quest
  • bennymarktbennymarkt Posts: 2
    Same problem here, the streaming freezes after a few seconds. Huawei Mate 10 Pro and Android 9.
  • chettawanchettawan Posts: 78
    Hiro Protagonist
    Cast to the phone never work for me both Go and Quest. My phone is Huawei P20 Pro. Cast session always freeze after a few minutes.
  • happyDecayhappyDecay Posts: 10
    I have the same issue on Quest and Huawei P20. Cast freezes after 5 seconds and cannot be re-established unless I restart the Oculus app. 
  • digiomegamondigiomegamon Posts: 2
    Huawei P30. Is this a Huawei problem?
  • barsaaa2barsaaa2 Posts: 1
    Me too In huawei p 30 pro
    It is not huawei problem. 
    It is facebook fault. 
    They need to develop their app to be compatible with all cutting edges smartphones in market.
    Need to make better QA. 
Sign In or Register to comment.