New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Rift S Headset sensor check failed?

2»

Comments

  • pokotacopokotaco Posts: 2
    NerveGear
    edited June 2019
    after hrs of trying a bunch of crap .. this fixed my sensor  problem in seconds .. alienware r4 .. windows 10 .. went to device manager .. to usb controllers .. disabled tobii eye tracking .. yours might read "eyechip" .. restarted computer .. DONE .. rift s works great .. i hope this helps someone out there .. 
  • FeralReaperFeralReaper Posts: 38
    Brain Burst
    SO here's my path and the reason I'm getting a refund. 

    I run "fix software" it rips 7gb of data from my internet.

    I run it, works like a charm. Then I reboot, error comes up that the oculus software can't open. I repair it again. It works but the tracking doesn't. Then it forces an update to the firmware again and now it can't see my cables.

    Rift s is complete shit and they don't seem to be fixing it. I would get your refund guys.
  • HenryWalker16HenryWalker16 Posts: 1
    NerveGear
    its not a problem with the headset just update windows and reinstall the oculus software i had yhe same problem this fixed it
  • WroughtSamuraiWroughtSamurai Posts: 3
    NerveGear
    We found a solution on our end. Stupidly, after finally giving up after hours of trying by clicking the "Skip" button, we are brought to the main page, and a banner at the top of the screen basically says "Hey, have you tried installing this?" (Can't remember the exact words) but we installed it and it works if you then re-do the set-up from the device menu... ridiculous. Why would they make you install a vital download only after giving up on getting it to work? Oh well, it's up and running now I guess.
  • adrbinadrbin Posts: 4
    NerveGear
    edited July 2019
    Hello everyone.
    I had the same problem.(I have!)
    At first I installed Oculus according to the instructions.
    I put the headset on, then world around me start flickered, on and off repeatly, then i saw just noice.(grain like on old tvs)
    Six *** hours I was trying to solve this problem. I tried everything.
    My joy in purchasing the oculus was way gone. Then it miraculously began to work.
    I didn't even shutdown the computer at evening in fear that something go wrong, but yet Oculus didn't work next morning.

    Another 12 hours... I did clean install of windows, finished all windows updates.
    Installed the latest video card driver. Oculus just flickered a few times and then the noise again.
    After removing the device in oculus sw it could not find the sensors.
    I thought the problem might be in the usb 3 controller driver. ASMedia
    I'Ve tried the latest drivers, older drivers. I tried to disconnect all other devices from the motherboard if there was a problem in power supply usb.
    I have tried different settings of the oculus, Hz setting etc.
    Nothing helped. But I notices that when the oculus worked, it appeared in the control panels as "pc camera" and "rift s sensor" when it didn't work.

    Then I turned on beta chanel... in oculus settings and the option to upgrade oculus software appeared. After the upgrade, a red panel with the option to upgrafe the firmware was displayed.
    And after upgrading the firmware, the control panel showed "pc camera" again and the oculus worked again.
    It didn't matter the version of asmedia drivers, after rebooting, after removing the devices in oculus sw - it still worked.

    I thought I won...
    But few hours later there was a tadaaa sound of plug&play and blackness in oculus.
    I found out that "rift s sensor" is in control panel again.
    Since then, nothing is running again!!!
    There was no shutdown pc, restart, windows updates, change of drivers, nothing changed at all, and yet "rift s sensor" appears again on its own.

    This incompatibility or whatever, whether it's an oculus or windows error, is absurd, annoying and incredible.

    Can anyone tell how to make sure that the control panel will have a "pc camera" in which case everything works? Thx.
  • sraurasraura Posts: 590
    Trinity
    Check the cable connector from HMD's end.
  • adrbinadrbin Posts: 4
    NerveGear
    Hello, also check and replug cable on HMD's end, I believe it is not the problem.

    Right now I am working. My steps:

    1) I uninstall ASMedia drivers.
    Device manager:
      ASMedia USB3.0 eXtensible Host Controller - 1.0 (Microsoft)
      Root Hub USB (USB 3.0)
    when plug Oculus:
      Rift S USB Hub
      Rift S USB Hub

    Control panel:
      Rift S

    Oculus wizard:
      At first time: it flickers and blackout (grain)
      Second time: sensor can't track headset.
    Headset firmware: 1.8.0

    2) Trying find updates of asmedia drivers automaticaly:
    Device manager:
      ASMedia USB3.0 eXtensible Host Controller (29.8.2016 1.16.38.1)
      ASMedia USB Root Hub
    when plug Oculus:
      Generic SuperSpeed USB Hub
      Generic SuperSpped USB Hub

    Control panel:
      Rift S Sensor
      Rift S

    Wizard:
      3 point loading, black screen
      After removing devices: Sensor can't track headset.

    3)
    Turning off Beta
    Unplug Oculus
    Stopping OVRService
    Deleting appdata/local/oculus
    Repairing Oculus SW (downloading 7GB :-/ )
    Updating Oculus SW (1.38.0.261476)
    Updating Firmware
      Headset (1.7.1 - less then before)
      Touches (1.11.0)

    Control Panel:
      PC Camera
      Rift S

    Wizard:
      OK

    Strange. Beta turned off, older firmware and yet.
    I will test few things and inform you about other findings and changes.
  • adrbinadrbin Posts: 4
    NerveGear
    edited July 2019
    ...
  • adrbinadrbin Posts: 4
    NerveGear
    edited July 2019
    UPDATE: Few minutes of sleeping and Oculus freezed my computer, after restart sensors doesn't work, I have my "hands" in my head... during reconfiguring "cant track sensors" text appears again. Even "pc camera" is in control panel, nothing changed and yet doesn't work again. I find out previous Oculus has same issues with external sensors, so Oculus developers could seriously work in and improve. This is not worth the money.

    UPDATE: After second restart, it changed to "rift s sensor" in control panel. Here we are at start again...

    UPDATE: I reinstalled Oculus sw (beta off), it needed to update (to older version I guess), then a firmware update message (to 1.7.1) appeared. Instead, I turned on the beta. Nothing.
    I uninstalled the controller drivers, installed a new, nothing.
    I turned off the beta and started the firmware update to 1.7.1. It needed to update sw (newer version). PC Camera (only one device) appeared in the control panels. Nothing.
    Updated usb driver here. A second "Rift s" device appeared in the control panels, and Oculus worked.
    So I suppose the firmware update process must be done regardless of the version.

    After placing the Oculus on the table for half an hour, the sensors do not run again.
    When oculus freeze and lose conectivity, just stop ovrservice, then unplug and plug the oculus, start the oculus app and take the headset on. (great isnt it?)

    After some time, a "rift s sensor" appeared in the control panels and nothing worked again.
    I bought an external controller for PCI-E with SATA power. When I put oculus into it, "Rift S" and "Rift S Sensor" appear in the control panels, but Oculus was working.
    "Incompatible USB" message was displayed in Oculus sw. (it's a newer USB 3 than on motherboard with extra power supply). And unfortunately, every 10-15 minutes, the sensors do not work (blackouts), or the USB connects and disconnects. It's not usable. I tried newest and older drivers - nothing.

    I plugged the Oculus into the usb on a motherboard again and I repeat the restart process regularly, or reinstall Oculus sw completely. And it pays off! :(
Sign In or Register to comment.