New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

My Rift stays black after update today :(

Hello!

Oculus software got updated today, including a driver update, and now my Rift stays black! :cold_sweat: 

I already updated the grafic card driver and repaired the Oculus software...but still black!

Anyone got the same problem and help?

Thank you

Answers

  • HoernleHoernle Posts: 16
    Brain Burst
    Yes i have exactly the same problem. Is your orange light on but the white LED is not appearing when opening the software, right? Do you get a notification in the Oculus software that your rift is not working correctly? The suggested support page says sth about dash not working, am I right? 
  • nyomennyomen Posts: 1
    NerveGear
    edited June 2019
    Same here, DisplayPort just says no.
    So its working for like 30 Seconds and then it just says the DisplayPort is not connected correct. 
    Used this USB-Port and Display-Port for like 2 weeks and yesterday it just stopped working.
    Restarting, Reinstalling driver (rift and nvidia driver), using different DisplayPort, using another USB-Port nothing is working anymore.
    Sound, Microphone, Headtracking and Controllers are still working in the first 30 secs but the screen just stays black all the time.
    Seems to be a real issue with the firmware update.
    Can't imagine the hardware broke somehow till the rift s chilled on my desk all the time and the cable was just taking care of all the time.

    Btw: Don't know why this should be answered, since the problem seems to persist on Rift and Rift S users.
  • johann_novak_shjohann_novak_sh Posts: 7
    Brain Burst
    Same here. I downloaded the update two days ago and ever since, the display was black and the LED color is orange.
    After several repair tentative and fully reinstalling three times (OculusApp>Uninstall + registry + AppData) and graphic card updates, nothing has changed. When I plug the HDMI cable on the computer, Windows doesn't detect the new display.
    However I tested the installation procedure on another computer and it was flawless, everything works fine and the display shows correctly everything so I think it really is related to some data not cleared on the computer.
  • HoernleHoernle Posts: 16
    Brain Burst
    it's good to hear that I am not alone with this issue. It makes it more likely that the update has an issue on some maschines.

    @johann_novak_sh Is your Rift (and the sensors) green in the oculus software under devices? How do you know Windows doesn't detect the display?
  • GraysGrays Posts: 6
    NerveGear
    Hello,

    I had a similar problem yesterday.  Maybe here it's your (temporary) solution, it works for me.
    Go to the installation directory (default : C:\Program Files\Oculus\Support\oculus-runtime) and run OVRServer_x64.exe file.  A command window will open, and MUST stay open (you can minimize it).
    Then if we've the same issue, your Rift will work again.

    It's a temporaty solution but it works (for me atleast).

  • johann_novak_shjohann_novak_sh Posts: 7
    Brain Burst
    When I did the first update, yes it seemed to the OculusApp that everything was ok. I could launch an app in the OculusApp but nothing happened. However, as of now, I can no longer install the software completely because a part of the installation requires to put on the HMD.
    I know that it isn't correctly detected because before, when I plugged the Rift's HDMI, my two monitors turn black for a second. But it is no longer the case.

    By the way, my specs :
    Windows 10 Pro 10.0.17134
    NVidia GeForce GTX 970
  • GraysGrays Posts: 6
    NerveGear
    Yes there's a serious issue with the installation right now.  It need to be fixed.
    It's seems that there's an issue with Windows 10 - 1903 update.
  • johann_novak_shjohann_novak_sh Posts: 7
    Brain Burst
    edited June 2019
    Ok so I tested the fix with the manual launch of OVRServer_x64.exe.
    Somehow, it was already launched so I had to kill it manually beforehand. Then I installed again the OculusApp. At first, it didn't found the HDMI so I unplugged/plugged it but it was still not found. I ignored all of the following steps and was able to access to the OculusApp. Finally I killed the server the started it again, and my Rift was found.
    To sum up, playing with the manual launch of the OVRServer_64.exe somehow fixed the issue.

    So thank you very much for the temporary solution, this got me through the missing HDMI issue !
  • johann_novak_shjohann_novak_sh Posts: 7
    Brain Burst
    Hello again,

    After testing the Rift, it appears that the display seems ok but I cannot open OculusHome nor self made applications.
    On ovr_Initialize(), the following line is output and times out for at least one minute :

    [Client] Connected to the server running version (prod = 1).1.38.0(build = 256587) feature version = 0. Client runs version (prod = 1).1.37.0(build = 0) feature version = 0

    There seems to be a mismatch between the client and the server.
    Besides, ovr_Create returns false and according to the last error, there is "no HMD attached" (code -1007).

    Does any one have any clues about this ?
  • KingPinAutKingPinAut Posts: 14
    NerveGear
    I just can´t believe what solved my problem!
    I had an "ö" in my windows user name and after reading a tip in the "Rift 1.38 Release" thread here I just changed that to "oe" (restarted PC maybe, don´t know for sure) ....and suddenly the screens on my Rift went on again.
    Hadn´t tested much since then but saw no obvious problem thereafter...
  • HoernleHoernle Posts: 16
    Brain Burst
    @KingPinAut I also had an ö in my Username but changing it didnt help. Did you also rename your userfolder in the registry?

    @Grays I have to give that a try

    In general, how do you guys know which oculus software version you have? Are you looking at the version file in the drivers folder? This says 1.37 for me. I dont know how to update to 1.38. Running the driver Update exe doesnt Help.
  • yoman44yoman44 Posts: 1
    NerveGear
    i had the same problem 
    tried evrything , reinstalling oculus , changing usb , running setup
    finally did windows update rollback and the screen lit , but only to give an error saying "oculus dash encountered a fatal error"

    please help !
  • blackfoxczblackfoxcz Posts: 2
    NerveGear
    Well, same problem here, after updating to the latest driver Oculus Rift stays black...
  • HoernleHoernle Posts: 16
    Brain Burst
    @yoman_321 if you reinstall the oculus software now the screen will be black again ;-), I have been there!
  • kprnkskprnks Posts: 3
    NerveGear
    The same black nothing from my side, no display in VR but display ok on monitor when I wearing vr. Any idea to correct it? I went throuh every repair process and reinstall rift softver but is still inot working...
  • kprnkskprnks Posts: 3
    NerveGear
    I even changed my video card back to the older one but still the same issue, black nothing in vr....I opened a ticket and now I'm waiting for something :)
  • RattyUKRattyUK Posts: 1,191
    Wintermute
    Hoernle said:
    @KingPinAut I also had an ö in my Username but changing it didnt help. Did you also rename your userfolder in the registry?

    @Grays I have to give that a try

    In general, how do you guys know which oculus software version you have? Are you looking at the version file in the drivers folder? This says 1.37 for me. I dont know how to update to 1.38. Running the driver Update exe doesnt Help.
    From the Oculus desktop app:

    Settings: Beta: Enable PTC
    This will download the latest PTC version and update firmware as required.
    PC info: AMD Ryzen 7 2700X, MSI MPG X570 Edge, 16GB Tforce Pro Dark DDR4 3200, KFA2 RTX 2080 Super, Samsung 870 Pro M.2, 2x 240GB SSD, 3TB WD Green HDD & 4 TB Seagate Barracuda HDD, Antec Modular 750w PSU, custom watercooling loop. (Win 10 Pro & Opensuse Leap 15.1 Linux) 32" AOC 4K Monitor.
    Rift S
    Laptop: Aorus X5 V6-CF1 (I7-6820HK, GTX 1070, 2* 256GB M.2 NVME, 1TB 7200 HDD)
  • GlarcanGlarcan Posts: 7
    NerveGear
    edited July 2019
    bom dia a todos.
    ao abrir o meu rift s ontem a mão direita não estava respondendo ao movimento, então deslliguei o oculus fechando o aplicativo. ao reiniciar, não tava mais aparecendo imagem. troquei a bateria dos controles, reinstalei o aplicativo, atualizei o windowns, a placa de video, o oculus, fiz um monte de coisas, mas nada resolveu. A luz branca liga, o som funciona, mas nada de imagem. Que tristeza.

    good morning everyone.
    when opening my rift s yesterday the right hand was not responding to the movement, so I unlocked the oculus by closing the application. when restarting, was no longer appearing image. I changed the battery of the controls, reinstalled the application, updated the windowns, the video card, the oculus, did a lot of things, but nothing solved. White light turns on, sound works, but no picture. What a sadness.
  • GlarcanGlarcan Posts: 7
    NerveGear
    edited July 2019
    top
  • haibo545001haibo545001 Posts: 6
    NerveGear
    But when I double-click the OVRServer_x64.exe file, it will automatically close only after one second.
  • Peekz121Peekz121 Posts: 1
    NerveGear
    Same problem here!
    I have too NVidia GeForce GTX 970, does it have something to do with it?
  • ubik-RoyBattyubik-RoyBatty Posts: 4
    NerveGear
    NVidia GeForce GTX 970 here too. My rift was working one day and not working the next.
  • HoernleHoernle Posts: 16
    Brain Burst
    Check out my Post in this Forum with solutions  for the black Screen issue, maybe that helps
  • MPiresMPires Posts: 162
    Art3mis
    Glarcan said:
    bom dia a todos.
    ao abrir o meu rift s ontem a mão direita não estava respondendo ao movimento, então deslliguei o oculus fechando o aplicativo. ao reiniciar, não tava mais aparecendo imagem. troquei a bateria dos controles, reinstalei o aplicativo, atualizei o windowns, a placa de video, o oculus, fiz um monte de coisas, mas nada resolveu. A luz branca liga, o som funciona, mas nada de imagem. Que tristeza.

    good morning everyone.
    when opening my rift s yesterday the right hand was not responding to the movement, so I unlocked the oculus by closing the application. when restarting, was no longer appearing image. I changed the battery of the controls, reinstalled the application, updated the windowns, the video card, the oculus, did a lot of things, but nothing solved. White light turns on, sound works, but no picture. What a sadness.
    Se não estás a usar a versão de testes tenta usá-la, no meu caso está a funcionar muito bem e houve updates de software e firmware.


  • HugeHardHugeHard Posts: 1
    NerveGear
    My rift s worked fine before yesterday.
    but now when i put  it on and look down, it will turn to orange light and black screen
    I am going to be angry.

  • Techy111Techy111 Posts: 6,863 Volunteer Moderator
    Well before you get angry are you in the beta ? If yes disable and try again and if no, opt in.
    A PC with lots of gadgets inside and a thing to see in 3D that you put on your head.

  • pensionedpensioned Posts: 3
    NerveGear
    Hoernle said:
    @KingPinAut I also had an ö in my Username but changing it didnt help. Did you also rename your userfolder in the registry?

    @Grays I have to give that a try

    In general, how do you guys know which oculus software version you have? Are you looking at the version file in the drivers folder? This says 1.37 for me. I dont know how to update to 1.38. Running the driver Update exe doesnt Help.
    I,m no expert but I found the software version by running Oculus... Look in  Library/ Updates / Recent...Oculus Software Update was first in the list. Click on What's New.
Sign In or Register to comment.