New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Displayport not connecting on setup

Support ticket is taking forever so thought might as well post here to see if anyone has any insight. got my Oculus S the other day and went through setup and everything but once I got to the headset sensor part, it wouldn't progress for about 40 minutes so I went ahead and restarted it since it took my friends who got the headset only a few minutes. When I restarted the Oculus software I wasn't even able to get past the first part where it asks for you to plug in your DP and USB 3.0. It detects the USB but there's absolutely nothing with the DP no matter what I do and I'm completely lost as to what to do. Spent almost 1k on upgrading my computer specifically for this so I'm a little peeved. Any help is appreciated, thanks. 


  • sraurasraura Posts: 590
    1. Make sure that cable is properly seated on Rift S end. You can find detailed instructions how to do that by browsing this forum a little bit more.
    2. Make sure that windows 10 privacy settings allow access to your camera.
  • snowdogsnowdog Posts: 8,054 Valuable Player
    Plug in your USB 3.0 first, wait 10 seconds and then plug in the Displayport.
    "This you have to understand. There's only one way to hurt a man who's lost everything. Give him back something broken."

    Thomas Covenant, Unbeliever
  • Singular_ShibeSingular_Shibe Posts: 3
    snowdog said:
    Plug in your USB 3.0 first, wait 10 seconds and then plug in the Displayport.
    Done that about 1000 times. Camera settings enabled and the connection directly on the headset seems snug. 
  • SpyworkerSpyworker Posts: 2
    Same issue with my 1080TI... Support is looking into this according to their last reply to my ticket.
  • sraurasraura Posts: 590
    edited June 2019
    snowdog said:
    Plug in your USB 3.0 first, wait 10 seconds and then plug in the Displayport.
    Done that about 1000 times. Camera settings enabled and the connection directly on the headset seems snug. 
    May I ask what kind of computer you have and some specs?
    Also GPU driver version and windows version would be helpful.

    Did you connect the cable directly to display port or using some adapter?

    Opting to latest Oculus app beta build might help. This will probably update your Oculus S firmware also... You can opt in from Oculus app by going to settings -> beta and turning "public test channel" -> "on".
  • LeeChan1985LeeChan1985 Posts: 1
    I might have found the issue and can help you solve this it took me almost two days. If your display and usb is not connecting try check the headset it self the wire leading to the headset could be loose  try pushing it in and you might hear a click. The wire to my rift was loose I pushed it back in and got it to connect. Hope it works for you
  • zarocostazarocosta Posts: 2
    the connector display port  it's a real shit, it is cheap, after 3 days it does not work cause the internal tabs are damaged, the same problem was with the other Rift
  • pwlpwl Posts: 1
    I’m seeing the exact same problem as OP , also with a 1080ti .  tried many things including reseating cables, different ports , nvidia displayport firmware update, etc.  support is stumped & i’m looking at at 3-4 business day delay while they try to find an answer.  

    i’m guessing the oculus software is not properly in sync with all of the other windows, etc software (eg i have the latest usb drivers, but oculus app warns that i need to update them).

    fwiw this is for windows 10 (1903) ... seems like that update is causing some issues
  • LMLucianoLMLuciano Posts: 2
    So no posts since July. Have all you people solved your connection problems because I'd love to know what you did? I have the same problem with the Rift S not detecting the displayport and right now all I have is an expensive paper weight.
  • matt.roncaratimatt.roncarati Posts: 1
    Same problem here. After extensive conversations with Oculus support their log files said that my mini displayport on my Nvidia GTX 1660 Ti was defaulting to my dedicated motherboard GFX card. I have since sent in my computer for a complete repair and factory reset, and the same issue persists. This is apparently a very common issue. Displayport is recognized for 2-4 seconds then disconnects. 

    The frustrating thing was that the Rift worked for the first day I purchased it, then this happened. Sent it in for repair, then same problem. 
  • qikrikqikrik Posts: 1
    Just bought the Oculus Rift S a few days ago. Having the same issue with displayport recognized for a few seconds and got disconnected. Anyone think the problem might be with gpu compatibility?
  • Hamster_Man69Hamster_Man69 Posts: 1
    so i ran into something weird today... My displayport usually had the same problem where it connected for a couple of seconds then disconnected but now it doesn't disconnect but it still won't work
  • deeppurple1968deeppurple1968 Posts: 1
    I have thesame problem(((
  • ILikeCheezeILikeCheeze Posts: 1
    I had this same problem.  My computer would recognize my USB port but not the display port.  I built my computer.  My computer has a mother board that has a display port, I thought I was all set up.  I plugged it in, it failed to recognize it.  After a few mins I realized I built a gaming computer with a super graphics card and the card has a different display port.  I plugged it into the right display port on the graphics card and boom it worked perfectly.  Be sure to check this out.  I still used the original USB port.  Hope this helps, my neighbor had the same issue, I solved his issue the same way.
  • TheEmeraldFalconTheEmeraldFalcon Posts: 1
    ILikeCheese what do you mean about the wrong and right port, a little more detail please?
  • VenModBenVenModBen Posts: 27
    Brain Burst
    Theemerald falcon - he was saying he plugged into the display port on his video card not the integrated one and now it works. however, I think most people are having issues. this thing is not working for many of us. I have a brand new video card that is within their specs and has 3 display port connectors and same bs. not connected but the amd adrenaline software shows it is connected to the display port.

    oculus software is obviously junk and not working properly.
  • Azulius22Azulius22 Posts: 1
    So i have this same problem, where my headset display wont connect to my laptop, i am using the adapter since I don't have a display port, my graphics card is a GTX 1050, when I plug the display port/adapter in my screen flickers for a second then does nothing.
  • adam.poole.313adam.poole.313 Posts: 175
    Its a terrible problem introduced in the version 12 driver and not fixed every since. I believe the only stable solution is to revert back to the 1.43 driver. Its at least worth a shot to confirm that the driver is the issue.

    Oculus Rift S, CV1
    Intel i7-8700K
    ASUS ROG Maximus X Hero
    16GB DDR4 x 2
    4 TB SDD, 2 TB SSD, 1 TB SSD
    Windows 10 Home
  • Gunner_GamesGunner_Games Posts: 1
    Tried that quite a few times and rolling back the drivers does not work either.
Sign In or Register to comment.