New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Oculus Quest and random WIFI lost issues

JohSm67JohSm67 Posts: 165

Some people are reporting that they get "Wifi connection is lost" randomly during usage! So do I....

I have not been digging to deep in to this yet.
But when checking around in forums there are some reports telling you that it might occur when you are using the same SSID on dualband (2,4 & 5 GHz) wifi routers / AP's! (Or if it's simply occuring if it switches between AP's)

I'm using like 4 Ubiquiti Unifi AP's in the house with a Cloudkey controller.
It's feels like it's working ok, have not seen this on other WIFI devices in my setup. But it could simply happen in the background on other devices. 

The Oculus Quest seems to loose the connection and reestablish it for me randomly, the closest AP is only like 2 meters from the Oculus Quest.
So it's abit annoying when information popup randomly during gameplay. (Yesterday while streaming to FB)

Any one else been experience it and found a solution for it? Known issue with Oculus?

I will test to create a dedicated SSID using the 5GHz band for all AP's only, to see if it helps and might be related to using the same SSID on 2,4 & 5 GHz.
If that do not help, I will try to use a Single AP using same SSID on 2,4 & 5 GHz, to see if it could be relate to switching between AP's.
Last test would be to use one SSID on the 5GHz band and a singel dedicated AP.

This will take some time to test as it's randomly occuring, so any other feedback on the issue from you out there would be nice!

By the way, are there any way to extract a local WIFI / Event log, from the Oculus Quest to investigate it easier?



  • JohSm67JohSm67 Posts: 165
    Ok, I didn't follow my inital test plan... (To much to do..)

    But the following setup works great, no lost WIFI connection on Quest or Go!

    Did set up a "Oculus" dedicated SSID on 5GHz Band, only using the nearest AP in the house.
    It will forcing the Oculus equipment to stay put on a single AP on the 5GHz band.
    Will try it some more and then also add the 2,4GHz band, using the same dedicated SSID.

    For Ubiquiti Unifi settings;
    Simply add a new WIFI network and another SSID and deploy it.
    (Then it will be available on all AP's)
    Then simply remove that network/SSID on each individual AP and band you do not want it to be available on.
    (Resulting in only beeing available on one AP and the 5GHz band.)

  • thecuriouspixelthecuriouspixel Posts: 2
    Having same issues, and curious to here if your findings hold up. We have a mesh network that mixes is up, but I only have quest issues when it gets bumped to the 2.4 version of the network
  • QVR-DudeQVR-Dude Posts: 32
    Brain Burst
    I have (not including my Quest) three total devices that draw frame rate from my Comcast modem.  I have the 2nd best send/receive bit-rate.  Only the Quest reports wifi signal loss.  Poker Stars is unplayable.  However, when I'm downloading a new game/app the through the store, there's no indication of interruption.  I'm thinking maybe a Poker Stars issue. Dunno...
  • neuromamaneuromama Posts: 1
    I just got my quest yesterday and am having the same issues with intermittent WiFi connection loss
  • OccultulistOccultulist Posts: 1
    Yeah WiFi on mesh network dropping out is BS. Might just return the quest.

    this happened on my friends using Orbi but I thought it was maybe just his setup. Bought one and same thing happens with brand new quest connected to Samsung SmartThings mesh network.

    Looks like the quest is the one thing that can’t be used on a mesh network...

    Have to disable WiFi and reenable it in quest and it works again...

    I hate facebook....
  • RennSchoteRennSchote Posts: 1
    Same here. :-/ Bought a new Quest and ran into annoying Wi-Fi drops.

    I am also using a mesh network with several repeaters on 2.4 and 5Ghz network sharing the same SSID.
    A quite normal setup nowadays.

    I am really disappointed and expect a fix from Oculus.

  • LavelleUpLavelleUp Posts: 4
    I really need a fix for this, quest keeps bouncing from 2.4 to 5ghz. I need it to just stay on the 5ghz.
  • shawzie101shawzie101 Posts: 2
    I have the same problem. I have an Orbi Mesh Network which does not allow to split 2.4 and 5 GHz. The Quest disconnects so much I've stopped using it. All my other devices work flawlessly on my Mesh Network.
  • ResistoonResistoon Posts: 15
    Brain Burst
    I have a Netgear XR500 wireless router and setup a guest access for just the Quest, and it still kept losing the WiFi connection.
  • arie2816arie2816 Posts: 1
    Same problem here with Orbi Mesh  Network
  • kem423kem423 Posts: 6
    Brain Burst
    I bought the Oculus Quest the day it came out.  I didn’t notice issues until I started playing online games like Elven Assassin and Wands.  It is extremely frustrating to keep dropping wifi even though all of my other devices don’t have issues.  My son just got a Quest too so we now have two in our home and his drops wifi constantly also. We are using an Orbi router and I cannot set a dedicated 5Ghz connection.  My son has a file hub that he is now using to connect to the wifi.  He then connects the Quest to his file hub.  He hasn’t been dropping since using it but shortly after he connects directly to the Orbi his wifi drops again. Please fix this Oculus.  I don’t know why all of my other devices can connect with no issue.  Seems like this should be something a Quest update should fix soon especially since it has been an issue since launch. I love my Quest and use it everyday.  Just really frustrated and not being able to play online due to wifi drops. 
  • BluSnake57BluSnake57 Posts: 1
    I'm getting the same issue with my Orbi mesh router. It's really starting to get agitating especially when watching movies because this is my main tv and having it lose connection every 20 minutes ruins the experience.
  • JohSm67JohSm67 Posts: 165
    Seems like there is a lot of issues with the Netgear Orbi productline!

    There are alot of settings to playaround with in it’s settings

    Try disabling the following:
    Daisy Chain, Fast Roaming, IPv6 and Set 20/40Mhz Coexistence to 40Mhz only. Save settings and reboot the router and satellite(s).

    Also do Firmware upgrade if not already done.

    Set one SSID name for 5GHz band
    And another SSID name for the 2GHz band. 

    Then use the 5GHz band SSID.

    Or open up a support ticket with Netgear and one with Oculus.
  • kem423kem423 Posts: 6
    Brain Burst
    edited October 2019
    JohSm67.  I have latest firmware. You cannot separate 2.4 and 5 GHz on the Orbi without renaming them through CMD prompt and other things that would be difficult for users not familiar with old DOS and CMD prompts.  I did that and it sort of worked but caused my satellites to stop working so had to switch back so I could have the coverage in my household .  Still think it is an Oculus issue since I have numerous other devices and none loose connection.  Using a file hub to create a separate 5Ghz network works but then I can’t cast to my tv since it is wired ethernet and no longer on the same network.  Can’t seem to win. I have fast internet. When my kid and I are both using our Quests we can play Elven Assassin together for hours with no drop. Just can’t cast Beat Saber To the tv which is frustrating because playing in a group when no one else can see is boring for everyone else.  
  • DabombTJDabombTJ Posts: 1
    I just got a Quest a few weeks ago.  I have an Orbi system as well and after reading many posts I think this is a Quest issue that needs to be fixed.  For now I have to restart my Quest to get wifi working for about 10 minutes and then it will disconnect.  So i purchase my games on the app and hope i can download them before it disconnects.  I cannot seperate my channels since it is a mesh system, but I also have had this Orbi system for 2 years and have never had a dropped connection issues with any device until I got the Quest, so I think this is much more an Oculus issue than a Orbi issue.  They really need to fix this issue with mesh networks!
  • JohSm67JohSm67 Posts: 165
    Open a support ticket with Oculus!

    Even if it’s a mesh system it should be able to Use different SSID’s
    (But i guess different vendors has their settings.)

    I didn’t open up a ticket as I found a way to get it super stable by creating an additional SSID for ”Oculus” devices that is dedicated on the closests AP’s and only using the 5GHz band

    But I guess it should be reported to be corrected!

    Temp workaround connect by another small cheap 5GHz router (in Bridge mode) if you cant change advance settings on them!

    The Netgear Orbi if you google it, it appears other Wifi drop issues with it.
    So I should also open up a support ticket with Netgear for it!
  • DapperDanVRDapperDanVR Posts: 1
    edited October 2019
    Is Oculus going to Fix this issue soon or at least acknowledge it? Seems like there’s a lot of people out there that have been having this issue for months and they haven’t done anything? Im an original Rift owner and was really excited for this headset but now I’m having to consider returning it.. WiFi dropping every 15-20 minutes is absolutely unacceptable for this product. I can’t complete a single online game without it disconnecting which makes half my library unplayable and those titles were the reason I bought the quest in the first place. This also definitely seems to be something on Oculus’s end since every WiFi network I connect to (all strong signals, no dropped connections) this still happens. Also This is a great piece of tech and I’ve already invested quite a bit of money into my Quest library but this issue ruins the online experiences which is why I bought it. It’s Really disappointing to see this from a company I respected and supported so much. Also worth noting I had a clunky right joystick with drifting issues right out of the box so A+ quality control there. Definitely not feeling like I got a $500 product.
  • Rawl_DrawRawl_Draw Posts: 1
    I've had the great luck of working with an ISP that gives users a separated 5 band channel so I could put there my headset, but it isn't the normal situation, and I was having same issues until I realized this (thanks to this forum and nothing else). Seeing the huge community affected by this for so long, I think it's a big, big shame for so big corporation.
  • JohSm67JohSm67 Posts: 165
    I don’t doubt that there is some issue with the wifi part on the Oculus!

    But Wifi and Roaming/Mesh and beamforming might also cause some issues!

    The Netgear Orbi seems to also have had some issues with dropping connections according to support notes in forums, also the Snapdragon 835 found in like Samsung S8 and Oculus Quest are mentioned to have had problems while other would work!

    There should be some kind of debug page on the Orbi that might reveal more about what’s happening?
    (Don’t have the Orbi my self..)

    • From browser go to the router's debug page ( Use your router's IP address or
    • Enter admin as user name and your router’s management password
    • Tick "Enable Telnet" option
    • Use Telnet from a computer attached to Orbi to connect to your Router telnet and enter admin and the same password as above
  • quantum-jrquantum-jr Posts: 1
    I have the same issue that others are reporting with Orbi mesh routers.  I will try some of the ideas presented above and report back if I have success...otherwise, just adding my voice to others frustrated with this issue.
  • kem423kem423 Posts: 6
    Brain Burst
    I used Telnet and was able to rename the 5Ghz and 2.4Ghz SSID so is hey were separated. It worked but only for my quest. The rest of the Orbi system wasn’t working anymore. My satellites would no longer connect and broadcast so I lost a lot of coverage in my house.  Ended up having to use telnet and make just the one SSID for the combined 5 and 2.4.  Really annoying.  Using my kid’s file hub to broadcast a separate SSID has worked.  We can have two quests connected to it playing together online with no dropping issues.  As soon as I try to connect to the main house network (Orbi) I drop wifi. This makes it near impossible to cast to my tv, which is on the Orbi network, for any decent amount of time
  • Hnter2200Hnter2200 Posts: 3
    edited December 2019
    Double post... my B. See below...
  • Hnter2200Hnter2200 Posts: 3
    edited November 2019
    I work in IT and can attest that the Oculus Quest absolutely is the issue. It should work with Mesh Networks that dynamically decide which Band it goes to. I have a Netgear Nighthawk XR500.

    When I read the first post I Separated my 2.4ghz and 5ghz bands by naming them differently and setting 2 different passwords for each. After this I set a static IP on the headset and then I had zero issues.

    Being mid-level IT, this issue is clearly either hardware (the network card being used), or... some sort of software issue the headset has with being told to switch to a different wireless band on a mesh network... using the exact same name and password for both bands to create “one” SSID.

    Every single time my network dropped on the headset it had a “Network Authentication” error... which never made sense for the reasons you all have listed.

    Routers that use this type of feature that intelligently decides which band that your device connects to is part of the problem.

    Clearly based off of some of ya’lls posts, Mesh networks are the future and not everyone that buys an Oculus Quest is a System Administrator... so this needs to be addressed for the general public instead of having them mess with their Router’s Web UI just to get a stable freakin connection to the headset, on what is supposed to be an “easier” home networking method via the mesh network.
  • Hnter2200Hnter2200 Posts: 3
    edited November 2019
    Just a side note to everyone here that isn’t familiar... if you separate your bands into 2 SSIDs, you are essentially creating 2 separate Wi-Fi “networks” so you have to re-configure every single device that connects to them. Not just your headset.

    It just seems a lot of you are having issues with your devices when you’re creating two SSIDs to separate your 2.4ghz and 5ghz bands.

    2.4 is better for a steady connection further away from the AP, and 5ghz is better if you’re closer to the AP. 
    (Just something I wish I knew at first when started messing with new networking stuff)
  • kem423kem423 Posts: 6
    Brain Burst
    If you have a mesh network such as a Netgear Orbi you will continuously drop wifi.  This seems to be the case with any mesh network because your device can bounce back and forth between 5 GHz and 2.4 GHz or if there are 2 5 GHz it can bounce selecting the best connection.  When it does this your Quest shows that the Authentication Failed and your wifi disconnects causing you to have to manually reconnect.  There is a workaround that I found and installed today.  An APP called SWIFI will allow you to force your Quest to always connect to 5 GHz so that it will no longer auto-swithc and you won't drop wifi.  You need to have your Quest in developer mode and install SideQuest and SideQuest Launcher.  There are lots of YouTube videos on doing this.  You then need an APK called SWIFI.  You can Google it and download the APK.  With your Quest connected to your computer and SideQuest open just drop the SWIFI APK you downloaded into SideQuest and it will install on your Quest.  From the Quest go to Library>Unknown Apps>SideQuest Home and you can then open SWIFI.  Turn on SWIFI by selecting the switch in the upper right hand corner.  Scroll down to the bottom of the screen and check the box next to Prioritize 5 GHz.  This will make your Quest always pick 5 GHz over 2.4 GHz no matter what.  I was able to run multiple games, online and offline and screen cast for the entire time with no dropping of my wifi.  Before it would drop every 5 to 10 minutes and I would have to reconnect.  I hope this helps.  GOOD LUCK and happy Questing.
  • h.r.gargih.r.gargi Posts: 172
    edited November 2019
    Wifi dropping still happens here with my Quest. I already devided 5GHz and 2,4GHz by their SSIDs. I have a Repeater within my MESH Network sharing the same Informations from the Router and the Repeater. Today I separated the Repeater from the Router and excluted the Quest from its list of known devices. For now the Quest has to stay on the primar Router wifi Network. Hopefully that will help. For me it looks like the Quest has a general problem to reconnect once losing WLAN connectivity.

    German Oculus Quest / Go / Link Facebook Group ... join us
  • SpuzzumSpuzzum Posts: 843
    I'm using a TP-Link T4UH wifi dongle, set as a 5GHz hotspot, 866Mbps, with no dropouts whatsoever. I also have it running on channel 144 though, but I get the same results with channel 40. A rock solid connection.

    Some things to consider though, are all the different wifi and bluetooth devices in your immediate area, and what channels they're on. Too many wifi devices on the same channel can screw things up, and bluetooth can interfere with wifi, especially the 2.4GHz band.
  • h.r.gargih.r.gargi Posts: 172
    Maybe really another device interfering with it. Since it is not every day it could be...
    German Oculus Quest / Go / Link Facebook Group ... join us
  • Viteok8909Viteok8909 Posts: 1
    I don't understand to much about what is happening but i  loose WIFI connection so often that is unplayable.
Sign In or Register to comment.