New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Touch Controller Blinking Constantly and Won't Pair

OcuBrettOcuBrett Posts: 2
edited July 2019 in Oculus Rift S and Rift
I had this issue with my left controller before and somehow got it to work after like 100 tries and after feedback from Oculus Support pretty much just having me re-install everything. They obviously didn't know how to fix this exact problem. Now the problem is back after a firmware update. After the update my headset worked worked fine, but the controllers wouldn't come on. I sometimes have to pull the batteries and then put em back to get them to show up, but that didn't work this time. I went into pair them, and my right one failed. So now, this is what's going on. When I even touch my right controller, it blinks. 3 fast blinks, 3 fast blinks and 3 slow blinks and continues that pattern.  When I go to pair devices, the left controller lights go off, I press the home and Y button until it blinks, let go and it pairs. Then comes the right controller. It's already blinking when pairing. When I press the home and b button, it fails. It then goes on to the headset where sometimes it fails and sometimes doesn't.

Update - I tried again when typing this up. When it came time to pair the right controller, I didn't touch any buttons on it. While it was still pairing, the light went solid. At that point, I closed down oculus. When I started it up again, I skipped the setup completely. Now it works. So there's the fix.

I'm curious what exactly that blinking sequence means on the controller and if there is a definitive way to fix it. I will ask support and update here if I find out.

One note in regards to the suggestions of reinstalling everything, that doesn't fix the issue with the actual controller which goes into this blinking state even when the headset isn't even plugged in. It's something with the controller itself that seems to get hung up. A reset of sorts would be great.


  • MilkJuic3MilkJuic3 Posts: 1
    I had the same problem when I first got my Rift S and found the same solution. It has now come up again after this last firmware update. I am almost 100% convinced Oculus has no idea whats wrong and hope that not talking about it will make the problem go away.
  • 1Jobe1Jobe Posts: 33
    Brain Burst
    edited November 2019
    Same with my right cntrlr. Cep,n it paired fine yet never finalised! Led white flashes blinky, fast, solid .. etc as in "code" but nowhere was an explanation. IR something wrong. Camera saw no lights from it there. Someone wrote they narrowed it down to headset failure and picked up a "new set". Luv it. Anyway purchased a used rt hand cntlr and voila, detects again. Saved a bundle.
  • IExclusive_v2IExclusive_v2 Posts: 1
    So how do we solve this issue? I literally just got one out of the mail today and it’s blinking not pairing and I’m getting irritated cause there’s no solution 
  • Umpa_PCUmpa_PC Posts: 835
    I had this with mine, and I think it was also the left.  I think mine happened because I was following the instructions to the letter.  Sticking both controller batteries in on command cause me problems (I think).  What I did was to let it all set up with the right controller - then shut down the PC, remove the battery from the left.  Make a cup of Tea, turn PC on, boot oculus fit battery, pair...
    Oculus Rift S - Oculus Quest 128GB
    MSI trident 3 7RB-200UK Intel Core i5-7400 3 Ghz x2
    MSI GTX 1050 Ti (4GB) & MSI Aero GTX 1060 OC (6GB) & MSI Aero GTX 1070 OC 8GB
    16 GB RAM x2, 1TB HDD x2, 1TB SSD x2
    Windows 10 Home Edition Version 10.0.18363 Build 18363, Oculus version 17, Quest Version 17
    Fan Cooling by Zotac FireStorm - AfterBurner cause me problems.
  • HatoroHibikiHatoroHibiki Posts: 1
    So how do we solve this issue? I literally just got one out of the mail today and it’s blinking not pairing and I’m getting irritated cause there’s no solution 
    I had the same problem with my Quest. But I finally solved it by unpairing it and repairing it in the Oculus Mobile App. Just go to the mobile app and press the setting button at the right bottom. Under your name and email choose your Headset. Press the controller setting and press which controller not working. Then unpair it. Repair it after that.
  • AeonBRAeonBR Posts: 1
    I had the same problem and i found a way to fix it, what you have to do is : close the oculus app, unplug your oculus device, open the task manager, locate :  OVR Redir, OVR Service Launcher, OVRServer_x64(or x32), and any other programs related to oculus, select and click "end task" on each one of them, then open the oculus app, it will say something about not finding an device, now you plug in your oculus rift (or rift s), and the problem will be fixed! (NOTE : Once you do this, try to complete the controller set-up as fast as possible, because i took a little long once i did it and my right controller had the same problem when pairing, if that happens to you, just repeat the process! hope this helps <3
  • DankWavesDankWaves Posts: 1
    my controllers wont even connect :'( heres a link to a vid i took of the problem https://  www  .youtube  .com/watch?v=Li8l_zl7bqQ
  • kalastadkalastad Posts: 3
    the right controller shows that it is connected but it doesn't show me the battery life %, and it is not working and i can't find it looking through the headset. 

    the right controller blinks three times when i insert the new battery then it never blinks again. 

  • jacksonmaxson1jacksonmaxson1 Posts: 1
    i am having a pair problem where my left cpntroller doesent evan pair it just blinks slowly  and the after a while it blinks fast then stops
Sign In or Register to comment.