New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Unable to install Skybox through Oculus Library

LightningRurikLightningRurik Posts: 8
For weeks I've tried to install Skybox through the Oculus game library for a Rift S.

When installing from Library it will download (150MB) then get to "Installing..." From there it'll wait about 10 minutes then pop up an error from the Store: "Sorry, we couldn't install SKYBOX VR Video Player"

If I go to the library and manually reinstall there, it'll pop-up a notification: "To continue, Oculus needs to install additional system software for SKYBOX VR Video Player" 

The Library will then show "Installing Required 3rd-Party Components...". It will then fail and say "Attention Required" 
The Library will then get stuck on "Installing..." until I manually restart the service.

In repeated tries it pops up the Windows 10 notification of "Sorry, we couldn't install SKYBOX VR Video Player. Visit Oculus Support to get help."

I've reached out to Skybox support, but this is ultimately an Oculus issue.


  • kojackkojack Posts: 7,228 Volunteer Moderator
    Have you had skybox installed previously? I know some programs (I've run into it with Beat Saber several times) will fail to install or update if there's any unexpected leftover files.
    Go into the C:\Program Files\Oculus\Software directory and then look in Manifests, Software and Staging, and delete any skybox files. There might be 2 skybox files in Manifests, a skybox-studio-skybox-vr-video-player directory in Software, and maybe something in Staging.

    I just went to install Skybox to test, it failed. I checked and there were leftover skybox files in Software and Staging. I deleted them and reinstalled, it worked fine that time.

    Author: Oculus Monitor,  Auto Oculus Touch,  Oculus Forum Tool,  Phantom Touch Remover,  Forum Dark Mode,  X-Plane Fixer
    Hardware: Threadripper 1950x, MSI Gaming Trio 2080TI, Asrock X399 Taich
    Headsets: Wrap 1200VR, DK1, DK2, CV1, Rift-S, GearVR, Go, Quest, Quest 2, Reverb G2
  • LightningRurikLightningRurik Posts: 8
    edited November 2019
    Great idea! 

    But little luck. I uninstalled the app and searched for all *skybox* files I could find and deleted/renamed them. Including the ones in Manifests. It still wouldn't install.

    I searched the registry and removed all references I could find, but still didn't work.

    I then completely uninstalled Oculus and reinstalled it, and it still wouldn't install, with the same error.

    At one point it was installed and working fine, then I uninstalled it and it wouldn't reinstall.

  • LightningRurikLightningRurik Posts: 8
    edited November 2019
    Update: I was able to install easily in Steam and play from there (though it stutters a lot...)

    So Oculus Library has the issue.
  • Posts: 37
    Brain Burst
    edited December 2019
    Update: I was able to install easily in Steam and play from there (though it stutters a lot...)

    So Oculus Library has the issue.
    Just saw this thread sorry.
    Do you still have issues with downloading/upgrading SKYBOX on Oculus store please?
    We sometimes encounter that too but one of the following three would help us fix it in the end:
    1. Restart PC
    2. Restart Oculus store (Setting > Beta > Restart Oculus)
    3. Change to another Wi-Fi
    Hope it helps in your case.

    Meanwhile, you mentioned that SKYBOX Steam version stutters a lot?
    What video do you watch (specifically what resolution / bit rate / frame rate)?

    We appreciate if you could share with us more details at [email protected]

Sign In or Register to comment.