New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Cannot transfer files to the PC from Quest

iN5OMANiACiN5OMANiAC Posts: 19
Brain Burst
I plugged it into my PC and pressed 'import pictures' and nothing, so I pressed file explorer and it jjust shows a blank drive on the PC. The Quest shows as portable media. I've been told you need to give permission on the Quest when plugged in, itnever asks me for permission

Things I've tried
Restarting the Quest
Restarting the PC
Uninstalling the Quest driver from the PC
Uninstalling the Quest as a device from the PC
Plugging the Quest in when switched off and turning it on while connected to the PC

Nothing makes a request for access appear on the Quest, nothing stops the PC showing it as a portable device with no media, nothing on it. (I'm using Windows 10 and USB C data cable)

Cna anyone please help?

Thanks

Comments

  • KlodsBrikKlodsBrik Posts: 1,201
    Wintermute
    Isnt there an option in Quest setting to allow unknown sources ?
     
    Be good, die great !
  • Shadowmask72Shadowmask72 Posts: 4,314 Valuable Player
    Did you activate developer mode on the phone app?


    System Specs: ASUS NVIDIA RTX 3090 TUF GAMING OC 24GB , i9 9900K CPU, 16 GB DDR 4 RAM, Win 10 64 Bit OS.
  • iN5OMANiACiN5OMANiAC Posts: 19
    Brain Burst
    Did you activate developer mode on the phone app?
      I did yes, should I deactivate it?
  • iN5OMANiACiN5OMANiAC Posts: 19
    Brain Burst
    KlodsBrik said:
    Isnt there an option in Quest setting to allow unknown sources ?
     

    Its not that, thats for installing APKs
  • iN5OMANiACiN5OMANiAC Posts: 19
    Brain Burst
    I just fixed it in the most ridiculous way
    Someone on reddit made a program called open store VR
    I started that and plugged in the headset, it asked for permission for that app on the headset and when I pressed yes it allowed the whole PC

  • MetrogenicMetrogenic Posts: 1
    NerveGear
    I just fixed it in the most ridiculous way
    Someone on reddit made a program called open store VR
    I started that and plugged in the headset, it asked for permission for that app on the headset and when I pressed yes it allowed the whole PC

    This did it, somehow. I wasn't getting the blue button, just like you. I guess I had to prompt the PC to try to contact the headset before it worked? That part wasn't listed in any docs I've read. Very curious to know how many people are going to have this problem.
  • OogieBoogie0000OogieBoogie0000 Posts: 5
    NerveGear
    Did have the same issue - "no acceptence" message. But somehow installed the Open Store VR and now see all the Oculus Quest folders. Not sure how it worked, but it worked. Big thanks!!!
  • VR_Player_1VR_Player_1 Posts: 2
    NerveGear
    turn off developer mode and follow these instructions

    https://support.oculus.com/2255729571307786/
  • SpuzzumSpuzzum Posts: 843
    3Jane
    iyksmann said:
    turn off developer mode and follow these instructions

    https://support.oculus.com/2255729571307786/

    I was going to suggest using the ADB terminal to connect to the headset, as that's what works for the Go, but the link you provided is so much easier.
  • lancewlarsenlancewlarsen Posts: 1
    NerveGear
    edited June 2019
    Same issue SOLVED by simply turning off "developer mode" via the Oculus phone app, and then re-connecting USB. 

    Worked for Oculus Quest (had same issue previously with Oculus Go). 
    Would be lovely if Oculus would fix this -- shouldn't be the case.
  • hootie976hootie976 Posts: 2
    NerveGear
    iyksmann said:
    turn off developer mode and follow these instructions

    https://support.oculus.com/2255729571307786/
    This fixed it for me as well, immediately.
    As soon as I turned off Developer Mode in the Oculus app, my Quest prompted me to Confirm the connection. I clicked Confirm and my computer issued the "connected device sound." I was then able to copy files to the Quest via drag & drop on my Windows 10 PC. Thank you @[email protected]
  • DragonX5DragonX5 Posts: 1
    NerveGear
    I record some escenes frommy game but I cannot find them on my Quest carpet...
  • jonrummeryjonrummery Posts: 3
    NerveGear
    Disabling 'developer mode' on the Oculus app solved it for me too. Totally the last thing I would have tried!
  • chillpandachillpanda Posts: 5
    NerveGear
    Sorry to bump an old post but this was intentional to highlight the resurfacing of the OP issue. I had no problems connecting my Quest to my PC and transferring files up until 2 months ago with the latest update (with files on my Quest dating the latest as 8/28/20 which was when I was last able to transfer files, with developer mode still on). I experienced the exact symptoms described here without any changes to PC, drivers or USB C cables.

    The only difference or bit of information I'd add is that I could still successfully use Oculus Link but could no longer access the Quest through explorer for file transfers.

    Interestingly enough, I could not find Open Store VR that others mentioned however, without fail, disabling developer mode enabled the MTP function. Whereas, the provided link of manually updating the driver and changing it to MTP wouldn't work as Windows did not list the specified MTP device driver as an option and selecting the exact file kept producing an error of making sure the file was designed for 64 bit systems.

    In any case, this is well over a year later and it seemed (at least from my perspective) to be a resurfaced issue that was both time-consuming and frustrating to have to resolve. In the hopes of developing an app for Oculus, I now recognize I'll have to manually turn on and off Developer mode just to transfer files. It may also be worth noting that with developer mode on, ADB couldn't detect the device properly and the only thing that seemed to work was Oculus Link. Perhaps it has to do with coding of the new beta version for Oculus Link or changes made to adapt functionality with Quest 2? Who knows, just thought I'd mention the issue returning for me and thank everyone's input that helped me personally resolve this issue.
Sign In or Register to comment.