New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Oculus Rift S, audio cut out after visual glitch

LatonexLatonex Posts: 2
I've got my Rift for a few months now and it worked flawlessly until a few weeks ago. After a random amount of time my Rift S would glitch for a second and then the audio cuts out completely even for anything else on Windows. Only after I restart the Oculus Software does audio work again. 
I've tried several methods to fix this. Like changing USB Ports, Using a Hub with external power source, Oculus Tray Tool, Settings to "ultimate performance" so the power to any USB port won't be cut, ....
I've searched dozens of forums but just can't find the issue and it's getting really frustrating.
I hope anyone can help me with this. Thank you!

Windows 10
RTX 2070
16GB DDR3 Ram
ASUS Z170-P D3 Motherboard


  • LatonexLatonex Posts: 2
    Another thing is that whenever the audio crashes OVRServer-x64.exe seems to crash as well according to the windows Event Viewer.
  • AnolCorzairAnolCorzair Posts: 4
    edited February 11
    Have kind of the same issue but can't get back audio untill restart my pc. Also I haven't tried to restart the audio driver.

    This probably can go from windows 1909 version but Im not sure. Tell me pls which one you use. 

    Also please notice me in this topic if you find a way to solve it.
  • HardGlockHardGlock Posts: 6
    @Latonex and @AnolCorzair I too had this issue.  I noticed that my RAM consumption was getting very high before the issue occured.  (I had 16GB of RAM and it was using all of it.)  So, I doubled my RAM and the issue went away.  That said, the other stupid thing I noticed is that my 2400mhz RAM was only running at 1333mhz, and after correcting that my RAM consumption wasn't going past 13GB anymore, so, a bit of a double whammy on my end.  That said, check your RAM.  Leave task manager open on the RAM tab while you are playing and when the glitch occurs pull the headset off and see if your RAM was maxing out.  Fixed it for me, this was happening to me all the time.
Sign In or Register to comment.